Fibaro Dimmer 2 S2 not working consistently

This may have been discussed before but I have no idea what terms to search for to find it so apologies i this is a repeat question!

I have 4 Fibaro Dimmer 2s, 2 in one 4 gang switch and 2 in another 4 gang switch. Configured so that each Dimmer directly controls a set of lights and has S2 set up to trigger a Dimmer in the other switch via Zwave associations.

They’re in 2-way (i.e on/off, not momentary) switches and configured as such (Paramater 20 Switch type is set to toggle switch). The direct control of lights works perfectly.

If I turn off the lights through the app, or via google home for example, they don’t seem to sync up the status. Then, when I use one of the S2 switches to try and turn them back on I have to use the switch twice to get the desired result. It’s like the first press thinks it’s setting it to off but it’s already off, and then the second press set’s it “back” to on.

Combined with the slight delay on activating the remote Dimmers this makes for a frustrating experience, you press the switch and then wait to see if it’s going to come on or not, then potentially have to press it again.

Has anyone experienced the same and am I missing something obvious in the Zwave parameters?

Switch setup in case it makes any difference:

4 Gang 1
Switch 1 - Wired to Dimmer 1 - Controls Load 1
Switch 2 - Wired to Dimmer 2 - Controls Load 2
Switch 3 - Wired to Dimmer 1 S2 - Controls Dimmer 3 (Load 3)
Switch 4 - Wired to Dimmer 2 S2 - Controls Dimmer 4 (Load 4)

4 Gang 2
Switch 1 - Wired to Dimmer 3 - Controls Load 3
Switch 2 - Wired to Dimmer 4 - Controls Load 4
Switch 3 - Wired to Dimmer 3 S2 - Controls Dimmer 1 (Load 1)
Switch 4 - Wired to Dimmer 4 S2 - Controls Dimmer 2 (Load 2)

What are you using in your 4 way setup, just the relays or Smart Lighting as well?

Look at the live logging when you do the command from you Google Home, then you would might see some error/debug message what can show you what is the problem.

Just the Dimmers, using “association group 4” and including the Device Network ID of the target Dimmer.

Had a quick look at the events list in the IDE for last night when I turned them off from the google home and not seeing any errors.

Does Smart Lighting let you trigger actions through S2? Might be worth a try to see if that’s more reliable but presumably that will operate through the cloud rather than locally?

There is a parameter 22 that either changes the status or synchronises it with the switch. Yours should be set to 0. I also think parameters 24, 25 and 26 should be 0 for your setup.

Un fortunately you cannot use S2 with smart lighting. There only option is to use the Scene ID function with webcore.

I am talking about live logging, not the event list. Is there any chance that the Hub receives a message what is unhandled, and so the Hub is unaware of the current state of the switch.

I have checked and parameter 22 is set to 0. I did try changing it to 1 a while back but it didn’t seem to alter the behaviour in any way. Parameters 24, 25 and 26 aren’t set so I assume they default to 0. I could try setting them but think I have to switch to a custom DTH to access those settings?

I think I started reading up on Scene ID and webcore and decided that was an avenue I didn’t have the time or energy to explore at the moment!

With regards to live logging, I’ll try it when I get home and see if there’s anything unusual in there.

Thanks for the suggestions so far!

Try setting parameters and testing with this DTH. Then switch back to the official one for local operation when it’s working.

So I’ve used the DTH provided to change all those values to 0. I’ve also tried parameter 21 in both states as it says that controls whether to send current state or last known state. Nothing seems to have changed unfortunately.

I’ve looked at the logs, and I can see some but not all of the actions. Very strange

  1. Switch on the remote load from Dimmer 1 (as per above) - shows in logs
  2. Turn off via Google home - shows in logs, several entries sending commands and confirming status
  3. Press physical switch to turn lights back on - nothing happens, nothing appears in logs
  4. Press physical switch again - light switches on and appears in the logs.

I’m thoroughly confused!

Isn’t that a switch configuration issue then? What type of switch are you using? What is your setting for it in the relay?

I would think, that you haven’t set that up correctly that is why it doesn’t register the switch event.

As mentioned above it’s a toggle switch and configured as a toggle switch. S1 is behaving like a toggle switch - working perfectly. S2 behaves like a toggle switch as long as the light hasn’t been turned off using the smartthings app originally Google home.

If there is a separate setting for S2 switch type I can’t see it?

This does seem odd. These dimmers were designed to work with a momentary so maybe this is a bug.

I’ll try to set one up at home tomorrow and test. For now you might have more luck on the Fibaro forum.

@Mjombly, I would check on the Fibaro forum as @siwilson advised. I’ve look at the manual, and you are right, there is no separate parameter for S2 switch.
But regarding Parameter 26, I would think that should be 1 - 3-way switch function for S2 enabled, but it is not really clear for me, what that functionality really means.

Thanks, will post on the fibaro forum and see if they have any ideas. I appreciate you taking the time to look into it though!

Regarding the 3 way switch option, my understanding is that it’s used when you have 2 physical switches controlling the same load (e.g top and bottom of the stairs). It means S2 is wired to the second switch and controls the same load as S1.

I connected up another Dimmer 2 and programmed S2 to operate another of my lights (Fibaro FGS-223) via direct association. I had this setup with a momentary switch and then a toggle switch. I can’t see much difference in the behaviour between the two. However, its not 100% reliable with either. I think it just loses the Z-wave message somewhere. Interestingly, I can see that neither have any route entries and are likely communicating through the hub. Maybe this is the problem?

Thanks Simon, maybe you’re right and the Google home thing is a red herring and it’s just that it’s losing some messages along the way. Not sure how I go about stopping that though. I assumed they were communicating directly and bypassing the hub.

I appreciate you taking the time to recreate the set up and the problem!

Thinking of swapping them all out for Aurora Aone dimmers but I’d need 8 and the cost would be prohibitive.

I am sure they do try to communicate directly. However, Z-wave is a mesh so the message has to follow the established route(s). The message could well go through one or more hops along the way. in my case (although its hard to tell given the diag info I have) I believe the hub is the middle hop between my modules. It could be that the hub is dropping the message.

If that’s the cause then I am not sure if other vendors modules will behave any differently.

I tried again last night. Certainly if I flick 2 switches at the same time or very close then one of the messages gets lost. I can still consistently recreate the problem with Google Home though so I don’t think that is a red herring. About to post on the fibaro forum and see if I get anywhere!