Fibaro Dimmer 2 Integration

If you’re struggling, @JDRoberts ’ FAQ is worth a look:

Edited to add - this is a device handler rather than a smartapp, just in case you’re trying to create a smartapp with the code.

That’s what I was doing! Thank you. I will try Rajiv’s code. In a previous post you mentioned you commented out a parameter. What does this mean? All I need to do is make S2 work and both on momentary switches.
Many thanks

There’s a parameter section in the manual for the module, well worth a look over as it explains a lot about what it can do. Previous to Rajiv’s code, it was necessary to go into the development interface to set (or comment out) parameter settings.

Now these can be accessed directly through the ST app on your phone (cog icon). You will need to play around with these to get S2 to do what you want it to do.

I will have a read through that tonight. Could you just tell me, the cog icon just takes me into a section that says the device name and ON, then Give your device a name and the name again and then two buttons saying replace and remove. Am I looking at the right thing?

You’re looking at the right thing, although it doesn’t sound like you’re using Rajiv’s code (or at least the most recent variation) as there should be a lot more in there.

Sorry! I’m getting my devs confused. Rajiv made the original, it was @hajar that made the much improved version.

Here you go…

Thanks for your help. Still working through it all but I feel more knowledgable than I did yesterday so it’s going the right way!

Hi, any news on the official ST certification on the Fibaro Dimmer 2? - I have the latest SmartThings Hub and the Fibaro FGD-212 installed - but not sure how to pair it to my hub as there is no such device listed in the app. Have others got this working? How do you pair it up?

1 Like

I discovered that you can pair the Fibaro Dimmer 2 through flicking the light switch on/off three (3) times - whilst selecting the clicking on “Add a thing”, “Start looking for Things” … and eventually it paired. This is great to know as the unit was installed behind a wall and not easily accessible.

Hi,

I have installed three (3) Fibaro Dimmer 2 (FGD-212) switches in my home.

Number 1 dimmer is in my front room
Number 2 dimmer is in my hall (with immediate <1 Meter proximity to dimmer 1)
Number 3 dimmer is in my master bedroom (top of stairs) ~15 Meters away from the hub controller

I am using a Smartthings Hub 2 controller.

All devices have been found/discovered and are paired to my Smartthings hub and visible on my Smart phone app.

All devices operate (on/off/dim) as expected using the physical switches connected to the dimmers, so they are all fully functioning as expected.

I can connect to and control dimmer 1 from my smart phone via the Smartthings app and I have full range of control and dimming as expected.

When I view the logs on my account I can see clean messages being sent during successful operation.

e.g. 7:35:38 PM: debug UNHANDLED COMMAND Crc16Encap(checksum: 6, command: 5, commandClass: 49, data: [4, 34, 0, 122, 166])

However I CANNOT control dimmers 2 & 3 at all via the Smartthings app (they are simply unresponsive to any control commands sent to them - e.g. on/off command or dimming level commands).

They are all installed (wired) identically in line with the first dimmer (1).

When I check the logs during attempted operation on these additional dimmers I get a security error:

e.g.:
7:31:46 PM: debug UNHANDLED COMMAND SecurityMessageEncapsulation(commandByte: [0], commandClassIdentifier: 38, commandIdentifier: 3, reserved13: 0, secondFrame: false, sequenceCounter: 0, sequenced: false)

So I am getting a log entry for each of these additional dimmers that are attempting to respond to my commands - they just simply are not working. At least I know that they are paired AND communicating with the Hub.

Any ideas how to resolve this? Could it be a firmware difference on the other dimmers? How can I check?

Note: This is not a range issue as I have physically moved the Smartthings Hub 2 to be in range (beside) each of the installed Fibaro dimmers.

Thanks

Ciaran

1 Like

Hi, just an update to this. Thanks to this Community forum I have managed to get my devices to work. All the answers are in this great forum, it just takes the patience to read it through. So to answer my own question - the unhandled commands can be handled by creating a “device handler” for the unsupported Fibaro Dimmer 2 device and then altering the code (in my case a single digit) to get it to function the way I needed it. It’s not as scary as it sounds - all the help is over in this thread, so apologies for my newbee question above, and good luck to others that have this experience. Fibaro 2 Dimmer (212 not 211)

First post and I’m kicking myself because I found my way through the difficult bit without having to ask any questions that had already been asked/posted!

Last night I finally got my Dimmer 2 working both via the app and using the existing toggle switch - Worked like a dream after using Rajiv code!

Today I have returned home with a momentary rocker switch and larger back box… fitted them, works on the app but not on the switch. Tried the old switch - Nothing. Changed the code to allow for momentary switch (param 20 = 0) and but still nothing.

Any help would be fantastic please.

oh also tried calibrating just incase.

FYI - Once working this all works SOOOOOOO well with Alexa! Just need to stop my 3 yr old turning lights on and off now:rage:

reset the dimmer to factory default and the switch works. paired the dimmer once again with ST hub and linked it with the code… lights turn on/off with the app but only turn on with the switch now.

Are you using a 2-way momentary switch/roller blind switch? Just make sure you’ve set the right param. Sounds like the input on S2 is being ignored, if you are using a 2-way.

No a 1-way normally open press to close switch, I think I was the problem and was adjusting the wrong digit in the parameters…

zwave.configurationV1.configurationSet(parameterNumber: 20, size: 1, scaledConfigurationValue: 0), // Enable Dimmer to work with 3 Position Momentary Switch

I was editing the size rather than the value. What does the size refer to? I assume the text after the // is a side note and not a command?

Sorry I don’t have much experience with coding. Thank you for your input

some problem here nutter. Do you have a solution already?

Just bought a Fibaro Dimmer 2 (212) and made a device handler, inserted this code:
https://github.com/codersaur/SmartThings/blob/master/devices/Fibaro%20Dimmer%202%20(FGD-212)/Fibaro%20Dimmer%202%20(FGD-212).groovy

I have wired the whole think like this:

I probrably have to set some parameters but can’t find the right ones. Somebody know what the problem is?

Hi @Arjan_Pas, did you get this sorted or do you still need help?

If you are using a “1-way normally open press to close switch”, that would be described as a Momentary switch in the Fibaro docs.

Also, FYI, I just updated the code today for the device handler you are using. It now supports full parameter synchronisation, multi-channel device associations, protection modes, fault reporting, and advanced logging options. :grinning:

See here:

1 Like

@zcapr17 thnx! Turned out to be a broker unit. I’ve got It working now.
Thnx for the reply anyway :thumbsup:

Hi - hoping someone could help me with a Fibaro 2 Dimmer config issue in the new SmartThings app. I want to configure S2 to trigger a Scene or an Alexa routine but cannot work out how. I have tried publishing the device handler above but my app seems to be stuck to another older device handler I had published before reading this thread that only offers some of the parameters for customisation. If anyone could help I Would really appreciate it

Hello all, Im using a Fibaro dimmer 2 to control 3 LED pendant lights. Using the brilliant device integration available here, i have set the options i want and run an auto configuration. Im doing an install at the light/ceiling rose side of the circuit as there is a permanant live and neutral.

The three bulbs, Dim fine when going off, but dont dim up when coming on. Also they stay lit when off just a touch. I was under the impression that I dont need a bypass when you have permanant Live and Neutral, only when you have the nutral through the light which keeps the fibaro on even when the switch is off.

Am i wrong and you need the bypass any time the load is too low ?