FAQ: How to troubleshoot mobile phone presence issues

It sounds like you have things under control, but let me know if I can help with anything related to SharpTools! Feel free to tag me here (@joshua_lyon) or reach out using “Send Feedback” from within SharpTools.

Ahhh I did not realize you were the SharpTools Dev, very cool :slight_smile: Great app! I’ll get in touch with you if I have any questions or problems. Thanks!

1 Like

Oh BTW (off topic), one of the other use cases for SharpTools that I’m planning is to add a layer of security around NFC tags. I started playing with these last week using the Maker channel on IFTTT but anyone can open the URLs and trigger the “that” in IFTTT that way. Alternatively, having the NFC tag trigger a Tasker task that uses SharpTools to do ST actions means that only specific phones can trigger thr NFC actions. So another thumbs up there :slight_smile:

1 Like

Would it be possible to post some pics of your profiles & tasks? I’d really like to get a grasp on using the 2-tier location methodology. Thank you!

(I’m using “Wi-Fi Near” for actual presence and it’s been mostly good, but not good enough :slight_smile: For several months I’ve also used Autolocation in parallel, i.e. just sending notifications so I can compare it to Wi-Fi Near. I can’t say I’ve observed any qualitative difference.)

I have been out of town and unable to test the two-perimeter setup so far. Headed home this morning. Once I test and get something that works well I was planning to start a “how-to” thread since I haven’t seen one yet. Give me a day or two and I’ll try to put something together.

1 Like

I created a new how-to thread for this:


Great, so far. Thank you. Looking forward to the next installment.

Sorry for jumping the gun, but does this

mean that loss of Wi-Fi Near won’t trigger AWAY all by itself and that a subsequent confirming move outside the close perimeter has to happen before AWAY is set? (This has been my biggest issue, such that I implement a timer when I lose Wi-Fi Near that counts down before I actually set AWAY.)

1 Like

Correct. This requires an “or” capability, which Tasker doesn’t have for some reason. There’s a workaround, however, using three separate profiles and the %PACTIVE variable, which gives you a comma separated list of active profiles. The Cliffs version is to create one profile that activates when you connect to wifi (Home-WiFi). If you don’t have any specific actions for this, you can add a short wait as a dummy task. Create a second profile that activates when you are inside the inner perimeter (Home-Location). Then create a third profile (Home) that activates when variable %PACTIVE matches [asterisk]Home-WiFi[asterisk]/[asterisk]Home-Location[asterisk] (replace [asterisk] with * ), where the asterisks are wildcards and the slash is an “or”. This tells Tasker to activate Home profile when either Home-WiFi or Home-Location is active. Then tie your SharpTools present/not present action to this Home profile.


Created a how-to thread here:


Hi everyone

This is my first post, please apologize me if some rubbish come out from my mouth.

I read everything and i want to tell you my experience.

I use geofancing to perform my alarm arming.

So i setted up the preinstalled routines ‘I’m Back!’ and ‘Goodbye’.

I have 3 cell phone in those routines, Goodbye say that everyone lives move to away mode, I’m back says that the first come back move to disarmed mode.

All ok but sometimes some cellphone result at home but in real is 40 km far.

It happend to my son first than my wife. I just remove them from presence mobile sensor and put them again inside and start to work again.

This morning got the same problem so i spent sometimes to make some test.

The cellphone result home but i’m 40 km far. What i did?

I tried to fix my location, reboot, logoff from the app, switching off everything with any result. The cellphone was at home again.

So my last chanche to update the status was to remove the device , but i decided to make the last test.

I hust remve my phone from the routine ‘I’M BACK!’, what has happened?

The status of my cellphone was NOT PRESENT.

I add again the cellphone on the routine and correctly i still result as not present.

My conclusion is that we have to find the guilty somewhere in the routines.

Hope it help somebody to fix the problem



You don’t say what you are using to determine presence. I suspect that’s the main problem. The native SmartThings phone presence is notoriously erratic, hence thus thread and the various fob or Tasker solutions.

The solution by @destructure00 is a great solution that balances power and accuracy. If you’re not using it, it’s worth the learning curve.

Hi this is not a solution is a workaround, suppose it working i can provide myself but not other cellphone in the family.

My family member has ST app installed with silenced notification because they think is boring stuff.

So i don’t want to follow this too much comlplicated steps.

I do prefer to investigate much better as possible and help the team to fix the bugs.

That’s my opinion

If you are using Android, try these things:

  1. Set location mode to High Accuracy in your phone settings
  2. Set Optimize Wifi to disabled in your advanced wifi settings
  3. In battery settings, remove SmartThings app from battery optimization
  4. Set Wifi scanning to always available in your advanced phone settings

Depending on phone model, some or all of these may be available. I’m missing 2 and 4 in my Droid Turbo 2, but my wife’s HTC M9 has all available. Her phone was pretty bad with location reporting, but has gotten much better after changing these settings.

My problem is at the opposite.

The ST continue to see present the phone but the phone is very far… I have no problem joing the network but escaping

Why can’t smarththings just see when your on the network hence your home. In so annoyed with erratic presence sensor from both my and wife’s phone

1 Like

Maybe others have seen this but my mobile phone presence for myself and my wife have become rather unreliable. After reaching out to support, they insist that the only factors determinative of presence are: (i) the GPS location on the phone and; (ii) the app and the location assigned within the home (ie. home address and geofence).

Over the past 2 weeks I have watched my mobile presence do all sorts of weird things that usually culminate in a device (either mine or my wife’s) departing at some random point in time and returning at another random point in time.

For example, yesterday my wife’s phone left the house at 11:30:42 only to return at 11:31:11. Now she was not gone for 29 seconds but this caused an avalanche of things to occur (I know I can eliminate those things with false alarms). However, last night my wife’s phone left the house at 10:45pm only to return at 3:30am. More so, my phone left at 2:30 and when I awoke this morning it was still gone. With the exception of me waking up and picking up my iPhone, nothing changed nothing moved yet ST believed we left the geofence.

I can recreate the event with wifi on or off on ST. I also have both Nest and August and netter app shows either device as leaving the home and both are setup independently to perform tasks when the user leaves a Geofenced area (or address).

This is a ST app issue whereby something is causing the app to communicate to the hub that the user’s device is no longer present on GPS.

Has anyone seen this before? I have read several posts about users leaving and not being present on ST when returning, but I have yet to see a person report their device will just declare itself no longer present when not moved or disturbed.

Also, for clarification, I have removed the apps from both phones, I have wifi on and off, I have location on always I am not in ‘Low Battery Mode’. I have changed nothing which would cause a phone resting on a nightstand idle for several hours to declare itself no longer present and then present again.

Happens to all the phones (iOS) in my house all the time. I finally solved the issue by following @JDRoberts strategy of using CoRE and multiple sensors (in my case iPhone, Life 360, iFTTT & a motion sensor) to set a virtual switch for each person’s presence. It’s seemed to really help smooth out the ST issues with device presence.

1 Like

This feature seemed to work fine for me when I first got my SmartThings over a year ago. Granted I didn’t pay as much attention to it back then since I didn’t have much, if anything, trigger when I was present or away. Now that my home automation has expanded I would really like this feature to work properly.

It appears that it just doesn’t work, ever. My devices are always away at all times. I have reset the phones to factory default, verified that all permissions are granted to the app, adjusted the size of the geofence, made sure it is always on (ignoring low battery or battery conservation), and reinstalled the app dozens of times. When I reset, it will usually show that my phone is present (usually), but when I leave the phone changes to away and never comes back.

My GPS is solid. I can go the geofencing page and see my location in the geofence yet SmartThings still shows my phone away. I reset all three of my families phones applications while away at a family dinner over the holidays. Two of them came back away, the third show that it was present. To add insult to injury, my whole family runs on Samsung phones.

Please make a wifi option for this app until you can fix whatever is wrong with the geofence method.

i had a similar problem with my wife’s samsung s6 edge… seems to have gone away when we switched to an iphone 8.

am not sure if android is fully supported but you may want to check Webcore presence sensor?

i have the same problems ,the entire platform is a dumpster fire
nothing ever works with it , reliability is worse than a crap shoot much less than 50/50
presence never works and lights go off line all the time , HUE worked fine until i integrated with ST
i should have just learned how to to use home assistant or openhab or some other much more complicated platform with this we have no control and the reliability sucks