SmartThings Community

EZMultiPli (aka HSM200) Z-Wave Plug-in Multi-Sensor Officially Approved SmartThings Device

Tired of changing batteries? Looking for a great plug-in multisensor? EZMultiPli (aka HSM200) is now an officially approved SmartThings device! Multi-Sensor: Motion, Temperature, Luminance. Never needs batteries! Wall powered! Z-Wave range extender and color LED can display the weather or if your garage doors are open or any other state you want. Read “How-To use EZMultipli (aka HSM200) with SmarThings – Tips and Techniques to get the most out of it.” https://drzwave.blog/2017/04/27/ezmultipli-how-to-for-smartthings/

2 Likes

Do you know what is the operating temperature of this device? Need one for the attic, which can get very hot.

Found it:
Operating Temperature Range: -20ºC to 80ºC

What I like most about this EZMultiPli is that I think I can use it as a basic SmartThings status indicator – red for alarm armed, green for not, and other colors in between. It’s other capabilities don’t add much when used in that role, except for maybe the motion detection fits with being armed.

So I like the product, and I’ll probably buy more to put near my home’s alarmed doors, but I’m having trouble making sense of its LED color controls within the SmartThings environment. Could I be seeing some kind of software bug defect or some kind of hardware (manufacturing or design) defect, or am I doing something wrong with using it?

Let me explain: In the Device Handler, I’m offered a plain white on-off button control for the LED but also a color wheel icon within which there are 11 color “on” buttons – 4 shades of white and 7 others. But something seems a little off. The whites all look the same to me (I didn’t try to tell them apart). Yellow, Red, Green, and Pink make the LED glow the color I’d expect, so that’s good (very good because red, green, and yellow are the most important colors). But pressing Orange gives a yellow light, Purple gives hot pink, and Blue gives light aqua. There’s also a sliding control that seemed like it could offer other colors but I never got that to work as reliably as the color buttons.

Then there’s also SmartApps. The LED can be used via automation. The SmartThings SmartApp that made the most sense to me for this was the one under Lights & Switches called “Smart Lights”. I tell the App I want to control the EZMultiPli, that I want to “Turn On & Set Color” and I get to pick a color and a dimmer level, doing this when Mode Changes to a particular mode (e.g., Home, Away, etc.). For this, I’m offered 4 whites (again, I didn’t try to distinguish them) and 7 colors. The Red, Green, Blue (strong blue), Yellow (greenish-yellow), and Pink (hot pink) were all pretty good. But Orange made the LED glow yellow (greenish-yellow), and Purple made it glow hot pink (the same as the Pink option). I’m confused. I would’ve liked Orange to look orange and purple to look purple. Oh, and I’m not sure the dimmer control did anything – I tried a couple at 80%, 100%, and 20%, but for the couple I tried didn’t seem to make any difference.

I’d appreciate some help getting the last couple of colors to show up as their names say, or an explanation for why I’m having so much trouble with a couple of them.

Best regards,

Craig in PA

Although the official device type handler gave you a color wheel, and the Amazon product description doesn’t fully describe the product, this device only offers seven colors. When you choose a color like orange or purple which is not one of those seven colors, it’s just falls back to one of the others. Also, it is not dimmable. You can see the available colors on the manufacturer site or at the Dr. Zwave blog link from the first post in this thread.

https://www.expresscontrols.com/products

Also note that they count the “off” state as a “color.”

White, Red, Green, Blue, Aqua, Yellow, Pink, Off

So it sounds like the device is working correctly for you, it’s just that the app is letting you choose colors that are not actually available for that device.

JDR,

Ahh, yes, that is very helpful. So the hardware doesn’t support "Orange or “Purple” even though the Device Handler driver and SmartApp mistakenly offer those, and the “Blue” offered by the Device Handler driver seems miscoded to invoke aqua (blue+green) in the device. I wish the ST implementation of this device announced those discrepancies or fixed them.

Maybe the underlying cause is that the DH and SA are based on generic color control templates that assume each of the R,B,G LED’s can be set for a lower intensity (dimming), but the hardware only supports full on or full off so it’s not even possible to produce Orange or Purple??? If so, Orange and Purple should be removed from the DH and SA list of colors (not to mention any mention of dimming) and the Device Handler should be fixed to have Blue code for just blue instead of aqua (blue+green LEDs) … and maybe also disable the infinite spectrum color wheel?

“DrZWave” (Eric), are any corrections to the “officially approved” code planned? It should at least be very simple to fix the DH driver to make Blue invoke blue instead of aqua (and almost as easy to remove Orange and Purple from both the ST DH driver & SmartApp).

Best regards,

Craig in PA

1 Like

I’m not sure I can make changes to the device handler now that ST “owns” it. I’ll see if someone in ST can answer that.

The color wheel is a standard component in ST as are the 11 buttons. Why 11 I’m not sure. But the EZMultipli only has 7 colors (and off which is the 8th color) and is not able to dim at all. Each of the 3 LEDs (RGB) is either ON or OFF.

1 Like

Thank you for replying, DrZWave. Very much appreciated.

BTW, given success with use as a system status indicator light using at least some colors, I ordered more of them. (I have 5 so far – I hope they play well together unlike the 1st generation ST outlets that had a red/green LED and got confused when more than one was switched at the same time.

Thanks,

Craig in PA

Echoing the thanks here for all the work in getting the HSM200 supported in SmartThings!

I’ve managed to get the motion sensor, luminance, and temperature sensors working but what doesn’t seem to work is the LED. I used to use it on my ISY as a motion sensing night-light, but in SmartThings, the LED won’t turn on and stay on. What I think is happening is that color #ffffff is being written to the device immediately after the color I want is written, at least according to the “Recently” tab. The tile that turns on the LED also does the same thing. All I see is a little flash of color and then it is gone.

Any ideas why/what might be causing this?

Thanks!
Oliver

1 Like

Unfortunately I don’t have any insight on what ST is doing. They are updating a lot of drivers and the EZMultipli is expected to be one of them.

They send a color_switch_Start_level_change and then a STOP which is an odd way to set the color but it will work. I suppose other Z-Wave bulbs work that way and they just reused the code for EZMultipli which fortunately will operate correctly with this set of commands.

My ST system works fine. I can set the colors and all is OK.

Eric

Has anyone figured out a fix. Mine used to turn on red when the garage was open after sunset. Now it won’t turn on red. It turns on white. I can set the color manually in the app but whenever the garage is open after sunset it’s white instead of red.

1 Like

Also having the same issue Gavin is (will only turn on white via smartapps- used to be red)

I ended up using webcore and it works fine with webcore. I noticed the specific lighting control I was using was cloud based anyways so switching to webcore was not a problem.
I do find it odd that webcore can turn it on red but smartthings can’t.

1 Like

Same issue as you guys, had a standard Smart Lighting automation to turn on red when it sensed motion at night, worked for a long time and then started turning it on white instead of red. Will try WebCORE, thanks for the suggestion, really hate that stuff like this just mysteriously stops working.

1 Like

Can we get a copy of device handler
I needs to.modify so that you can choose temp in apps. Apparently there is not full temp capability.

I got an HSM200 a few days ago and I cannot get it to function correctly. For some reason the motion detector triggers every 6 minutes regardless of motion. See the pic below. Any ideas? I have tried not the default HSM handler as well as the DrZ one. Thanks!

That just looks like a temperature report, not a motion report. Is it actually triggering a “motion active“ automation?

Thank you. I accidentally attached the wrong image. Here it is with no one in the house

This time of year it’s usually the heating system, but there are some other possibilities. See the FAQ (this is a clickable link)

Thought I would post this. I’ve created a webcore 2 pistons that I think accomplishes what everyone is looking for.

This is the link to the pistons. However, be warned, the LED flash color notifications do not work well with the ezmultipli at this time. It seems to be a device handler issue or firmware problem on the sensor itself. But it does work.