Extra new Home location appeared in my account. Can't delete it

I noticed on the web and in my app I have TWO Home locations now. One is my actual Home, and the other looks like a brand new setup with no devices or smartapps, or even map location set yet.
I don’t know where this second “Home” location came from.
When I try to delete it from the Web ui I get an error: Error
500: Internal Server Error

When I try to delete it from the app I get an error: Something went wrong. We are unable to remove your location. Please try again later.

Contact support

Hi @chris_rose

You can try this, for me it was helpful:
In order to delete a Home Location that has nothing in it:

Login to IDE at https://account.smartthings.com 134
Goto Locations
If you have multiple Locations, select the invalid one
Make sure there is no Hub associated to it
Scroll to the right and click Edit
If the Default Location shows “true” (will be read only)
If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
Now you can edit/delete the additional Home location as it will automatically be set to “false”.

If that fails to resolve the issue, contact ST support and they can do it https://support.smartthings.com

You can find the original thread here and the solution was from @jkp Can't delete a location keeps giving error, any suggestions?


This is most likely due to when your account was converted. When that happened, a new location pops up. This has happened to many, many people, including me. I’m mobile right now, but there are a couple topics about this already in the Community. I’ll post what I can find when I can, but do a quick search and you’ll be able to find a solution if ST support can help or takes forever to gat back with you.

and @Scrupix posted exactly what to try!

Thank you so much, setting the “real” location to the default, and then delting the other location did the trick. All set now.

1 Like

Sounds like you got it straightened out, but as far as what happened and why, see the FAQ. The duplicate location issue is discussed there. :sunglasses:

1 Like

Thanks for this. That was driving me nuts!

1 Like

Thank you!! Exactly my problem, Support could not figure it out…
If only that error was in English instead lol

It worked for me thanks!

Worked perfectly - thanks!