Everspring ST814 Temperature/Humidity Detector


(Daniel B) #1

I’m brand-new to the world of ST, so please forgive me if I’m not properly following ST etiquette here…

Has anyone been able to get the Everspring ST814 Temperature/Humidity Detector to work with ST?

I’ve tried changing the device type to a # of different options, but none seem to work.

I reached out to ST support and this was the reply:

"Unfortunately we aren’t officially compatible with the ST814 just yet. We’re working on it, but I don’ have an official timeline I can offer you. You may be able to reach out to the build community at build.smartthings.com/forums.

Somtimes, a possible workaround for non-supported devices is to manually change the device type. There is no guarantee this would work (and I’ve never seen anyone try it with an ST814) but if you’re able to connect it to your hub as a “SmartSense Moisture” like you said, then you could try changing the device type to an Aeon Multisensor or something similar. If you’d like me to give that a shot from my end, just let me know when you’ve connected it.

Meanwhile, I’ll pass this along to the hardware team to reinforce the desire for ST814 support.

Sorry for any inconvenience."


(A2thejay23) #2

i bought one a while back and experienced the same troubles you did, i gave up for now and it’s just sitting in the corner collecting dust. Hope someone knows a way to make it work!


(Mike C) #3

I have one too… waiting for support smile:


(Steven Robertson) #4

Does anyone know, how long new devices take for development take to integrate and get working with SmartThings. I just bought the EverSpring Temperature/Humidity z-wave sensor. I got it connected but only have the Battery % that displays. SmartApps displays ‘No installed SmartApps’.


(Matt) #5

I’m hoping you guys found this on your own. This was one of my first “Things” purchased.

Here is the device type code I found and have been using. I ran across this post tonight because I’m trying to figure out why HADashboard can’t display this devices Temp.

There are two versions in that post. I have been using the first and just now switched to the second.


(Doug) #6

Dang, I found the other post where it stated that someone HAD gotten it working and to see post x. Unfortunately all attempting to go to post X does is log you out of the forum and put you at the root page. So now I have one and it does nothing… Any update on this device? Anyone have any luck changing device types (as suggested at the beginning of this thread)?

Thanks!


(Matt) #7

@dmw999 If you are referring to the ST814, it’s not officially supported by ST, however it does work with code from

You’ll need to review the entire post but there are a few versions of the device type and information on how to add it.

Let me know if you get stuck.


(Doug) #8

Thanks, that was the link I was looking for!! Thought that I had looked at it, too - perhaps I just didn’t scroll down far enough.

Thanks!!