SmartThings Community

European Z-wave, and unsupported devices support question


#1

I’m a new smartthings owner and have been testing the hub out for a few days now. I have a number of existing Z-wave devices, some work and some don’t. For the ones that don’t, I’ve tried searching the forums but no luck.

I was wondering if someone could please point us in the right direction, a quick intro to device types and maybe a guide on adding new unsupported device types e.g. European Z-wave devices?


#2

I 'm sure that’s frustrating! It may depend on the specific command sets that are supported by each device. Really there’s no general rule for this.

You can go to the Z wave alliance product site and check the conformance statement for each product to see which command sets it supports.

( A device might only be manufactured for specific regions, but it would be very unusual for it to have different command sets for different regions.)

After that you just need to go to the devices category of this form and search on that particular product and see what members’ experiences have been.

SmartThings is a certified Z wave controller at the basic level. Which means it should be able to pair with any certified zwave device and issue on or off.

Beyond that, it depends on the exact command sets which are supported by each device. Which again are published publicly on the Zwave alliance site for each certified device.

If you tell us the exact model numbers, we could probably figure out more of what’s going on .


#3

Thanks for the info @JDRoberts!

I briefly had time to mess around last night and eventually got two of them to work now. However, it was very much trial and error!

Also, I added custom device types of the generic Z-wave motion sensor, and Z-wave open/close sensor… not sure if those were actually needed?

If I have time, I might remove those custom device types and devices from smartthings and try adding them again to verify.


#4

If by “don’t work” you mean you can’t get them to join to the network, that’s an entirely different kind of issue.

Smartthings should be able to “find” any certified zwave device.

It was zwavewave device can’t be found, the problem is almost always one of two things. Either the device is using a different Z wave frequency and the smart things hub, or the device thinks it’s still belongs to a different network this can happen even with a brand-new device because devices may have been paired with a test network at the factory, and then for one reason or another, this information was not cleared prior to shipping.

If the device is on a different frequency, there’s nothing you can do. The two devices will not be able to talk to each other.

However, if the problem is just that the device still thinks it belongs to a different network, that’s easy to fix by first clearing the information about the old controller from the device.

When this happens, any Zwave controller, including the SmartThings hub, can do a “general exclusion.” You will have to do something physically with the & device, typically push a button on it, which puts it into listening mode.

Then you have the smartthings hub send the general exclusion command, which tells any Z wave device nearby that is listening that it is OK to clear the controller information if it is trying to do that.

At that point, the device you pushed the button on should clear its old controller information. Once that is done, it is ready to join a new network.

So now you follow the procedure for that device to join a new network.

Support can help you with this if you have trouble joining any individual device to a network.

http://support-uk.smartthings.com/hc/en-gb/articles/204656422-How-to-Exclude-Z-Wave-Devices


#5

Yeah, part of my problem was getting the devices in a ready state to pair. However, still not sure if me adding the device types helped with the process or not.


#6

There is no way to answer that question without the exact model numbers.


#7

This is were I’m getting a bit confused. For example, for me to get netatmo connect to discover my basestations and outdoor modules, I had to alter the smartapp code and add the device types to “my device types”. Without that, they wouldn’t appear.

Likewise, when I was messing around with the z-wave devices last night, it didn’t seem to appear to work until I also added the generic z-wave device types to " my device types". That’s the bit I’m going to verify when I have time?

Also, in the android app, none of the devices I mentioned above were available as options either. So all in all, there’s still quite a bit for me to get to grips with…


#8

You shouldn’t have to add any of the standard device types, they should already be available to your account. It’s only custom device types that have to be added.

Are you using some supersecret MI6 tech or something? Because without the Z wave model numbers we can’t give you very helpful answers. :sunglasses:

This should help generally:


#9

Haha, no. I just keep forgetting to note down the model numbers. Then I’m usually most active on the forums during the day when I’m not at home to check them!


#10

I’m still not at home but here’s the example with netatmo:

17:25:03: error Error creating device: physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Netatmo Outdoor Module’ in namespace ‘dianoga’ not found.
17:25:03: debug Creating child
17:25:03: debug In createChildDevice
17:25:03: debug Outdoor module
17:25:03: debug In getDeviceList

Bear in mind, netatmo connect is “offically” supported in the UK android app but, it still tries to connect to the US servers, so I had to modify the smartapp to reference the EU servers and manually added my netatmo clientID & secret… not sure if that complicated matters and hence this unknown devicetype error.

If I then add the netatmo device types to “my device types” then the netatmo smartapp completes setup normally and adds my devices as expected.


#11

Yeah, that pretty much complicates everything…I’d start a new topic just on Netatmo in the UK.


#12

I have posted in the netatmo integration thread, but I guess that the UK specific problems do merit its own post.


(Danny Olsen) #13

NorthQ danfoss thermostat

D-link z100 window sensor

These I am trying to make work with ST :confused: