Aqara Temperature and Humidity Sensor: 2nd one won’t connect

I’m trying to get the Aqara Temperature and Humidity Sensor to work on my Smartthings. I have five of them.

I have created a Device Handler with this code:

It worked fine for the first one and a “Xiaomi Aqara Temp Sensor” appeared in my list of Devices. But, when starting up two more they won’t connect.

I have tried to restart both of them (Pressing for 5 sec on the button) but always get the “no connection”-blink and they don’t connect.

Any ideas what to do?

How many total zigbee battery operated devices do you have? And how far are they from the hub when you try to connect them?

I am just wondering if you hit a limit on the number of children one of your repeating devices can have, which would include the hub.

The hub can handle either 32 or 64 children, depending on the model hub. Other repeating devices can handle anywhere from zero to about 11, but typically between three and five.

You could try removing the sensor which did join and then try adding one of the other ones. if the other one adds in that scenario and then you can’t re-add the first one, then you probably hit one of these limits. In that case, the solution is just add another repeating device.

The Ikea Tradfri smart plug happens to be a good repeater in a smartthings zigbee network and is very inexpensive. It is also available in many different countries. In the US, it usually costs less than $10 when bought directly from IKEA. It is available in many different countries.

But most mains powered zigbee devices with the exception of the sengled brand will work as repeaters. :sunglasses:

Thank you for your quick reply!

Now everything works!

I have no idea what the problem was but when I went into “Add device” on the Smartthings app and “search nearby”, pressed 5 sec on the sensors, it magically worked for all devices this time and now I’m very happy :slight_smile:

1 Like