[EDGE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung

Right, but my locks never showed up here with the standard device handler. When I installed this device handler they now appear here, yet offer no information.

The custom device handler adds motion capability, the stock one doesn’t.

1 Like

Ahhh okay, I think I understand. It’s a motion capability but only shown as active if the alarm goes off? Sorry, took me a while…


Just installed your app and device handler for my BE469 yesterday and it seems to be working well so far.

I was wondering if there is a way to see when the door is left open without installing another sensor on the door? Right now after installing this device I seem to only have control over the door lock and do not see any other information. Do I install another device to see if it is left open or closed?

Also, I am unsure what the middle button means on the screen and it says “unsupported” I have a screencap below.

I also saw on my activity that some of the actions didn’t actually happen and I was wondering if you could tell me why they are listed, such as “Auto lock”, “Unlock using code”, and “Alarm Mode”. The only thing that happen that morning was the door was unlocked manually. I have a screen cap of this below as well

Thanks for you help.

Unsupported because your alarm is off and hence sensitivity is not a valid option when alarm mode is set to off. Set your alarm note and you can set sensitivity.

Any luck getting this resolved? I just started getting this exact same error code about 1 day ago. Lock has been working great for several months, it is has now become unresponsive.

Thanks for replying.

Is there a way to see when my door is left open without installing another sensor on the door? I was hoping the lock would be able to do this for me.

Not that I know of.

I’m still lost what error is being referred to? MSR is just a message to help identify functionality of locks. It’s not an error.

If it was working earlier but not working now then it’s a communication issue between the lock and hub. Think along the lines of what can be done to isolate the communication problem. Reboot the hub, repair the zwave network, check your battery (remove it physically, if it isn’t communicating the battery level is not reliable), if you’ve added a new device Recently take it offline as it may be causing interference. If nothing else exclude and delete the device and start over.

I restarted my hub.
I moved a extender close to the lock.
I ran zwave repair.

Nothing worked so far.

I have a couple of other sensor close to the door and they have no issues.

What I’ve notice is that something it doesn’t work… But other its perfect.

I notice I get the error when I’m coming home from work and after a few hours of no activate.

Did you exclude, delete and re add the device?. Did you try the stock ST lock device handler?

Again, this isn’t an error. It just indicates that lock isn’t responding to the request for information. That indicates the problem is with the communication between your lock and hub. This message is written to debug when the lock doesn’t respond to a request for information.

Also look through your “my devices” page and make sure that you don’t have duplicate devices (I found one in my setup last week). If they are there delete ALL the devices (duplicate and active) and then add them again. I’ve seen ST for some reason try to communicate with the dead/inactive duplicate devices instead of sending the commands to the active device. The only solution was to delete all instance of active and inactive device and add it again.

Hey I don’t have duplicate device stored.
I’m trying to identify the issue by doing 1 thing per day…
I removed your SmartApp Schlage Lock Alarm Mode and sensitivity change and monitor.

So far no issues today…I will give it until tomorrow and update you.

Ps. I have not delete and pair it again.

Start with this.

I will not have time until the weekend… The little one will not allow me. Lol

I have a FE599 with the RBoy device handler installed. The code manager and device handler are both latest version (as of a few minutes ago).

My battery life is taking a hit - 80% after two weeks of infrequent use. I think the issue is a repeated command that seems to be looping: “deleteCode.”

Following the install two weeks ago, I tried the “burn code after use” function, and I wonder if that is the problem. I have only tried it that one time, and may have broken the function by modifying something before the command had a chance to execute? I’m guessing here.

Incidentally, if you ask me to send a log, please toss in a link as to how to grab the log to attach it. I’m sketchy about how to send you that data.


This app has no “burn” code. You’re using some other app. Wrong thread :slight_smile:

The code I’m using is “Lock multi user code management with notifications and automatic relock” version 4.3.3.

I bet it is just a terminology error on my part? I set user 20 “User Type” as “One time.”

In the ST app, the “Recently” column shows “Lock User Code…” every couple minutes, but that is not particularly informative.

The “Main Door (Device) Events — displayed” shows “APP_COMMAND deleteCode” repeated every minute or two.

Okay. Just reprogram the slot which is being deleted and start over clean slate. For some reason your lock isn’t acknowledging the delete code so it’s retrying it.
Are you sure you are using this enhanced device handler? See the first post for FAQ’s and the bug with the v2 hub.
Also change the programming timeout to 60 seconds and you can disable retrying if you want in the options.