(EDGE Driver-Mc): Zigbee Drivers for Motion, Open/Close, Moisture, Smoke-Co Sensors and others Devices

Hi @Mariano_Colmenarejo

I bought this Neo zigbee Siren on aliexpress, do you think it is possible to add it to your driver?

Tuya Zigbee Smart Siren Alarm Temperature Humidity Sensor Home Security with Strobe Alerts Works With TUYA Smart Hub - AliExpress


It is possible but with @w35l3y driver, since this device is using EF00 cluster.
This is his tread you better try his driver first

1 Like

Hi @Kimmo_Liias

Added to driver some time ago

Hi @sidk
Added to this driver version

─────────────────────────────────────────────────────────      
 Name         Zigbee Temp Sensor and Child Thermostat Mc 
 Version      2023-11-03T21:15:46.2500653
─────────────────────────────────────────────────────────
- id: "_TZ3000_rdhukkmi/TS0201"
    deviceLabel: Tuya TS0201
    manufacturer: _TZ3000_rdhukkmi
    model: TS0201
    deviceProfileName: temp-humid-battery

An added to this driver thermostat without child device

────────────────────────────────────────────────────
 Name         Zigbee Temp Sensor with Thermostat Mc 
 Version      2023-11-03T21:18:46.336949326
────────────────────────────────────────────────────

Hi @brenthaag

I have no idea how Sinope implements the flow meter.
I don’t know if it uses a custom cluster or reuses one of the standard ones like 0702, to measure flow instead of electricity consumption.

I’m sorry, if it seems complicated to me with the information I have, if there is some documentation that explains it it could be possible

Hi @cordell25
This was posted almost a month ago.

No problem…I appreciate you looking anyway. I have asked the manufacturer and they won’t share the info.

Thank you - I’m a bit confused so I must be doing something wrong.

When I look at my Driver in Smartthings it shows “Zigbee Switch Mc” and the version is “2023-10-10…” - the link you posted shows that it should be “2023-10-12…” to see those new updates so do you know why I seem to be on an old version (I just installed the Edge driver yesterday)

Could it be a fingerprint issue?

posting some screenshots in case it helps with the issue:


The driver should have been updated to the latest version automatically if your hub is enrolled in my channel.

These are the two devices in the driver, I don’t know the fingerprints of yours.

( mfr = “_TZ3210_dse8ogfy”, model = “TS0001”)
( mfr = “_TZ3210_j4pdtz9v”, model = “TS0001”)

@Mariano_Colmenarejo why are you adding again Sonoff Motion Sensor and Sonoff Contact Sensor? They were previously deleted or what? They were already in your driver before.

Hi I have the same issue here, the version is still 2023-10-10T
And the fingerprint is _TZ3210_dse8ogfy, model TS0001.

Hi @Capriccio @cordell25

Published last version “2023-10-12T14:08:48.900600395” again.
I don’t know why it’s not on the channel, maybe I forgot, it could be

@AurElHA

Models SNZB-03 and SNZB-04 did not exist in the drivers, nor do they exist in the stock drivers.
There were models DS01 and MS01.

I also added yesterday the DS01 model from the manufacturer “zbeacon” instead of eWeLink, it must be another brand from Sonoff

1 Like

Could you add this to Zigbee Temp Sensor with Thermostat Mc. One device makes all much easier to handle automations etc.

I mean this device I previously asked:
Manufacturer
_TZ3000_dowj6gyi

Model
TS0201

Added to this driver version

────────────────────────────────────────────────────
 Name         Zigbee Temp Sensor with Thermostat Mc
 Version      2023-11-04T10:07:10.496537802
────────────────────────────────────────────────────
- id: "_TZ3000_dowj6gyi/TS0201"
    deviceLabel: Tuya TS0201
    manufacturer: _TZ3000_dowj6gyi
    model: TS0201
    deviceProfileName: temp-humid-therm-battery-05

Problem solved. Many thanks!

1 Like

Thank you! That did the trick.

It appears to be working for the most part. A couple of notes:

The FingerBot Down Motion and FingerBot Up Motion are displayed as % but I don’t believe that is what the values represent. Instead it’s more of a scale of 0-100 where 0 is the top and 100 is the bottom. So you can set a value from 1-50 (50 being the middle) to control how far up the arm moves before stopping. And a value of 50-100 to control how far down the arm moves before stopping. I don’t think displaying it as a percentage makes sense.

I also found that the Up Motion setting seems to be working correctly but the Down Motion setting doesn’t seem to be doing anything differently when I change its value. Could you check that and see if something in the driver is off?

Thank you again for making this driver!

Hi @cordell25

I’m sorry to disagree with you on this.
% seems like the perfect unit for this case.
0 to 100 could be mm, cm, dm, m, km, which would not make any sense.

Almost everyone understands that 100% is the maximum, 50% is middle and 0% is the minimum of whatever.

That’s why the downward range of motion is between 50 - 100 and the upward range of motion is between 0 - 50.

I did about 1000 tests to make it work, the values that the driver shows are those that the device returns as accepted into the data point ranges

I commented in the post that the device itself does not accept any combination of up and down movement values and readjusts them, in certain cases, to the values that it considers logical to correct function.

Sometimes I don’t understand Tuya’s logic too and it’s the best he can get.

The driver code is in my guthub repository, if someone wants to improve it I would be very happy, but I give up, at the moment I don’t need more.

Edit:
By the way, I also tried it with a hub and the Tuya app and it worked the same, except that it has adjustment sliders, but it seemed less precise to me.

The device may have a firmware or design defect.

1 Like

Hey there! I am using an Ikea motion sensor (the E1745) and just can’t get it to work.
It doesn’t work with the standard driver so i tried this one and still, it always get’s stuck on “Motion detected” and never recovers.
Has anyone any idea how to fix this? It’s driving me crazy :slight_smile:
i am using an Aeotec Hub V3.

Runs with Zigbee Motion Sensor Mc by @Mariano_Colmenarejo .
This sensor does however tend to show very often offline, although it then responds on movement.
Better to delete and re-pair to make it configure correctly.

1 Like