(EDGE Driver-Mc): Zigbee Drivers for Motion, Open/Close, Moisture, Smoke-Co Sensors and others Devices

Yes, Google Home recognizes at least some ST virtual devices. And if the device has switch capabilities you can use it to trigger Google Home routines.

Hi @3asmarthome

Added to this driver version

───────────────────────────────────────────────────
 Name         Zigbee Multi Switch and Child Mc     
 Version      2023-01-26T14:21:44.549968034        
───────────────────────────────────────────────────
- id: "FeiBit/FB56-ZSW1JK2.5"
    deviceLabel: FeiBit 4 Switch
    manufacturer: Feibit Inc co.
    model: FB56+ZSW1JK2.5
    deviceProfileName: four-switch

Hi Mariano,

How are you?

I hope fine…

Could you add this device for you Motion Sensor Driver:

Hi @@Mariano_Colmenarejo,

My Smartthing Zigbee switch is not able to create single switch. All switch come under parent sqitch and it show child switch. How can I make all child switch as individual switch . I am using Zigbee Multi Switch and Child Mc.

Please help

Hello @Mariano_Colmenarejo

I recently got a Moes 3 Gang Switch I added your Multiswitch Driver but is only detected as “thing”

here is the data from zigbee thing, hopefully just adding it to the driver may work,

Hi @Jose_Manuel_Bermudez

This device use cluster EF00 and does not works with standard drivers.

There is a specific thread for devices using this cluster

Hi @sumon

For this driver you need a Hub with firmware 45.x or up.
new firmware 45.11 for smart wifi hub is in progress this week.

For use child device wit firmware smaller than 45.x the must be use Zigbee Multi Switch and Child Mc-(OLD)

To create child devices:
You have to enter the Settings option and create the independent child devices you need switch2, 3 and 4

In my example case is a device with 3 switch

If your preference is already selected with create device then select NO create device and click save.
Select create device again and click save. The preferences only report value changes, the value displayed is only informative of the current value

These created devices will appear in the hub room or unassigned room

These devices are the ones you can change the name of in the three-point menu, edit option

Hi @Dienzora

I hope you are well too

This device was added several time ago

1 Like

I’m fine too.

Thanks Mariano!

1 Like

Hello I see you added a driver for zigbee ID lock 150.
Is it possible you can add a driver for the z-wave version too?

Thanks.

Hi @soultwist

Locks are security devices, which I don’t know well.

I added that model and some more because it was practically the same as an existing one and I only needed to add the fingerprints.

Always under the responsibility of the user himself

Friendly reminder.
Thanks!

Hi @Wajo357

Sorry, I had forgotten.

I will see how to do it since the driver has several subdrivers and there are also devices that only use the default ones, using the same profiles, so the latter would show the capability without displaying information and the app would be constantly saying that not all the data is updated.

I also changed some things in the driver and it has given some users problems and I have gone back to the original version, to see if it works well.

1 Like

OK. Thanks. Keep me updated.

@Mariano_Colmenarejo , Is there a way to change the time range so that anytime a light is turned on, it would adjust to the time of day and change color and brightness? With this current 6am to 6pm time frame, if a light hasn’t turned on within the time frame, it is stuck at the last state (color and brightness). Could you add an option for the start and end times in the settings?

In my old setup, my lights’ brightness and color would mimic the the time of day throughout the entire day. So when it was 1am and I turned on a light, the brightness would be fairly low and around 2700k vs during the day at 6500k and a high brightness.

Ok. Thanks anyway.

Thanks Mariano, but there is an error with the model no. It should be FB56+ZSW1JKJ2.5 . The error one missed a J that I highlighted in Red. Can you help me to correct it?

Regards,

Kevin

Hi @3asmarthome

Fixed in this driver version

─────────────────────────────────────────────────── 
 Name         Zigbee Multi Switch and Child Mc     
 Version      2023-01-30T22:41:50.637198358        
───────────────────────────────────────────────────
- id: "FeiBit/FB56-ZSW1JKJ2.5"
    deviceLabel: FeiBit 4 Switch
    manufacturer: Feibit Inc co.
    model: FB56+ZSW1JKJ2.5
    deviceProfileName: four-switch

Hi Mariano,
Thanks for updating this driver “FeiBit/FB56-ZSW1JKJ2.5”.
I was able to re install all my 4 gang and they were working fine up until yesterday however they have all suddenly gone off line except for anything else not using the “FeiBit/FB56-ZSW1JKJ2.5” driver. All else is functioning normal including the hub.
Can you please advise on possible issue?

Hi @solidwater922

I do known that could happen.

This device was successfully added on Monday, a J was missing from the model.
Try to re-pair device or there was a reboot of the hub, taking a few minutes