[Edge Driver] FortrezZ Water Meter (Updated 11/28/2023 see post #23)

This is what i see

Whoa, you’re definitely not using my driver.

When you tap on those 3 vertical dots and tap on Driver, what does that show you?

The new link worked. I didn’t find the “Zwave Thing Mc” driver but I found what I think is the equivalent one (maybe updated name) called “Z-Wave Device Config Mc”. Here is what it shows…

Hope this helps. Thanks again!

Edit: To answer your question, all water meters and hubs were purchased at the same time many years ago so I would expect all locations have the same exact hardware.

No worries, and that helps a ton! The driver you selected also gives the similar info, so thanks for doing that.

This is the problem:

image

When the meter joined your hub it didn’t properly capture all that info.

We have a couple options. One, I can update my driver to add those 0’s fingerprint and then you’ll be able to use the driver; OR, you can exclude the device from your hub and rejoin it.

I can easily add that fingerprint for you, but there is a possibility of the driver not working properly if something else didn’t join correctly. If I remember right, this particular meter has been there for a while and working, right? If that’s the case, let me update my driver and get back to you very soon… Be right back.

Hi @Gold_Standard_Proper ,

The driver has just been updated to include the fingerprint of that meter. Force close your app and clear cache and the driver will update in your app. Here’s the version you should have after doing that:

image

Try selecting that drive for the meter after doing that and let me know? You will have to reset the meter for sure, and just to have clean data as well.


@johnconstantelo

Before I read your last reply I was able to remove the water meter from the hub and re-add it. The app immediately started working when the meter was re-added.

Thanks again for all your help!

Do you work for Samsung or just do this on your own? If on your own, do you accept payment?

1 Like

Awesome, glad it worked!

I don’t work for Samsung/SmartThings, I just do this on my own because I enjoy it and have been with SmartThings since the very beginning.

No need for payment at all!

1 Like

Ok, since there’s no Driver option you’re going to have to remove the device (exclude it) and rejoin it to your hub.

Just to be safe though, try that again because I just updated the driver for the user above having an issue with something different that may actually help you too. Would you mind trying again?

I thought I replied yesterday sorry. I don’t have access to it till later this month it is at my vacation home

1 Like

I am trying to download the driver but I do not have permission to access the channel invitation.
What am I doing wrong?

It is currently a system wide problem.

2 Likes

@Ivan_Luis_Falleau Do you have any insight into when this will be resolved?

1 Like

Hi @Bob3 ,

I created a new invitation that should now work, so please give this one a try:

https://bestow-regional.api.smartthings.com/invite/oxl4AXxvwj13

Remember, make sure to enroll the channel and then install the driver. Once you join the meter to your hub, it will use this driver. You also need to reset your meter, so reference some of the posts above on how to do that, or just create a simple manual Routine in the mobile app.

This invite worked fine, thanks.
Bob

Hi @johnconstantelo. I just asked the engineering team about this and they told me that it should have been fixed. Could you please confirm?

Hi @Ivan_Luis_Falleau ,

Yes, it’s working again, thank you!

1 Like

Very exciting, I deleted and re-added and the device is reporting! Thanks so much for your work.

1 Like

Excellent, glad to hear it’s working!

I had given up on getting my Fortrez flow meter working after the SnartThings upgrade. I installed the new driver and am quite happy it brought it back to life! I looked through all the doc I could find but could find out how to either text my daily water gallons or see a graph of the usage by day. Does something like this exist? Thanks!