[Edge] Driver for Aqara Switches and Remotes

  • deviceLabel: WS-USC02 Wall Switch (No Neutral, Double Rocker)
    model: lumi.switch.b2laus01
  • deviceLabel: WS-USC04 Wall Switch (Double Rocker)
    model: lumi.switch.b2naus01

added, please let me know if it works

1 Like

It paired perfectly. I had to wait about 5 mins before the switch completely configured. Timers, routines, and switch status all work. Both buttons are on the same page and it’s flawless. Thank you! I’ll update you if anything noteworthy occurs.

Model: WS-USC02

1 Like

Hi @veonua , I just added the WS-USC04 switch. It was discovered right away, and works perfectly. This device also has energy and power metering capabilities. I don’t use that much, so big deal.

I did notice that when selecting the device to control it via something like my Aeon remote, instead of seeing “main” and “Button2”, I see “Left” and “Right”:

Thanks for all your work on this!

changed profile to the one with the power and energy. (app restart or re-pairing might be required to pick up a new profile)

instead of seeing “main” and “button2”, I see “Left” and “Right”:

‘main’ and ‘button#’ are internal component names they are standardized, ‘Left’ and ‘Right’ are labels and can be applied to the specific layout and use case… as far as I can see in US it’s Top and Bottom

Thanks, I’ll get to looking at that after work today. Are the labels something I can change?

EDIT. I couldn’t wait. It worked perfectly after I removed and rejoined the device. Thank you!

1 Like

HI All,

Has anyone tried the Aqara Motion Sensor P1 with this Edge driver? I’m going to order one just to see if I can get it to work. The Driver works fine with the older model, but it is using the older 1.2 Zigbee protocols.

@veonua I have purchased a P1 Aqara and paired it to Smartthings Hub. I’ve used the old IDE device handler and It is now sending back data.

I’m going to try and have a go at getting it working with your Edge DH, any tips/hints or help would be great

unlikely because I don’t have any P1 motion sensors , and ended up with using motion sensor by YG

Hi @Jeff_Gallagher
Are you saying Aqara Motion Sensor P1 works with DTH? What DTH are you using?
Is it possible to provide logs from IDE for pairing, motion detection and battery updates?
Thanks

can you please use PM or another thread, as it’s not related to aqara buttons and switches

Can you share the old IDE you are using for the new P1 sensors?
Thanks,

It’s not working with the P1. I’m trying to find time to play with an Edge Driver

Does this driver support these settings for the single no-neutral switch?

there are dozens of models around , please find your device on website like Xiaomi QBKG03LM control via MQTT | Zigbee2MQTT

and see which capabilities are supported by hw

The screen shot is from the Aqara app, so I assume it knows the hardware supports the settings. This is the model:

well, the community driver I am using to check features and endpoint has this Aqara US wall switches additional features (operation_mode,action,power_outage_memory) · Issue #10186 · Koenkk/zigbee2mqtt · GitHub

so it could either be a simple solution (copy EU endpoints) or a complex one - trying to figure out device endpoints I’ve never seen.

changed the profile to EU. please try and send me a log

Not sure if something changed. Last week I was able to add all my WS-USC01 switches without any issues and have them working properly. I then ordered a few more switches and now though I can add them with the driver they do not show the on/off button on the cards in the app and now show a temp alert that doesn’t seem to work. I now have to go into the card setting to turn on/off the switch.

You might have settings added, like this but in the ST style [Edge] Driver for Aqara Switches and Remotes - #118 by Automated_House

I’ve changed the device profile so there is a button press and a temperature measurement .
And the ability to work as a decoupled switch.
Do you have the button click registered in the history?

This is what it looks like. Both are off in this screenshot. The card should grey out when off. Light 1 has the on/off button, shows the status and was added last week. Light 2 does not grey out when off, always shows connected, doesn’t show the on/button on the card and was added yesterday. I do have the button click register in history.