[Edge] Driver for Aqara Switches and Remotes

Thanks. Finally got it to work by holding the LINK pin until the blue LED starts blinking. It didn’t work initially. Tried adding device without removing old button, didn’t find anything. But some how I noticed the button is working again. Maybe it takes a few attempts.


I was hoping somebody here could answer this question for me: Will a product in the compatible list (Aqara wireless mini switch, WXKG12LM) work with the driver even if it is region locked (China only) but has a similar model number?

It’s important to note that the list of devices found on the forum is not a “compatible” list, but rather a list of devices that have been tested by forum users in the past. Keep in mind that there is no guarantee that any of the devices on the list will work well, or continue to work well in the future.

Regarding the WXKG12LM device, it will most likely work ok. However, for those who want to be absolutely sure of compatibility, I recommend purchasing ST certified devices from local shops.

1 Like


First, just want to say thank you. Your drivers work great for my Aqara buttons.

I have a small request. Would you be willing to provide a more specific description for your channel? Right now, it looks like this:

It makes it hard for me to remember what this channel is for without digging into it and other channels I subscribe to. Ideally, I could customize the description myself, but I don’t think that’s possible. I know your channel covers a lot of things, so it might not be a simple thing to come up with a more specific name. Just looking at what drivers you offer, I wonder if the description could be something like “Zigbee and LAN drivers for Aqara, Xiaomi, IKEA, Nanoleaf, and MQTT”.

Obviously not urgent! I appreciate your hard work. :slight_smile:

1 Like

Hi again! I’m totally willing to try to update the code for these devices to display the right options. However, I’m new to this so I would appreciate your attention if I’m looking in the wrong place. :slight_smile:

The devices in question are either lumi.remote.b1acn01 or lumi.sensor_switch.aq2.

So far, I’ve found SmartThingsEdge-Xiaomi/xiaomi-switch/src /configurations.lua. In this file, it looks like it’s possible to specify supported_button_values. Currently, this is what the main branch shows, which I’m presuming is what’s causing the wrong values to appear in the devices:

According to Aqara Wireless Mini Switch WXKG11LM Zigbee compatibility, these devices support the following:


With that in mind, I forked the code and changed the values to the following:

I assumed that “single” and “pushed” were equivalent, and used “pushed” for that value because that was what was in the existing working code. I don’t know what “release” would be. Since I’m not sure what that action means, and since my device works with the other values, I left that out.

Here’s the pull request: Update configurations.lua by TodBonzalez · Pull Request #19 · veonua/SmartThingsEdge-Xiaomi · GitHub

1 Like

to make things even more complicated Aqara released 4 square buttons

Aqara Wireless Mini Switch WXKG11LM Zigbee compatibility (2 devices with the same model)
Aqara Wireless Mini Switch with Gyroscope WXKG12LM Zigbee compatibility
Aqara Wireless Mini Switch T1 WXKG13LM Zigbee compatibility

each of them has a different set of clicks

WXKGX1LM configuration is for round button Xiaomi Mijia Wireless Switch WXKG01LM Zigbee compatibility

As things keep changing, the configuration has become a mess. I initially tried making groups to handle models and apply changes more efficiently. However, now there are three types of configurations to deal with: on profile level (yaml files), on device-group level (configurations.lua), and on model level (CONFIG_MAP in init.lua).

I am open to suggestions on how to reorganize it in a better way. Maybe we can move the lua configs to yaml, as it’s a more suitable format, but I am unsure how to do it in a smart way.

I’ve seen/set this line only once in my life, I hope the change is applied :slight_smile: not even sure how to check

Yea, that sounds really frustrating.

As far as I can tell, for the device(s) I updated in the pull request, both are in


Only lumi.sensor_switch.aq2 is in

In any case, while I admit I barely understand the files at the surface level, I think for the changes I described the only file that needed to be updated was configurations.lua. This doesn’t solve for how to organize them better, or what to do if Xiaomi releases more devices.

I’d be happy to help update configurations.lua for the other buttons you listed, to match the https://zigbee.blakadder.com/ descriptions. However, I don’t have the devices to test. :slight_smile:

Hi, @veonua
Not sure if you can help , but can you try adding this Ikea remote switch.

Ikeas p/n E2213

Model : SOMRIG shortcut button
Manufacturer : IKEA of Sweden

It is a new device by Ikea , older devices already supported. A review can be find here:

The specific of this driver it contains almost none of default Zigbee code, while Ikea uses mostly generic and standardized firmware.

Maybe it’s better to ask @Mariano_Colmenarejo if he can add Ikea’s fingerprint to the existing Zigbee driver.

affects whether it will connect to a Xiaomi hub which is set to a different

Its one of those that can only pair with Aqara Gateway (Mainland Chinese Version) and Aqara App. For Mihome App, it is required to set the region to Mainland China for it to work

I’m just paraphrasing what was stated in the product listing

Edit: I’m happy to inform you guys that it does indeed work with the China only variant. Currently 3 operations are functioning (Pressed, Held, Pressed twice) while the remaining operations (like pressed 3/4/5 times) do not. No report on battery status as of yet. Will update when I get a reading.


I have one of the newer Aqara T1 mini switches. It seems like it is not in the fingerprint file, so I have created a pull request to add it: Add fingerprint for Aqara WXKG13LM Mini Switch T1 by mrtorrent · Pull Request #20 · veonua/SmartThingsEdge-Xiaomi · GitHub

This is my first time looking at Edge driver code, so hopefully I’ve done this correctly.

Edit: Do I need to add it to xiaomi-switch/src/configurations.lua as well? Anywhere else?

Are there any updates to the driver?

I’ve been using it for Aqara Wall Light Switches Single and Double rocker for a while now and they’ve been perfect. Last several days they’ve started blinking red-blue, then work for a bit, then blink red-blue and default to regular switches… They’re absolutely buggy.

I’m expecting this from ST, but the driver was working perfectly for a long while.

I love this driver for aqara wall light switch. There is just one point that I would like to clarify related with energy consumption. The values are not correct, is this because my voltage is 230v and USA is 110?

May I know the exact app that you use to sync the second switch with the virtual switch? Can’t seems to find the smart light app in the Apple App Store.

It’s not that kind of app.

“SmartApps” are specific to the smartthings platform. You don’t get them from the Apple App Store or the play store. Where you get them depends on where the author is hosting them, but the good news is that the “smartlighting” smartapp is built into the smartthings app as long as you are in a country where it is available.

To find it, open the smartthings app.

Go to “routines.”

Scroll all the way down, and you should see it in the “SmartApps” section.

1 Like

Thanks for the pointer! Will look into this for the switch sync part.

1 Like

Aqara has been using different coefficients in the energy consumption calculation. Since modern lights consume very little energy, I didn’t fill in all the numbers for every model.

There is an experimental feature for several switch models that allows to display of separated tiles in the app. I can try to activate it for your model.
It’s a non-compatible change so you have to remove and repair the device