Edge Device Builder for Tuya Zigbee buttons

Has anyone tried using the edge device builder for tuya zigbee buttons?

I got some cheap tuya zigbee buttons which incorrectly pair to SmartThings as zigbee switch. I tried using the edge device builder to suggest this was a 1 button battery device. It successfully applies a new driver on the device but the device doesn’t work, no status change on button press.

It shows up in the SmartThings web ui thusly. Via the app mc thing with a blank screen, even after 20 mins.

Could be that the device uses EF00 or custom clusters. What profile is the device using?


I presume you selected the zigbee-button driver before changing the capabilities. Can you do driver logging for that driver and try pushing the button to see what is happening?

Yes, I selected zigbee button before I selected capabilities. Might have a go at driver logs tomorrow, getting too late for today :grin:

I’d be astonished if it worked with a tuya-made device. Tuya uses proprietary clusters, which is exactly the opposite situation from what the edge device builder is for.

Its purpose is to allow a device manufacturer who has a vanilla Zigbee 3.0 device to add their fingerprint to the stock edge driver, and then submit it for ST certification.

Tuya devices will almost always require a custom edge driver if you want to connect them directly to a SmartThings/Aeotec hub. Here’s the community FAQ on that:

FAQ: Using Tuya Zigbee Devices Directly With a SmartThings/Aeotec Hub (2024)

Alternatively, some people may prefer to use a tuya matter bridge, and bring the device in that way. The connection would be local and not require any custom code. But you’d have to check to see if that button model is available through the matter integration yet. :sunglasses:


Thanks for this. Suspected it wouldn’t work. Might be interested in a tuya matter bridge if it was reliable and cheap. If anyone has tried one and got it working I’m curious about cost a capability supported

Always cheap if it’s Tuya. :wink:

They have two models out right now, the Zemismart M1, and one from Moes.

I believe both @Trakker2 and @X0mbie have the zemismart, but I don’t know if they have it working with SmartThings or not.

They are cheap, but I don’t know if they work.


I have both the Zemismart M1 and the no-name Smart Wired Gateway Pro working in SmartThings.

These Tuya Matter Bridges are one and the same device - one of the few that are actually developed and supported by Tuya. Zemismart, Moes, etc… are just white labels of the same Tuya product.

So there is no need to purchase the more expensive branded bridges - just get the cheapest one.

1 Like

Thanks! Are any of the Tuya buttons exposed through the Matter bridge yet? I have an Aqara Button that is working well through an aqara matter bridge, but I haven’t heard one way or the other on a tuya button yet. :thinking:

No, the Tuya butons / scene switches are not working yet in ST when exposed via the Tuya Matter bridge.

Some buttons are exposed, some not. The 4 button scene switch is bridged and is visible in ST :


However, with the exception of the button states during the inital pairing - no more events are registered later : (


Tuya temoerature and humidity sensor is also exposed, but the humidity is always 40%
and does not update.

It is not ST issue - exactly the same problem is seen in Apphe Home.

Tuya Matter bridges are not ready for real use yet. They have too many bugs (or features simply not or partially implemented) and it is a lottery whether a Zigbee devices will be exposed or not, and then again a lottery whether it will actually work or not.


Just for interest, have you photo / link for this button?

Thanks for the information. It’s unfortunate, but hopefully they’ll get it fixed eventually.

As I said, my aqara button Is now working well via their matter bridge. When I first tried it, though, it didn’t work at all. But about a week after That failure aqara did a firmware update, and then all the functions showed up in SmartThings correctly. That one costs more than the Tuya options, but at least it demonstrates that matter bridges can work for this device class, but apparently it’s harder than it looks for the manufacturers. Hopefully Tuya will get it right in time.



I think it was this one


Ok. I’ve got one that looks like that, with press once, twice or hold, runs on a driver from @zambobmaz
His channel invitation is here Samsung account
I don’t much like the button ergonomics though, in routines can’t trust difference between press and hold. Also found if not used for a while it falls offline and needs the batteries taking out and putting back in, to avoid re-pairing.
I thought maybe your’s would be a 4 position Tuya which could be a substitute for the Tradfri 4 position which I do like.

1 Like