Ecobee fan min control

I have a new E3 Lite but imagine this probably applies to a standard E3 too. I am finding based on the web reports that my fan is running in cycles even when I have min fan time set to zero. It also happens to be running for the amount of time I set my min fan time to when I do set it. Does anyone know if the E3 will cycle the fan regardless of your setting, and in doing so, make sure to meet the min you set or does it only cycle if you set a min? I have been trying to get it so that when the area the thermostat covers is occupied (as indicated by schedule) it will min cycle the fan for 10 min. Otherwise zero. So it goes to zero when away from the house. I can see the setting is registered correctly (zero) in the app and on their web portal, but the fan seems to run for min 10 min even so. Not sure if this is E3 behavior or if its somehow it getting confused by the way I am setting it (via device handler, not via app, web, or on device).

EDIT: One other note that may be relevant is I have no away schedule programmed. Its either sleep or home and I use ST to set to away.

Hi @farlicimo,

I don’t know which DTH you’re using, but in general MinFanOnTime is set via a smartapp like ecobeeSetFanMinTime at my github.

Refer to

The smartapp allows you to map your ecobee schedule with a minFanTime by hour. You can create as many instances as you need. I’d recommend to create one for Home and one for your Away schedules (that you use instead of the corresponding ST hello mode). So, you should use the ecobee Away schedule as much as possible and use ST only to set to thermostat to Away when you are not home when you should be there or vice versa (exceptions to your regular schedules)

In general, I’d recommend to use the ecobee scheduling as much as possible to avoid too much dependency on the ST scheduling (which has proven to not be so reliable over the time).

For any help on configuration, refer to


I’m using your DH and per the Ecobee app and web portal it registers zero but the thermostats (2 of them) both keep running intermittently at the 10 minute setting which is my when present setting. When I used your app to set fan time by program state I found it was hit or miss if the fan time got adjusted so thought I would try calling the DH function directly which has been solid so far, but the thermostat doesn’t seem to respect the setting.

Hi, I think that you should call ecobee support and check the way your fan is connected to your ecobee (i.e. wiring).

If you see _minFanOnTime’s value change from 10 to 0 at the ecobee portal, and your fan is still running on its own (as the fan will still run when your HVAC is heating or cooling even if you set this parameter to 0), then there must be a problem with the way your fan is wired to your HVAC.

I’ve owned an ecobee for quite a long time, and I haven’t seen this behavior at home. If I set minFanOnTime to 0, my fan will not circulate on its own (it will run only when the HVAC is heating or cooling).

P.S. Many people have used the smartapp and nobody has reported to me any issue with it.

I just removed all automation around fan time then toggled to 5 min and back to zero through the Ecobee app. Will see what that does. I can see patches of time where the fan didn’t run so wouldn’t think it’s wiring but always possible. I’m loath to call Ecobee as last time it was a 2 hour wait.

I have a new Ecobee3 & have it set to auto & fan only runs when heat or AC is on. Call Ecobee they have great customer service.

I set both to zero through the app last night and they faithfully followed the rule. Will try setting one to 10 via ST and see what happens. Something else that happened odd yesterday is one of them didn’t report HomeIQ for 12 hours. Now appears to be updating again.

Still looking good. Using automation set one to 10 min and left the other at zero and it appears both followed the rules. Now going swap back to zero and see if that works. If so seems like it was just being flaky and maybe was related to the thermostat not reporting to HomeIQ for 12 hours which happened during the odd behaviour.

Still behaving it self so looks like was a fluke.