Echo Speaks: Quarantined

I guess this is the end of Echo Speaks? I tried to complete a Server Update to update Heroku? Received the following from SmartThings. :hot_face:

{“error”:true,“type”:“RateLimit”,“message”:“This endpoint has been quarantined, please contact support”}

I know that Sept 8th was the cut-off and I have procrastinated, but most of this has been that the Alexa Routine App is woefully inadequate for the applications that I had working in WebCore!

Most of the devices I wish to control from Alexa with Voice are not showing up!

HE is now getting Echo app installed and the ST devices that I need to integrate, making my HE to ST device migration ratio 60/40…

I’ve been living under a rock and missed the cutoff or ES. I’ve scrubbed it from my set up for now but I would like to get an alternative up and running to get my Dot’s talking and playing music again.

Is there an alternative or will they be adding the ‘speaking’ capability into the new Alexa skill?

1 Like

That would suck if they start charging a monthly fee after you’ve set up a barrel of monkeys. :monkey_face: :monkey: ((:monkey: :monkey: :monkey: :monkey: ))

1 Like

Yikes… I am betting that once they get us ‘Echo Speak’ migrated users completely hooked, every so often, they will auto pipe in a Tide or Pepsi commercial, or try to sell me some OTC medical enhancement products on the Alexa devices I authorized :rofl:

4 Likes

Thanks @jlv, i saw this but wasn’t sure if it was still the ‘old’ version.

I’ll have a dig into it one evening this week. :smile:

It’s not Echo Speaks at all, but an alternative to getting spoken custom announcements on Alexa.
New thread:

1 Like

I still use the classic app and use a direct query to alexa servers, It works to messages , remainders, and Itunes stations, the problem is that I need to update the cookie information every 2 weeks, but for me is ok.

If only we could see ST use Alexa Announcements in their new Alexa Skill :wink:

I need a little help. What I am trying to do is get my echo to say “front door open” when the door switch (connected to smart things) is opened. What I did (probably wrong) is: got the voicemonkey skill setup, made a “monkey”, generated a URL, went to ifttt and setup up an if door opens, then webhook the URL. Then I went into Alexa to setup a routine to have her say “door open”, but when I try to select my monkey I am told “error device is not currently supported”. To begin with, I don’t know what webcore or webhooks is. I have messed around with IFTTT some before. Any help, even is just a link to what I need to read, would be greatly appreciated!

EDIT: apparently this won’t work until SmartThings fixes the new Alexa integration.

If you just want a fixed message for a simply condition, then you do not need voicemonkey. Just the built-in Amazon Echo linkage and the SmartThings Skill is all that’s needed. Enable it and make your contact sensor exposed to Alexa. Then add an Alexa Routine in the Alexa app. Here’s one that speaks on my tablet when I open my cellar door:


This is the simplest way and involves the fewest parts (just SmartThings and Alexa).

The challenge with this approach is that Alexa Routines are simple and don’t support rich logical conditions. That’s the point when you might want to move to webCoRE and voicemonkey (or Echo Speaks Lite if/when that becomes available).

(I just realized I cheated a little bit in the above example. I’m still on the “classic” Alexa skill, but I think this basic simple functionality still works in the “new, improved and sucks” skill that you get when you link today. And after I posted this I realized I have already moved the Cellar Door Contact from SmartThings to Hubitat, but it should work the same with SmartThings. It’s just the door nearest to where I’m typing, so it’s easy to test with)

That’s how I had all my doors setup before, but about a month ago they pretty much stopped working. I saw the Alexa smartthings skill was updated around the same time. The skill now has 1.5 stars and a bunch of people complaining. In the smartthings app I can see the doors open and close, but it’s not making it to Alexa. I assume the skill is the problem, so I’m trying to find a way to get announcements from Alexa without the skill. I had messed with ifttt, but I can’t find a “then” action that will get alexa to say something. If anyone knows a way to get Alexa to talk without the smartthings skill, please let me know.

Ok, in that case you are best off trying to get voicemonkey to work. I’ve not tried it via IFTTT so I can’t help you with the error there. It is easy to get it to work with webCoRE (and there’s an example in the Alexa Voicemonkey Skill thread).

( alternately, the Alexa skill does work in Hubitat :wink: )

So I just tried to setup the routine in the Alexa app and now its fine with selecting the voicemonkey virtual device and it worked great. The next problem is that ifttt only allows 3 applets in the free tier. Each routine is going to need it’s own applet and I have way more than 3 routines. Shouldn’t I be able to exclude ifttt and just set it up in the smartthings hub to run the voicemonkey URL when my door switch (connected to same hub) is opened? I haven’t messed around with smartthings at all, except to add devices.