Difficulty getting a zwave device to create a mesh route to hub

Device: Outdoor Zwave 240v GE/Jasco switch
Hub: Latest version smartthings hub

I have a relatively robust zwave home automation network (approximately 30-40 zwave devices and 5 zigbee).

I recently installed an outdoor zwave switch/timer powering/switching an outdoor outlet circuit, primarily used for christmas lights, etc. The device is linked to my hub via the S2 authenticated protocol (not sure if that creates any issues?).

The issue I’m having is that I cannot, no matter what I do, get smartthings to establish any route hops to nearby devices between the device and the hub. This is not allowing me to keep my hub in the server closet I have always stored the hub, as the direct connection between the device and the hub in the server closet is at the limit of connectivity or doesn’t allow for a consistent connection (I have to move the hub closer to the outdoor device to pair it).

I have run several dozen zwave repairs, to no avail. I have at least (3) 120v/repeating devices in between a direct line between the device and the hub, which would create much shorter and more reliable signal hops. I was getting a lot of “could not update routes/delete old routes” error messages during zwave repairs with the hub in my server closet, and subsequently excluded/rejoined the device (several times). However, I simply cannot get smartthings to create a route for this particular device with at least a single hop to another repeater. I have tried running zwave repairs with the hub in different locations, but for whatever reason the hub simply wants a direct connection to the device. I’m getting “cannot delete old routes” messages if I relocate the router and run a repair. This appears to be preventing any working/logical mesh routing. Can anybody suggest anything for me to try?

It seems like when I move the hub closer and run a repair, no hops are established, but when I move the hub only 10 ft further, I get the “cannot delete routes errors”. help?!

So first.

The routes showing in the IDE are NOT the only routes available to a device… It is only the LAST reported route.

Given that - Is it working? If it’s working - stop and let it be.


The device works if I keep the hub a little closer to the device. If I put the hub in my server closet in its preferred relatively central location, I do not get a reliable connection. The device typically drops offline, and does not reconnect.

IDE lists no route whatsoever for the device. This is frustrating/puzzling because I have two zwave plus outlets within 20’ or so of the device, and then a wall switch between those devices and the hub. Any hop or route including any of those devices would/should create a more reliable connection.

I’m assuming If I do not see any route whatsoever in IDE for the device, that there is only a direct connection hub>device, and this would explain the device going offline. Is this not a valid assumption?

No - it means it hasn’t reported a route yet. It can take over 24 hours to get the data. As you can probably tell - the IDE is a horrible tool for realtime mesh troubleshooting. You need to adopt a slow strategy to making changes.

Question - Do you have any other S2 devices in your setup - is this the first one?

@JDRoberts can a S2 device route through a non-S2 repeater?


Do you have any other devices using S2 security? Because those are the only ones that can repeat S2 security encrypted messages.

You can tell if a device supports S2 security by looking at its conformance statement at the official Z wave alliance product site.

Most important, as @nathancu mentioned, is understanding what you are seeing in the smartthings report. It’s not a routing table of available routes. It’s just a single point in time record of a single message that got sent. And it can take a while before it even records the first one so make sure you toggle the device on and off a couple of times and then you may have to wait a couple of days before you start seeing a route record. that’s not the way most hubs report zwave routing, but it’s what they’ve chosen to do


That’s what I suspected - it’s going direct because it has no other choice, and I strongly suspect it’s just out of range for direct connection where your hub usually lives.

1 Like

An S2 device can, but an S2 message cannot.

So if you add an S2 device to a network and you let it default to a lower level of security, then it can use the existing repeaters. But if you add it with S2 security enabled, then the path for those messages have to also support S2 security.

1 Like

Yes, I do have several S2 devices in my setup, sprinkled throughout the house. Most I believe are Inovelli wall switches, and ironically one of the closest repeaters to this device is an S2 unauthenticated plug in switch (this would be the closest repeating point). I have some legacy switches as well, and when I review the routes on other devices it seems like everything repeats regardless of legacy/S0/S2.

S2 unauthenticated Messages work with more devices than the two higher levels of security.

You said you added the newest switch as “authenticated”. But the closest repeater is “unauthenticated.“ That would create the issue.

The odds are you don’t need a higher level of security, particularly given that your other devices aren’t, have you considered re-adding this newest device at a more compatible level?


Either delete it and add it at a lower security level or get you something like this to stick in between.


Ah, this is all very helpful and new to me, thank you JDRoberts and nathancu. I don’t think I need the high level security, as the majority of my devices are legacy zwave/zwave plus devices w/o S2 security.

Man, I went back and forth with support and got pretty much zero help, but ya’ll have really helped me out.

I will try rejoining the device w/o using the QR code, or check if the closest repeater is S2 authenticated capable…and report back



Good luck! let us know how it turns out.

I added something to my standard questions list today. “Is this your only S2 device?”

1 Like

Note also that S2 devices can adopt one of three levels of security, unauthenticated, authenticated, and access control. So you may need a follow-up question to see if the different S2 devices are at the same level. :wink:

1 Like

I excluded and rejoined the device, this time skipping the dsk/QR code and opting to skip the secure join in the mobile app. The IDE is showing the device security now as S2 FAILED.

I’m running network repairs, and just getting error messages over and over for the device and nearby repeaters that I’m trying to route through, even moving the hub closer to the end device.

The repeaters in the wing of the house that I"m trying to route through to the hub security levels are listed in the IDE as follows:

Minoston 2 channel switch: S2 unauthenticated (no dsk shipped with product)

Jasco zwave plus outlet: zwave_Legacy_non_secure

zooz or inovelli Zwave switch: zwave_Legacy_non_secure

Is there a difference between S2 failed, and S2 unauthenticated? If so, how do I rejoin the device as S2 unauthenticated? I tried rejoining as a generic zwave device, and as a GE switch, and both resulted in S2 FAILED. I’m not sure how to rejoin the device any other possible way.

Do I just leave the hub closer to the device for now, and hope that at some point the mesh network “figures it out” and routes the device through at least one other repeater in the network???

I have tried excluding, factory resetting the device, and rejoining it to the network. It continues to show S2 FAILED. No matter how I exclude/reset/rejoin it shows S2 FAILED in the IDE and is not routing through the S2 unauthenticated repeater, or legacy repeaters nearby. I have been toggling the switch via the mobile app periodically hoping to have the routing table magically update, to no avail.

Is my only option to buy an S2 authenticated repeater, and rejoin the device via S2 authenticated, and hope they route through each other? Kind of stupid when I have 3 repeaters in the area, but if I have to throw money at the problem, I guess I will :frowning: Having to relocate the hub away from my router switch and UPS for a single damn device is rediculous on a “mesh” network :confused:

You’ve been doing that and waiting 24 hours? Because it doesn’t feel like it’s been long enough to see routing report updates yet.

As to the join status, I don’t know enough about the smartthings zwave platform to know exactly how it’s implemented for that. Hopefully someone else will.

When zwave was created, it had a very strong commitment to backwards compatibility. But they have drifted away from that, both with the S2 security platform And with association groups under Z wave plus. And there will be more fractures with the new 700 series.

It’s frustrating, but I think it’s the reality that pretty soon, probably with the 700 series, we will see a significant loss in backwards compatibility. At least on a practical day-to-day level.

It has not quite been 24 hrs. I’ll try to be more patient (I’ve been screwing around with this device for far, far, too long…).

I took a look at some other routing paths for some wall switches that I have. I actually did find at least one other switch with a security level of S2 FAILED routing through an S2 AUTHENTICATED as well as a LEGACY NON_SECURE wall switch on its route to the hub. That would lead me to believe that this device with a level of S2 FAILED should route through at least one of the two nearby repeater options in between the hub that have S2 unauthenticated and legacy security levels, but I could be wrong I guess.

All I know is I’ve not had any trouble like this adding anything to my network (including the red series s2 switches) and getting reliable performance out of the box, considering the amount of available zwave devices in the network to route through!

Sorry, I’m confused.

S2 FAILED routing through an S2 AUTHENTICATED

is not the same thing as routing through an “S2 unauthenticated“ device.

S2 Authenticated is a higher security level.

And, as always, remember that the only report you get from smartthings is a historical picture of a single message. It’s not telling you what it can do or might do or will do the next time.

If you really want to see if it will route through a specific device, you probably have to cut power to the other options, and maybe even temporarily move the hub even farther away so that the hub itself is out of range.


Sorry, I’m confused.

S2 FAILED routing through an S2 AUTHENTICATED

is not the same thing as routing through an “S2 unauthenticated“ device.

S2 Authenticated is a higher security level.


Yes, I understand that. I think I’ve even confused myself! (Thanks zwave designers.)

My example is my zooz Couryard Light wall switch, which is S2 Failed. Its last routing path is:
Courtyard Light > Island > Bookshelf > SmartThings Hub

The Island switch is S2 authenticated, but the bookshelf is a legacy unsecured wall switch. My thinking is if the legacy switch can relay the signal, the S2 failed device I’m having a heck of a time on the other side of the house should route through either the S2 unauthenticated OR the legacy zwave plus outlet nearby.

Strangely and contradictory to an earlier comment on this thread, I do have a red series S2 authenticated wall switch that has its first hop through a zwave plus outlet that is listed by the hub as legacy_non secure in my network. Now I’m really confused… I thought only S2 secure messages could be relayed by devices with that same security level? :man_shrugging: :man_shrugging: