Devices Unavailable

As @jkp said, a lot of people have been reporting the same thing. If you have Device Health turned on, you could try turning it off for a while (I usually do about 60 minutes) and then back on again. I also noticed that when my devices show offline, they still function if you go into the device details.

Also, be sure to log a ticket with ST support.

@jkp @Core_Phx, I have logged a ticket with ST Support, but to say that have been less than helpful is an understatement. They told me that the problem was all on my side and was with interference from WiFi devices. This makes no sense to me since Z-Wave is in the 900 MHz ISM band and not the 2.4GHz or 5GHz bands of WiFI.

I Have pushed on my ticket with them, but they have gone dark. Was hoping that the community had something more to add… but I guess that I am not the only one with the issue so I guess it makes me feel better

Yes, I have device health turned on, I left it off all night and turned it on this morning and still about 10 of my devices were unavailable. I have been able to get some to “work” by going into the device settings and “saving” them but that only works for a very short amount of time.

Yeah, Support has their “canned” responses that are complete and total BS. I’m hopeful they will have a patch pushed out shortly to resolve this.

I had some of the same issue(s). I also had problems with some SmartApps suddenly stopped working.

My network has been pretty stable the past few days. Here’s what I did:

As for the SmartApps I have deleted them and created new. That has been successful with a quirk of using sunset as a trigger will not work without an offset…?

@wolfewl i have tried to run the ZWave repair a few times, but it never seems to do anything. In fact the last time that i ran it, i actually lost communication with devices that had never had a problem before…Im trying not to touch it anymore. My fear is that once they “fix” this issue that i will have to re-setup all these unavailable devices and i dont want to make the issue worse than it already is…

Such a shame. for product that had been working rock solid for me for such a long time to be so FUBAR right now sucks. It sucks more that i havent heard any response from ST Support letting me know that this is a “known” issue and they are working to resolve it.

Did anyone was able to resolve the problem. This had happened to me twice since the update. I have too many devices and I don’t want to reset the whole system.

I’m thinking about changing to Versa :frowning:

Mine has been rock solid since I performed this Z Wave repair procedure…

Suggest turn off “Device Health” switch. That solved my problems.

I later discovered that, in addition to turning off Device Health, a hub reboot (power-off, wait 60 seconds and power-on) let the network rediscover itself and cured all of my problems. Note: If you have a V2 hub with batteries, take the batteries out before your power off/on reboot. I left my batteries out because my hub is plugged into a UPS which eliminates the hub’s need for backup batteries.

im going to confirm the full power reset procedure. Noticed one of my multisensors was not updating today. tried pulling battery and button press combos, etc. on the sensor to no avail. rebooting the hub from ide and network repairs also didnt restore connection to the sensor. then, i noticed 4 of my multisensors and 1 water sensor were listed offline in ide as of a few hours ago.

pulled power and batteries out of my v2 hub and waited 4-5 minutes before returning batteries and power. hub came online and after another few minutes i went to check each of the offending sensors, which immediately reported the change and updated status, temperature/etc.

I did have to put my hub in pairing/discovery mode for the initial sensor that i was having issues with (pulled battery/pressed button to reset) it came back into the hub like adding a new thing and all good now.

Come back next week and let us know if it stayed online. There are literally dozens of posts in the forum from people having an issue with devices going off-line, and the problem frequently comes back in a couple of days. :disappointed_relieved:

I have zigbee devices doing the same thing since February. After deleting all of them, and pairing them anew with the hub, I could not even go 24 hours without one of the zibgees (an Aqara door/window sensor) becoming “unavailable”.

But no amount of button-pressing on the sensor could get it to pair, so I had to “delete” it, and re-add it, which restored normal function. Batteries are not the issue here, these are very fresh batteries on a system only installed since January.

Samsung is no help, they want to deny any need to support the Aqara devices. If this keeps up, the Samsung hub will be returned as “defective”, and I willget a Hubitat, and see what they can do. It is only be returning these devices for a full refund that we will get any attention, it seems.

The Aqara devices don’t work with Hubitat either. Xioami only intended them to work with their own gateway, and they are, as engineers say, somewhat “idiosyncratic.“ So you can’t really blame smartthings for that one.

Just as one example, they don’t work well with most certified zigbee Home Automation repeaters. That can be a real problem and it may be that when you rebuild your network they chose a different repeater than they had previously been using.

The IKEA Tradfri bulbs and plug in switch do seem to have better luck repeating Xioami messages, so you could try some of those. There are some Hubitat customers who added a second hub just to run a network of xioami devices and IKEA Tradfri.

You can talk to people using the Xioami devices with SmartThings in the following thread:

OK, so easierand cheaper to add an Ikea socket than to replace a dozen of these (apparently) incompatible devices I was sold as “SmartThings Compatible”. We shall see, but we also have the issue of a less-than elegant recovery from a simple momentary power failure, and a complete dependence on an internet connection, even for local activities as issues to be addressed with this hub, as it is not nearly as “smart” a thing as Samsung leads one to think.

In the context of this platform, “local operations” means automations that can run without an Internet connection. It’s just that there are very few of these, essentially only the official smart lighting feature and some bits of the official smart home monitor feature. And then only if all of the devices included in the automation are using the stock device type handlers which are eligible to run locally. So you can set it up so that your motion sensor triggered lighting will still work without the Internet as long as all the other conditions are met. Or a siren that will go off if a window is opened.

However, all of that said smartthings is still a cloud-based system. You cannot arm or disarm the system without the SmartThings cloud (except for the ADT model). The app cannot communicate with the hub without the SmartThings cloud even if they are on the same Wi-Fi network. No notifications can be sent without the SmartThings cloud (again, except for the ADT model, which has its own cellular module to send information to the ADT monitoring center.) and no custom code of any kind, including webcore, can run without the SmartThings cloud.

So, yes, it’s a cloud-based system.

People who want something which runs completely locally except for third-party integrations like voice assistants, may want to look at hubitat or homeseer.

The list of officially compatible devices is on the SmartThings website:

At risk of seeming pedantic, there can be no security aspects to the system at all if it is a "cloud-based"system. If there is no progress on the issue of operations that run locally, even when the internet goes down, then the entire “SmartThings” ecosystem is a mere curiosity, a toy. The utilitarian aspects of the system must be stand-alone, so the water shut-off valve that cuts off the water main if sensors detect a leak is USELESS, as it will not work when the internet is down. Anyone can battery back-up their hub, so hubs that can run code locally will be the only ones to survive as products.

No argument from me. Check the forum, from 2014 until the introduction of the ADT model hub I’ve been saying that it cannot be considered competitive with purposebuilt security systems. That doesn’t mean it’s a toy, it just means it’s not an effective security system.

The introduction of the ADT model hub did change my opinion, and you may notice that all of the links on the official SmartThings site regarding security systems now take you only to that model. That one does have local operations for the security aspects. It has its own cellular communication module and its own battery back up and does not need the SmartThings cloud at all in Order for One of the dual logos sensors to detect activity and alert the ADT monitoring Center. It’s also the only model where you can arm or disarm the system locally, although you have to use either the key fob or the panel to do it. So I consider that model, and only that model, to be a potential candidate for a low-cost self install the security system. But as I said, I’ve been saying that for years. :sunglasses:

As far as the water leak issue, that can be done locally if you use zwave direct association between the water sensor and the valve actuator. But you won’t get notification of it until the cloud connection is restored. So that will meet the requirements of some people, but not others. Every system has pluses and minuses. I certainly agree that if what you want is a system with a high percentage of local operation, smartthings is not likely to be a good fit.

I like smartthings for convenience notifications for complex use cases, such as a reminder that the guestroom window has been left open when rain is expected and the guest is away from the house. It does that better than pretty much anything else in the same price range. But I don’t put any critical use cases on it as it doesn’t meet my requirements for reliability at this time.

Hell yeah thanks. Fixed all 25+ devices instantly. Thanks.

Glad it worked for you.

I’m not sure what the Device Health switch does except cause problems.

Also, I suggest that any time you add (or delete) a device or even make a change to an automated routine do a hub reboot (power-off, wait 60 seconds, and power-on). If your hub is a V2 with batteries, take the batteries out while rebooting. The reboot lets the mesh rediscover itself, I think. It may not be necessary but it’s an easy, no-hassle procedure. It works for me, anyway.

I never had this problem before (offline device but still work). Started now with aqara motion sensor and door sensor and also with orvibo door sensor.
Resolved by disabling device health