Device type in Smartthings IDE can no longer be changed to a handler

The Groovy IDE at this link below used to have a pulldown to change the device type to a specific handler. But now it’s gone. I have 3 identical switches and 2 picked up the correct handler on their own, but 3rd one did not and shows type = “Z-Wave Switch Generic”. I tried the recommended steps to exclude the switch from Smartthings and add it back but no luck. Other than this issue, the switch works fine with Smartthings. But I like having the handler code for extra features for all my devices and it worked before.

https://account.smartthings.com/login

I am still seeing the pull-down. Have you tried a different browser?

Hello, thanks for reply. I tried Chrome and Edge browsers. Here is the URL shown when I look at one device in my screen shot attached. I added the handler for “Type” when it was a pulldown and now I can no longer change the “Type” for any device as you see the pulldown is gone. Samsung cannot help with IDE issues and suggested looking here at the community.

Show Device (smartthings.com)

Did you hit edit at the bottom of the page before you tried to make the change?

5 Likes

THANKS!!! That works… I forgot to hit edit !

1 Like