Device excluded, but icon stays on Smartthings app


#1

Hi, I am new to the Smartthing. I added a motion sensor from EcoLink to the ST hub, it showed up as door open/close sensor. I tried to delete/exclude it by setting the hub to exclude mode and remove/replace the battery of the Ecolink motion sensor as suggested by some web posts, the app was unable to remove it, then I did a force delete, and the app says: oops, you might have removed some other device and the icon stayed on the “things” page. But I was able to add the same device to ST hub later, meaning it was excluded by the hub. How can i remove the “ghost” icon/device? from the “things” list? thanks!


#2

problem solved. Just found out there is a web interface (https://graph.api.smartthings.com/device/list) for each account. I deleted the ghost devices from the web and they disappeared from my phone app.


(Bob Anderson) #3

I just had the exact same thing happen! I added an Ecolink motion sensor, and it paired as a door open/close sensor!?

Now I am trying to go through the process of deletion, and it’s strange.

When I go to the Things menu, then hit the “gear” icon for this sensor, there is a button for “Replace” (huh? what does that do?) and “Remove”. When I click Remove, nothing happens.

I just deleted it from the IDE interface. Hopefully that allows me to start over.


#4

Replace for zwave devices is intended to let you replace a defective device with an identical one, keeping the old network ID. Don’t know if it works, though.


(Bob Anderson) #5

Ah, thank you. That makes sense.


(Bob Anderson) #6

It happened again. I went to the Add menu, selected the Ecolink Motion Sensor, selected add device, then put battery back in the motion sensor, and it says “Device detected but it is not the correct type” (or something very close to that). It shows up as a door open/close sensor again.

Any ideas how to get around this?


#7

Frustrating!

Since both are on the official “works with SmartThings” list, I’d try support@smartthings.com They should be able to help.