[Deprecated] Thinking Cleaner 2.x (Roomba Control)

Check that, it was just dead, once I set on home base to charge it picked back up the wifi. “Emergency Reset” fixed the wifi connectivity issue.

1 Like

Just want to clarify, since we can configure the TC from its local IP, provided you can live with no ongoing support and potential wifi reliability issues, is that enough to keep this integration going? This needs the cloud to hook up to ST, no?

No. The dth communicates with your TC’s local ip.

I think I’ve given up on this POS… I lost WiFi after battery died so I ordered a new lithium battery and now it won’t configure and stay connected…

I purchased a Neato D3 which is not as powerful as my Roomba 880 but this module is quickly becoming garbage. I have also modified the NEATO DTH to fit my needs and will focus on improving that. Sorry all, it’s time to [DEPRECATE] this code…

2 Likes

Understandable, thank you for all the hard work you put into it for community!

Thank you all for your help in continuing this effort. I can no longer keep my module wifi connected so I have deprecated the thread. Also the thinkingsync.com is down again… I have migrated to the Neato Vac at the following link:

I have already modified the DTH to somewhat mimic this DTH… If you have my Github Integration, it is available there…

1 Like

As soon as mine breaks, I’m with you!

Keep your eyes out, I got my white D3 on Amazon for $213 2 weeks ago (It was only the white one that was that cheap)…

I have a roomba 581.
Can I get a schematic for a wemos D1?

Not sure exactly what your asking for? I only modified the SmartApp and DTH.

I need a diagram for the circuit that hooks up to the Roomba and the Arduino. I’m not for sure what pins to hook up on the Roomba and where they would go on my wemos D1 Arduino board.

Sorry but I wouldn’t be able to answer that one. Not sure if anyone else would in this forum.

Thank You.

Please excuse any typos.

Sorry that this is an old thread but i was having the same issue. What i found was that when i connected the device via the Android app the last step screwed up everything and if i tried controlling it from the app. What i have done (and it’s been stable since)

  1. Use the app to reconnect roomba to wifi
  2. Right after it says its connected, before finishing with the app. I close the app and uninstall it
  3. Update the device in ST to ensure that the IP hasn’t changed.

This has worked for me.

1 Like

Interestingly I got a notification and email the other day that my Roomba undocked and docked… So I guess the thinkingcleaner servers still kinda work?

You’re right, the thinkingsync.com site is working again. Ever since it went down, I have been using the web interface on the local ip instead of their app, and the ST device handler has been fine so I didn’t notice. Someone must have swapped out the gerbil powering the site or something. I guess I might try setting up the app again…but I might just let a sleeping dog lie.

1 Like

Very odd, but after @TylerDurden comment I reconnected to wifi and it is staying connected…

Maybe worth reaching out to them again?

I may have just crashed the thinkingsync.com site… I clicked “Logs” and it timed out and now the site is unresponsive. (Sorry :frowning: )

I’ve actually moved on to the Xiaomi Roborock S50. No ST integration currently unless you set up a Pi as a middleman. But the robot maps the room and methodically cleans, and the app is nice. Works with Alexa too. Someone did some really cool work using the Pi integration where they could tell Google to clean a specific room and it would send the robot that house location and clean that area. (This can be done in the app manually.) I bought two, and the second one has a defect with the dock electronics. I’m dealing with the aliexpress seller now to send the unit back. (It’s a little challenging with the language barrier, etc.)

I gave the my old roomba to my parents. Hopefully the thinkingsync.com recovers soon.

EDIT: The site is accessible again.

I love my new Neato D3, with ST integration. I keep an eye on Amazon as randomly the price has dropped to around $200…

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.