[DEPRECATED] Blink Camera Device Handler with Motion Sensor, Live Video Streaming, Integration with SmartThings/SHM, Temperature, Signals and Push Notifications

It do with your hub and mobile app. Rendering is controlled by the mobile app not the DH. See the first post for FAQ’s.
Try to reboot your hub, router and mobile phone.

1 Like

Just updated the code and everything is working. No need for a router or hub restart.
Thanks @RBoy

Now I wish that the app could tell use when you post new code and recommend that we should go to your server and get the latest update.

1 Like

Hi this is Maddie here, I lead RBoy Apps support. All the SmartApps from RBoy Apps have built in support for update notifications. The SmartApps check for an update about once a week so you should have received an notification if a week has passed since the code update. If you haven’t received the notification please drop us an email and I’ll be happy to look into it and figure out what’s going on.

I just bought my camera with the 25$ discount, thank you guys, so I want to give back.
Here’s is the code:

Special Offer for Friends
Get $25 off your order at Blink


For some reason my system is randomly disarming itself. Therefore none of my cameras will turn on at night when the House is armed.

This is becoming really frustrating because it is difficult to diagnose…and I am afraid the cameras are not going to be working when I need them to.

How can I diagnose what is causing this? It seems to happen randomly.

@Phil_Panfili, one common issue is that routines and SHM sometimes tend to timeout especially when the platform is running loaded/slow (are you using Routines or SHM to arm your cameras?). Are you sure the system is being armed? If it isn’t you should use some sort a backup SmartApp like this one here which can detect if things aren’t turned on/off and then do it after it detects a mode change.

If the system is being armed and then it’s turning off that would require some digging to find out which app is sending the disarm command and if it’s disarming the sync module or individual cameras. If it’s individual cameras you can go into the IDE → My Devices → Click on your camera and see the list of Events to track down who send the camera disarm command. If it’s a sync module that would be more difficult to track down, maybe you can go through the list of events on your hub to see who send that one through it will likely be a custom command as by default individual cameras are armed and disarmed.

Other typical issues i’ve come across:

  1. Do you have CoRE installed, check your pistons - are they sending a disarm command
  2. Check your Native Blink app, it is configured to have a scheduled to arm/disarm your system creating a scheduling conflict
  3. Any other scheduling apps you’re using like Smart Lighting

Although the most common issue is the first one if you’re Routines or SHM to arm and disarm your cameras/system. Tracking down random issues can be painful. Hope this helps.

1 Like

Hi @Phil_Panfili,

And if all that failes, you may need to have Blink support look into the issue:

1 Like

I have the app installed and cameras working as I want with different modes and a piston for motion/resetting record times… In the activity logs I see that Amazon Alexa is sending refresh commands every 10 minutes. I’m not sure why…any ideas? I’m guessing this isn’t good for battery life…

I get inconsistent results with the SA using SHM to decide which cameras to turn on/off but I’m not convinced this is an ST, I think Blink doesn’t accept the requests quick enough and misses out turning on/off certain cameras occasionally.

I have 16 across two sync modules, 8 on each. In the official Blink app I have to slowly turn them on/off otherwise I get a “System is busy” message.

Blink has limitations at multiple different levels for various types of protections. What you may be facing is a sync module rate limitation, if the sync module is busy communicating with one camera it returns a busy signal for another command until the communication is complete.
In the ST integration we handle the busy server message and backoff for about 5-10 seconds and then retry upto 3 times.
If your sync module is having trouble communicating with your cameras (check signal levels and WiFi quality) this could be a reason why it’s responding with a busy message for extended periods. (which is where the backup Routines and Actions SmartApp comes in to help which retries again after a few minutes).

Also keep in mind that there are also overall rate limitations, so if you try to send too many commands too quickly it could shut you out for a bit. Classic examples is someone who tries to setup CoRE in a loop (accidentally) to take pictures or do a refresh on the camera or someone hits refresh more than 4-5 times in a row etc.

Hope this helps.

All cameras bar one have maximum camera --> sync module signal. The one that doesn’t is is 3/5. There are a couple of cameras that have very poor camera --> WiFi. If Blink would do the nice thing and let us know what the MAC address of each camera was on their respective settings page I could improve this more reliably but at the moment, one of my cameras has decided to connect to an access point over the other side of the house instead of the one that’s literally in front of it.

If the RBoy app has access to this information, it would be nice to know it, otherwise I’ll have to go to some crazy lengths to work out which MAC address belongs to which, they look like they’re using a Texas Instruments SimpleLink chipset for the cameras and I think an Atheros chipset for the sync modules.

1 Like

Thanks for the detailed reply. It is the sync module that is Disarming itself. It happened again yesterday, and the cameras weren’t armed for the night.

I only run Pistons for the individual cameras. I never did anything with the morning module.

What is the command to arm the sync module in Core?

Also, I notice in CORE all my Pistons are running a recovery every hour. Is that normal?

Same thing happens to me. And I only have 3 cameras. 1 or 2 of the cameras are missed.

You can find the list reference commands for Blink in the first post created by @RBoy

Expose interface to turn on/off system (sync module) via CoRE (monitorOn/monitorOff) (DONE!)

I’m not very familiar with the workings of CoRE probably a good question to ask on the CoRE community support topic.

You may want to verify that you haven’t enabled the “Switch interface arms/disarms system instead of camera” switch in the Blink Camera Manager SmartApp. Enabling that option changes the default behavior of the camera switch, so when you think you’re disarming the camera you may end up disarming the sync module.

1 Like

For at least the last 4 or 5 days, the temperature readings in the SmartThings app and in ActionTilesfor my 3 XT cameras have remained unchanged.
They show 57°, 57°, and 66°. Right now the temperature outside is 50°.
For the 1st week or so that I had the cameras the temps did fluctuate.

The temp readings are consistently the same in both the SmartThings app and in ActionTiles. The Blink app shows the temps changing as I would expect them to from day to day, and they seem correct (they match my weather station within a degree or two).

Updating the cameras in the Blink app does not cause the other 2 apps to update.

I believe ActionTiles gets it’s info from Smartthings, so why is Smartthings not updating the temps?

Any thoughts?

That’s because ST probably isn’t polling your cameras. Does it update the temperature when you click on the refresh tile?

Again thanks. I looked at the references. Am I right by assuming there is no way to arm the system my module?

I have the option checked to turn on and off individual cameras. So does this mean the entire module can’t be controed through a piston?

I was thinking of just creating a piston to run every so often to make sure the system is armed.

Is this not possible?

Yes, the refresh tiles in Smartthings corrected the temps.
Shouldn’t that update automatically?
Anything I need to do to make that happen?


That’s what I thought. Basically ST isn’t polling your setup. It’s supposed to every 15-20 minutes but sometimes it doesn’t. Not much you or anyone can do about it, most of the times the polling works sometimes ST just stops and there’s no explanation for it. Maybe we’ll look at putting an alternative mechanism in place for the next release.

Thanks for your help

1 Like