Danfoss lc13 temerature control disappeared

What the flying F?

I’ve just had a look on my TRVs. It is indeed gone.

@blake.arnold, are these the steps what should make this platform better? If you wouldn’t have killed the Classic app, then I could go back there and change the values from there, but now I have no idea what temperature setpoint my TRVs stuck on and for how long. And was any of my automations changing them…

@steven.green, do you know what is actually happening with the heating setpoint control? It seems to be you were working on the thermostat DHs recently and must be something was going on with the UX as well.

Are you sure that your automations doesn’t change the temperature setpoint? For me my automations and webcore pistons still are changing the setpoints correctly. Only the manually control of the setpoint isn’t working for me.
On the screenshot you can see that the setpoint (in German Heiztemperatur) has been successfully changed yesterday evening and today because of my automations (heating before going to bed) and webcore pistons (setpoint to 10 degrees Celsius if window has been opened)

You must be right. I must have looked on a TRV which hasn’t been added to any Automation.
But that doesn’t change the fact that a basic feature has been removed for some unknown reason and you have to do kirks to be able control a thermostat.
My TRVs hasn’t got any display to read the setpoint off. And basically no way to tell is it open or closed neither, just by touching the radiator or forcing it to close.

1 Like

sigh I have a suspicion about what happened. I’m checking to see if support has escalated anything to the internal ticketing system, and to see if I can track down the right individuals to fix this.

2 Likes

I just wanted to leave a note that there is a high priority ticket to track the progress of this. There are no updates right now.

6 Likes

Just guessing, but it feels like the Capability Presentation has been messed up, and it is missing the Heating Setpoint from there. But I can never know what has been done in the background with the UX plug-in for that capability. As it was noted before, the Automation part seems to be actually working, so that must be still there.
Thanks for looking at it!

2 Likes

Unbelievable. If I would maintain/release software like this I would be sacked.

2 Likes

Thanks for the info! Look forward to getting the correction.

I have the same issue on my Popp TRV. I have noticed I can still control it by the old Smartthings app, bit it has disappeared from the new app. I can also control it by a task as a workaround.

#metoo. LC13, temperature set-dials have disappeared :sob:

Today I took advantage of the BlackFriday prices for ActionTiles. I’m pretty happy that the control of the temperature set works from ActionTiles in addition to routines :slight_smile:

1 Like

Same for Fibaro Heat Controllers.

Was going insane, tried to exclude/include the units multiple times, but it didn’t work.

Happy to hear you’re looking at this.

Custom DTH fixed the issue allowing Google assistant to adjust them. However, since the forced switch to the new app those DTH’s no longer work at all.

Yep, and lc13 are officially supported… :roll_eyes:

After upgrading I saw that the custom handler wasn’t working any more and changed it to the standard one, which worked straight away. Great, I thought - it’s properly supported… until I tried to set the temperature. How can there be no controls? It’s pointless. The only thing you can change it to disable the controls on the device itself.
Please fix this - I mostly use it manually.

Hi, issue is now fixed with latest SmartThings controller version.

Still it doesn’t allow to increase temperature by halves of degree, which is manually possible.

2 Likes

Donald, can you please follow up on this ticket to ask for enabling temperature management with same resolution as the Danfoss device, so by halves of degree?

Currently neither automation nor recently re-enabled manual temperature setting allow it, so you need to stick with full degrees only.

@dckirker, I can confirm that the controls are working again for heating setpoint.

1 Like

@Kokers, it is odd, the

vid: "generic-radiator-thermostat"

Allows half a degree adjustment.