Damn Sonos and Webcore

Hello. I’m totally pilling my hair out over here - I’m using the new Smartthings app, with the new Sonos device handlers (web socket).

I had a text to speak door bell working perfectly until I did this update, and I understand that the new device handler for Sonos soeant support TTS, so I’ve switched to having the doorbell play a mp3 instead.

My problem is I can’t get the damn mp3 to play on my Sonos. The mp3 is in a dropbox and works totally fine. The address of the file is https://www.dropbox.com/s/u2azr8w77vdct8g/Doorbell.mp3

But what exactly do I add in the play track URL box within webcore?

Thanks in advance - I must be missing something obvious, which as a sleep deprived new dad is becoming oh too common :wink:

What kind of doorbell are you using?

Its an Arlo camera, so I’m using the motion off that. I can post the webcore screen shot but it used to work fine with TTS. I’m just trying to replace the TTS with ‘play a mp3 from dropbox’

Cheers

you should be able to use motion from an Arlo camera to generate TTS with the new app automation creator.

I think you want: https://www.dropbox.com/s/u2azr8w77vdct8g/Doorbell.mp3?dl=1

Dropbox’s URLs are a bit of a lie. When you go to the plain URL as you posted, you get a webpage with a download button. Adding ?dl=1 to the end will make it directly redirect to the file.

4 Likes

thanks for the reply - yes I can do it from the new app automation creator, BUT…

I have a webcore piston that triggers the TTS or mp3 when motion is detected at the front door, and then using a local variable, it won’t trigger again for 3 minutes (so say the postman doesn’t trigger it when he leaves, only when he arrives) It works really well to prevent annoying false alarms.

Do I have alternatives to webcore, or is it a sonos device handler issue? I’ve just started looking at sharptools. Hopefully I can fix it.

So my question still remains, what URL do I type in the play track box to play an mp3 from drop box?

Thanks

1 Like

ah, ok. Patrick gave you a good idea to try.

Ah yes - thanks for that. It still isn’t playing though. I can see in my sonos controller that it tries to play the mp3, and interrupts whatever is playing…but no sound!!

Here are screenshots of the piston, I’ve changed the input to the light switch for testing and put the do not repeat flat to 3 seconds…

your url is incorrect. It should be:

https://www.dropbox.com/s/u2azr8w77vdct8g/Doorbell.mp3?dl=1

That will actually access the file. dropbox.com?dl=1 isn’t going to go anywhere.

A good rule of thumb is, if you can type the URL into your browser and it either brings up a media play window or it downloads the file WITHOUT doing anything else, it will work. If you have to hit a download button or anything else, it isn’t going to work. Github “raw” files work really well too for short clips and a github account is fee.

Ah yes - I have the correct url - the screen shot I sent was done manually on my phone as I couldn’t screen grab the piston via the app (it only showed you half the url). I’ve stripped it down to absolute basics, and it just won’t play the mp3! The sonos app says reports the track playing as ‘smart things audio notification’ but no sound.

If I set sonos to play, say, a radio station, then pause it - then have the piston simply ‘play’ the sonos, it works fine and resumes the radio station…

bloody updates!! thanks for your patients.

OK - I’ve tried loads of variation - including using the built in automation tool in the new smart things app. It works. Everything is fine…

BUT - when I try and play a track from dropbox, or a website url, it simply won’t play. If I set the volume at a certain level I can see in my sonos app that the volume changes, but I’m always greeted with ‘Unable to play smart things notification, the audio is not encoded correctly’

Any help gratefully received…I know this should be so simple, and it used to work perfectly, for door bells and other audio notification I had triggered using webcore. Now its all gone to sh!t!

Boring update alert in case you were wondering…

it works - if I use mp3 from a website - still no joy from dropbox.

Thanks for your time

2 Likes

I use github. It’s free and you can sync with a folder on your desktop.

1 Like

Thanks Ryan,

You use github to host the mp3/raw files? Or do you sync with a PC folder and have the computer running all the time?

Could you point me in the right direction? I use github to install and update webcore and the odd device handler - it always feels a bit beyond my comfort zone but the help files are great.

cheers

You can create your own repo and then use github desktop to sync the files to github. You don’t need to have a PC running 24/7 for the files. They upload to the Github cloud.

Here’s an article to help you.

https://help.github.com/en/github/getting-started-with-github/create-a-repo

Ahh i see, so github is used very much like dropbox? But you report it works well and is fast.

Its crazy how I have it at the moment - with the door bell accessing the file on some random website. If they move or change the URL my system falls over…

Yup…the only thing with Github is that unless you pay for a memebership, eveything is public. So don’t store anything personal up there. :slight_smile:

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.