Cstat 17-zw

Has anyone added a Horstmann c- stat 17-zw to ST yet?

I’ve tried a number of handlers inc the 321thermostat and I can’t get it fully working.
I can sometimes get a device to appear in ST but no temperatures or set points are reported or controlled.

Thank you.

It should work it has support for the command classes

Supported Command Classes

    Manufacturer Specific
    Multilevel Sensor
    Schedule V1
    Switch Binary
    Thermostat Operating State
    Thermostat Setpoint V2
    Wake Up

Controlled Command Classes

    Thermostat Mode

When using the stock ST device handler, what do you see in the logs?

Do you know which handler I should be using? The “Zwave Thermostat”?

Nothing appears in the logs unfortunately. I see the ST commands being sent, but nothing returned from polls or configures.

I’ve tried the handler that works on my SRT321s, and most with a thermostat in the name. Don’t know what I’m doing wrong.
Remove device by general exclusion. Reboot ST. Reset thermostat.
Add device, ‘stat to learn. ‘Stat recieves network data. ST defaults to the 321handler I have installed for other devices. Then nothing updates.

Tried again tonight, will leave it overnight and hope.
Thank you so far.

Correct Z-Wave Thermostat should be work. You should see atleast something in the logs starting with

Parse returned

If you aren’t seeing that then the thermostat hasn’t paired properly. Try these steps (exactly) and then see if it works:

Thank you,

Repeated reboot and reset, hopefully there with the communications between the devices, so they should be added,

They will return the current temp and set point, but the logs show that the set points aren’t being changed by ST:

09e8906e-1e20-4aa9-8fc8-45b225da9a13 18:55:38: debug Parse returned [[value:21.0, unit:C, displayed:false, name:heatingSetpoint, isStateChange:false, linkText:SRT321 Thermostat, descriptionText:SRT321 Thermostat heating setpoint is 21.0°C]]
09e8906e-1e20-4aa9-8fc8-45b225da9a13 18:55:37: trace setHeatingSetpoint(18.0, 1000)

Any ideas?
Thank you

i just this out of the wave tweaker:

09e8906e-1e20-4aa9-8fc8-45b225da9a13 19:14:06: info Discovery Stats:
Number of association groups discovered: 0 [Print Assoc Groups]
Number of endpoints discovered: 0 [Print Endpoints]
Number of parameters discovered: 3 [Print Parameters]
Number of unique command types received: 7 [Print Commands]
Number of MeterReport types discovered: 0 [Print Sensor]
Number of NotificationReport types discovered: 0 [Print Sensor]
Number of SensorMultilevelReport types discovered: 1 [Print Sensor]
09e8906e-1e20-4aa9-8fc8-45b225da9a13 19:14:06: info General Information:
Device Name: SRT321 Thermostat
Raw Description: zw:S type:0800 mfr:0059 prod:0004 model:0001 ver:1.00 zwv:3.42 lib:02 cc:72,86,84,80,43,31,70
Supported Command Classes: [SENSOR_MULTILEVEL (0x31), THERMOSTAT_SETPOINT (0x43), CONFIGURATION (0x70), MANUFACTURER_SPECIFIC (0x72), BATTERY (0x80), WAKE_UP (0x84), VERSION (0x86)]
Security: Device is not using security.
Manufacturer ID: 0059
Manufacturer Name: null
Product Type ID: 0004
Product ID: 0001
Firmware Metadata: Firmware ID: null, Checksum: null
Application (Firmware) Version: 1.00
Z-Wave Protocol Version: 3.42
Z-Wave Library Type: 02 (Controller)
Powerlevel: null
Protection Mode: [ Local: null (null), RF: null (null) ]
Switch_All Mode: null (null)

Still nothing with the c-stat 17-zw.

It seems to be adding ok. It even updates the last active time in the app, but no updates to temperature and no control of the SetPoint.

Using the standard z-wave thermostat handler after giving others a few days each to settle.
Nothing. :frowning:

Any other ideas?
(Worked fine on a Vera Edge)

I was hoping the new firmware (18.18) would help, but i’m still struggling to get this Cstat working.

It adds fine, and after a bit of playing with he z-wave tweaker i think i understand the problem - it’s the wake up interval that’s currently set for 24hrs. Hence it’s not picking up any changes i make in the app, and rooms temperatures are inaccurate.

Is there a way to set the wake up interval to 900s?
All the device handlers i’ve tried don’t update it if there is a field for setting it. Wave Tweaker doesn’t have that field either. The device parameters doesn’t have it, so i can’t push it through.
Is there a code or anything i can use to set the interval to 900s, not 24hrs.

thank you.

I get this on the wave tweaker

c5f1469f-93e9-4d66-9c1a-521514902e8c 11:22:14: warn zwaveEvent(): No handler for command: WakeUpIntervalReport(nodeid: 255, seconds: 86400)

Hi Tom, did you every figure this one out? Were you just using the C-Stat 17w or the receiver HRT4-ASR-ZW as well? I can get it to connect and set temp but it seems to disconnect the ASR so the boiler goes into safety shutdown as it hasn’t received a signal from the thermostat. I saw on other forums that although these are Zwave they are only designed to communicate with each other not integrate into a system.

Any ideas anyone?

No, I never got it working myself.
It wasn’t connected directly to a boiler device as such, but it was associated to other on/off devices. These worked fine and with a Vera controller, just that the SetPoint wasn’t changeable by smartthings.

I’ve found the same. I can have them either (a) communicate with each other, or (b) see the thermostat in smartthings .

when it’s (b), turning the dial shows changes in real time in smartthings, but has absolutely no effect on the ASR, so regardless of what the temp says, the boiler won’t fire.