CoRE capture() / recordClip() with ARLO wireless camera

I am trying to use a simple piston to capture video off a ARLO wireless camera when a door sensor opens. Currently using the capture() action with no parameters and have also tried recordClip(). The piston fires but nothing happens in either situation. Do I need to pass parameters and if so how do I find out what they are?.

(I know I can capture due to motion but specifically wanted to catch a snapshot (ideally) when door is opened.

Any help appreciated!

If I get motion on my Ring doorbell, I’m kicking off a 30-sec video clip from my front-porch location Arlo camera via the ‘recordClip’ option. Parameter Type of ‘decimal’ and Parameter Value of ‘30’.

For some reason the ‘recordClip’ option had disappeared for me in CoRE. I can no longer force my Arlos to record from other sources/situations. Anyone else seeing this ?

I never actually got mine to work using recordClip but I agree the ‘recordClip’ option seems to have disappeared off my CoRE options as well

I think so. I’m still learning. I just picked the command when I linked up Arlo to ST and then accessed what was exposed in CoRE like all my other devices.

Anyone get Arlos working with CoRE or WebCoRE? Tried capture and stream with no resulting images/videos in Arlo app library.

1 Like

Any updates on this? Recordclip is no longer available. Don’t understand why it was removed.

I can see the recordclip option and the capture options on my Arlo wireless but I still can not get them to actually record or capture with CoRE. I tried 6 months ago when I got them and just today after reading this thread and still nothing. I’m sure I must be doing something wrong.

The only way I have found to trigger a recording from a webCoRE piston is using IFTTT webhooks.
example piston shown is very basic just to see if it would work and it does and creates a recording in the Arlo Library.

Switch 20 is a virtual ON/Off switch I created just as a test trigger for the piston

Motion Sensor 1 is my Arlo Camera

Obviously you need to set up the IFTTT url in webCoRE dashboard settings .

Then create an IFTTT applet using Maker Webhooks and Arlo.

It a work around solution but it works.

No option that I can see in IFTTT for capture though.

@twack @Tyler - why doesn’t Arlo work with CoRE/WebCoRE? Can we get this fixed? Also would be great if we could take a photo/snapshot with the Arlo too instead of only video recordings (maybe Arlo API doesn’t support this yet as it’s not in IFTTT either).

It’s an API limitation unfortunately.

We should be able to trigger record from webCoRE though right?

I’m not sure, @twack might be able to provide more information.

I believe CoRE/WebCoRE filters for devices with the capability “Video
Capture”. If this is true, Arlo cameras will not be able to be picked
because they do not currently support that capability. We are working with
Netgear/Arlo to implement this feature in the future. No time table at this
time though.

Hope this helps,
Todd

3 Likes

thanks for the feedback

is there another capability core could use to get video recording working? thanks again!

for those on this thread - I decided just now to test, I tried recordclip, no matter what type of parameter or the value, it seems to record a 30 second clip, so that’s progress. capture didn’t do anything as far as I can tell, as I may have mentioned on another thread, one of the things thats interesting that no matter how recording is triggered (arlo/ifftt etc, the camera “motion” changes to active)

also it seems recordclip REQUIRES a parameter for recording to work, any number, but without a parameter the camera does not record, go figure

Thank you for the info. I’m not seeing record clip though, can you post your piston? Thanks again!

1 Like

I hope this isn’t based on some BS like at what point I authorized ST to work with arlo

I mentioned in another thread, I need to spend way more time with SHM, it also has the capability to do 2 minute clips