Controlling relay with sunrise and sunset routine

Hi all, this seems to be a topic of much discussion on these forums but everything I’ve looked through doesn’t seem to have a working solution - unless it’s buried in all the threads! I have a Fibaro single relay controlling an outdoor light which I want to be able to turn on 15 minutes after sunset and turn off 1 hour before sunrise.

I initially setup two routines in ST; one to turn on at sunrise and another to turn off at sunset. Problem with this method was that although ST notified me that it has turned on/off the light, it didn’t actually turn on/off. I then tried the smart lightning SmartApp and a single routine which did what I want. This time, I didn’t get any notification (not sure if the SmartApp is even meant to send one tbh) and neither did the light turn on/off at sunset/sunrise.

I’ve checked the sunrise/sunset times in my IDE and they are fine. Anyone know what I’m missing to get this working? It’s such a simple bit of automation and I really expected it to work first time.


If you got the notification, it sounds like you set up the automation OK, and the problem is most likely something with your network in reaching the device. Have you talked to support about it yet?

Oh really? Hmm no I haven’t asked support. I’m in the UK so is it the same link?

You start from the same link and then on the menu there’s an option for UK support.

Or here’s the direct link:

@anon36505037 might also have some thoughts, he uses a lot of fibaro kit.

OK great, thanks. I will contact support.

I had removed the routines when I tried the SmartApp so I’ve reinstated them now in case it was a one off network issue.

When’s the last time you did a zwave repair?

I literally had the relay installed on Friday and set the routine up on Saturday. So though I can try that z wave repair it doesn’t feel like that would be the issue. I can control the light fine manually through the ST app and toggle switch.

1 Like

Did you run a Z wave repair after you installed the device for the very first time? It’s a good idea to do that anytime you’ve installed a new device. It just gets all the neighbor tables up to date.

And if there is a range problem, Z wave repair should show you error messages for that device.

I agree it doesn’t seem like that should be the problem since it works through the app, but it’s one of those “can’t hurt, might help” kind of things. :sunglasses:

Oh right. No I didn’t. I actually had the relay and 5 dimmer 2 modules installed on Friday so it definitely sounds like I should run that repair. I will do that now.

1 Like

So I’ve tried the z wave network repair a couple of times and all I get is the whirring icon and the screen that says “Z wave network repair started”. It doesn’t seem to come out of that. I’ve had it going half an hour so far and still no change.

Any thoughts why?

OK so I shut down and restarted my hub and then initiated the repair from the ide and that seems to have worked. After a few minutes I saw a line added to the table on the Web page for my hub and the value was “finished”. So I guess that’s the network repair done…

1 Like

And I’ve had a pretty (unhelpful) response from ST UK support saying that because the Fibaro single relay isn’t on their list of official supported devices, they can’t help with my issue. Great.

I setup the standard routines again to turn the outdoor light on at sunset and off before sunrise and again, I got the notification from ST that the light had been turned on at sunset, but hadn’t actually been turned on. I’m a bit baffled…

I’ve also been getting to grips with CoRE recently and thought I would try and setup a piston to do this but for some reason I can’t seem to be able to select a relay switch to control as part of setting up the piston. Help please!

I’ve managed to get this working. I switched the device handler for my relay to the generic Z Wave Switch and setup webCoRE on my IDE and created a piston with that - it works great.

1 Like