SmartThings Community

Connection to Domoticz defined devices like Blinds and On/Off switches

somfy
x10
rgbw
project_shades

(Martin Verbeek) #624

Will check it out. Need to recreate a virtual mood switch.

met vriendelijke groeten,

Martin


(Martin Verbeek) #625

just a small test, could you rename (in domoticz) to Kitchen Mood Switch? and hit refresh in SmartThings on the created device.


(Mike) #626

Interesting… There are now mood buttons, but the status is Off when it should be Group Mood 4, even after a refresh



(Martin Verbeek) #627

could you hit mood 4 in smartthings and see what happens?


(Mike) #628

Seems to be working! Status in domoticz is now in sync with the app


(Martin Verbeek) #629

The only way of really knowing i am dealing with a mood switch is to check for MOOD SWITCH to be present in the name and hardware being lightwaverf…will change logic to check for MOOD only but it seems a bit too wide check. Have fun!


(Mike) #630

Thanks! I’ll change the name of the other mood switches. I’m about to set up some rules in webcore. When I add devices, do I need to select all of the mood switch actuators? There seems to be one for each button


(Martin Verbeek) #631

Guess so, but not a user of core myself. But all buttons are separate devices.


(Mike) #632

Got it working. Thanks so much, I now have use of all 6 buttons!


(Farhanito™) #633

i don’t know what’s going on, but all of my selector switches are not working now.

tried removing and re-added those devices, doesn’t help.


(Martin Verbeek) #634

Anything updated in domoticz? Could you check the live logging in the ide for domoticz server app and device?


(Farhanito™) #635

not sure about updates, using domoticz stable 4.9700

what i saw from live logging in the ide

domoticz server

5:39:23 PM: info childs : 43
5:39:23 PM: info state size : 40
5:39:23 PM: debug getChildDevices(false), children=43
5:39:23 PM: info Delete from State devices []
5:39:23 PM: info Deleted, remove child devices []
5:39:23 PM: info New in Domoticz[]

all others devices in question showing only

5:44:20 PM: info [updateChildren]

seems like all my selector switches failed getting child devices. showing only NULL or some alphanumeric value in the mobile app. (i’ll update with mobile app screenshot)


(Martin Verbeek) #636

Will run a test later today…


(Martin Verbeek) #637

something has changed in DOmoticz, the content of field level actions has changed…to something not very meaningful…


(Martin Verbeek) #638

LevelNames are being encoded in the latest stable if Domoticz, i have changed code to decode. Update to 7.12 should fix the issue.


(Farhanito™) #639

updated. everything’s back to normal :slight_smile:

thanks


(Darren) #640

@dudz40 hey martin, still working hard on the code I see :slight_smile:

Everything is working great for me still but as ST have their numerous outages i’m finding myself moving devices around to local processing where I can.

In relation to this integration I assume this is deemed cloud based as

Domoticz is local
Handler is cloud
ST Hub is local

Just looking into my options :slight_smile:

Thanks and keep up the great work.


(Mike) #641

I’m finding that my mood switches are being triggered in the middle of the night but not sure why:
2018-09-04 5:24:13.412 AM BST
2018-09-04 5:24:13.387 AM BST

Nothing in the domoticz events log for the same device:

image

Any ideas?


(Martin Verbeek) #642

sorry, was away for a while. Still experiencing this?


(Mike) #643

No problem.
Yes still happening, no idea why though!