SmartThings Community

Connection to Domoticz defined devices like Blinds and On/Off switches

somfy
x10
rgbw
project_shades

(Richard Blackman) #644

Long time Domoticz user, fairly new to ST. I have managed to connect the two together, I can control on/off switches from within ST and see changes in contact switches ok. However, if I set up an automation in ST to trigger an event when a contact switch is opened it doesn’t work. Any ideas?


(Martin Verbeek) #645

Hi Richard, could you tell me where the real devices are? Are events from domoticz devices being processed by ST?

Are the notifications set in domoticz by the app?

It can go wrong in a couple of ways, so i might ask a few questions too many🤔

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------


(Richard Blackman) #646

Most of the devices are on windows. When opening one it registers in Domoticz, the notification is set ok and ST registers that the device is open. All looks good. But if I create an automation in ST to, say, turn on a light when the window opens then it doesn’t work. However the automation works if I use a ST sensor. Hopefully this is a clearer explanation.


(Martin Verbeek) #647

Sometimes ST is picky. Could you have a look in the ide, select the contact device and look at the events it has. I am interested in how open and closed are spelled, specially the capitals.

met vriendelijke groeten,

Martin


(Richard Blackman) #648

Open and Closed are spelled with just the first letter capitalized.


(Martin Verbeek) #649

Looks like there has been a change, I will change the status to lower case. Will be tomorrow when I push new version.

Thanks for helping out.


(Richard Blackman) #650

Thank you so much for your work on this.


(Martin Verbeek) #651

New version on repo. Curious if it solves the issue.

met vriendelijke groeten,

Martin


(Richard Blackman) #652

Yes, my initial test after loading the update worked. I set an automation in ST Classic to turn on the stair lights (which is using an ST smart plug) when the office window opens (using a domoticz sensor) and it worked. It will probably be next week now but I should be able to set up the alarm using ANY open/close sensor whether it is ST or Domoticz and have it activate on trigger.
Thanks again, a really useful script. It would have been pain if I had to replace all the window sensors for ST ones, and expensive too.


(Martin Verbeek) #653

i am using alarm the same way, it is also a combi of ST and domoticz devices, you should be fine. Have fun!


(Daniel Consuegra) #654

Ugh… don’t know what I did, but the Netatmo Thermostat stopped connecting to ST… What should I do? Might as well start all over…


(Martin Verbeek) #655

Is it my device handler for thermostat? Any error? What is the issue you see?

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------


(Gareth) #656

Hi there,

I’m setting up my Yeelight and I’m getting the following warning in the logs in the IDE:

No event handler found for ssdpTerm event ‘devicetype:04, mac:00178827F83F, networkAddress:C0A80110, deviceAddress:0050, stringCount:04, ssdpPath:/description.xml, ssdpUSN:uuid:2f402f80-da50-11e1-9b23-00178827f83f, ssdpTerm:uuid:2f402f80-da50-11e1-9b23-00178827f83f, ssdpNTS:’

This happens after the light has been added to the server and I’m trying to push the light into the Smartapp. Any ideas where I may have gone wrong?

Thanks


(Martin Verbeek) #657

Yes, will indeed happen after addition. It will be corrected automatically. Should not impact the operation of the device. Let me know if it does.


(Gareth) #658

The device isn’t being added though. Just noticed I’m getting the server is not responding so suppose there is a connection issue. I’ve copied the Action URL…I can control the device from the server but unable to pull the device data into Smartthings


(Martin Verbeek) #659

You could open the app again and check if you have true indicated after valid setting in domoticz?

Press Save would reset heartbeat from ST to domoticz


(Gareth) #660

Valid setting is saying false so I must check things again. I’ve copied the URL from within the app so I’m assuming that’s the right thing? Apologies for being a numpty…


(Martin Verbeek) #661

Should be the correct one, but also see a lot of problems when copying in the app on a mobile. Most safe way is to do it in a desktop browser.


(Gareth) #662

Hey there, it had to do with the firewall settings on the server side. Sorry to have messed you around but thought I should let other people know that it may be an issue for them…Thanks again!


(Rob) #663

@dudz40 thank you very much for the fantastic work on this intergation.
I need some assistance please. I have 3 Oregon temperature sensors setup as a start in Domoticz, they show up in Smartthings but don’t automatically update the temperature values unless I press the refresh button.
I can’t for the life of me figure out why it isn’t working. I have checked the notification settings in Domoticz and there are no errors in the log, only successful connections -
2018-12-27 08:04:57.164 Notification sent (http) = Success
On the Smartthings side I don’t see any errors in the live log and the “Valid setting in Domoticz” says true.
I have tried to recreate the Access Token and have made sure the custom URL is correct on both sides but still temperatures don’t update in Smartthings unless I do so manually.
Any help would be much appreciated!

Rob