SmartThings Community

Connection to Domoticz defined devices like Blinds and On/Off switches

somfy
x10
rgbw
project_shades

(Martin Verbeek) #604

it is missing a devicetypehandler called domoticzOnOffButton These will be the mood button devices that you can use to automate tjings in SmartThings


(Mike) #605

Just published the domoticzOnOffButton. The same set of DTH are still in the list and I still get the errors


(Martin Verbeek) #606

i do not see domoticzOnOffButton??


(Mike) #607

That’s what I thought, but I have published it twice. Is it different to domoticzOnOff?


(Martin Verbeek) #608

i see the issue…

A while back i have moved all my stuff away to a seperate git repo…please add the first one to your settings and
image
point your current sources that has to do with domoticz to Domoticz-Server repo.

I have created a seperate child device per capability to be more dynamic in the tiles i show or not. It will give you a lot of DTH´s though…domoticzOnOffButton nis part of this repo


(Mike) #609

I’ve point to the new repo but still showing the wrong name. Not able to delete as used by other devices

Off to bed now but will have another crack at this tomorrow. Thanks for your help


(Martin Verbeek) #610

Go to update from repo and the new devices should show, just select all and publish.
Do not delete existing ones they are not the same or a replacement, it is really a new one


(Mike) #611

This is what I have selected


Do I need to select all in that list?


(Martin Verbeek) #612

Please select all, you might not need all of them, but no harm.


(Mike) #613

Hi Martin, I now have everything published, but still getting the error

Noticed I have domoticzOnOff and domoticzOnOffButton

Any ideas? Think I might need to start from scratch


(Martin Verbeek) #614

Hi Mike, i will take a look early tomorrow.

met vriendelijke groeten,

Martin


(Martin Verbeek) #615

Could you paste state? goto my locations/smart apps/domotics server and locate the State section, I am interested in what is in there.


(Mike) #616

Sent you a PM with the state


(Martin Verbeek) #617

Thanks! Will check it out.

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------


(Martin Verbeek) #618

All looks like it should go correctly…i cannot see an obvious reason why this is producing a null error.

Could you do me a favor and remove / reinstall the app, maybe something was messed up due to the missing devices and errors it will give. I will make this part more robust.

thanks for the patience.


(Mike) #619

I’ve started again and I think that error has gone now.

There’s something I’m a little confused about: When adding the domoticz devices through the smart app, the mood switches still come in as domoticzonoff. I thought the device handler for these is now domoticzonoffbutton?
image

Also, the notifications sent from domoticz is on/off, so the group state is not sent to smartthings


(Martin Verbeek) #620

Button is a child device of the domoticzonoff device, it will be added dynamically. Could take a little. You can see additional buttons appearing on the main device kitchen mood which behaves like a normal switch. If you click on the kitchen mood in the ide you should see the button device appear. You can use these mood buttons in automations


(Mike) #621

I think I need to create a new token but when I try I get ‘Somethings Wrong’

My current domoticz url ends in access_token=null&message=#MESSAGE


(Martin Verbeek) #622

You indeed need a new httpAactionUrl in Domoticz, the app was fresh installed. You have to enable oauth for the app in the ide, that will allow the app to create a token.


(Mike) #623

Thanks that worked. Think I’m nearly there!
I’m still not seeing state changes of the mood switch. If I change from one mood to another, the status sent from domoticz is Off. Only if I select the refresh button does it give the correct mood button.

Should domoticz still be sending On/Off status? Shouldn’t this be Mood 1, 2 etc