SmartThings Community

Connection to Domoticz defined devices like Blinds and On/Off switches

somfy
x10
rgbw
project_shades

(Ed) #584

According to Domoticz device list = 569, I don’t use them all but on the tabs about 150, some of them being combined like TH + RH


(Ed) #585

Or course! Thanks for looking into it


(Martin Verbeek) #586

The error only happens when the initial child devices (capabilities) are added, modified code to test for it. The error is not related to the problem in domoticz.


(Martin Verbeek) #587

are you seeing these types of messages if you leave logging running for a while, especially the [eventDomoticz] ones, this is where the notification messages from Domoticz come in…image

One other thing to try is the following, copy the Url/Action from HTTP notification in domoticz into address of a browser and hit enter, it is OK if it does return a blank screen, otherwise i am interested in the info that comes back.


(Ed) #588

Tried the link but outside my home (at work now) and returned this:
{"error":true,"type":"AccessDenied","message":"This request is not authorized by the specified access token"}

I guess I need to be on the same LAN


(Martin Verbeek) #589

No need to be on the same lan. Could you go to the smart app and do revoke access token? It will get you a new one. Save, to be sure and copy paste the newly created customactionurl into domoticz.


(Ed) #590

Done, all seems to work now. I still seem to have the odd error on Domoticz log, like:
2018-06-27 22:02:16.033 EnOcean: 01 (0A/07) A5 73 4F 76 0E 05 03 D5 8E 00 01 FF FF FF FF 56 00
2018-06-27 22:02:16.033 EnOcean: destination: 0xffffffff RSSI: 14
2018-06-27 22:02:16.033 EnOcean: 4BS data: Sender id: 0x0503d58e Status: 00 Data: 76
2018-06-27 22:02:16.039 Notification: SENSOR 935 Temp 23.6
2018-06-27 22:02:16.041 (EnOcean-USB) Temp + Humidity (TH / RH Co2)
2018-06-27 22:02:16.061 Notification: SENSOR 936 AirQuality 790
2018-06-27 22:02:16.062 (EnOcean-USB) Air Quality (Co2)
2018-06-27 22:02:16.136 Error: HTTP:
2018-06-27 22:02:16.136 Notification sent (http) => Failed
2018-06-27 22:02:16.239 Error: HTTP:
2018-06-27 22:02:16.239 Notification sent (http) => Failed

this is a triple sensor, I have created a composite one with it, TH and RH are ok but CO2 shows = 0 on the ST App. The error seems to happen on the composite sensors.

Honestly, no need to solve this for me, you have been very helpful, so feel free to ignore me. I’m happy as it is, and it is a lot more than I had 2 days ago! :smiley:

Out of curiosity, when I trigger a switch on Domoticz, how long would I have to wait to see it on the App? Domoticz to ST does not seem to refresh automatically until I force a refresh on the App.

However the other way around works, ST to Domoticz refreshes ok.


(Martin Verbeek) #591

Should be pretty quick, the notification will result in an event in ST, but sometimes the ST cloud is busy


(Martin Verbeek) #592

Not aware that I did co2, will do some checking.


(Ed) #593

More than happy to keep providing feedback if it helps you make even better the plugin :slight_smile:
I have quite a hybrid system, for example I can see some thermostats also showing part of the information (I have Evohome and Z-wave TRVs combines).

Then I use wired contact switches for my doors and these are displayed on the app as very smart devices with battery, temperature, etc… I guess is in reference to the original ST sensors.

More than happy to provide feedback if it helps, for my I’m happy as it is now.


(Martin Verbeek) #594

Please do, always looking for suggestions etc…

The CO2 is Airquality sensors? if so could you paste the output of

domoticzIP/json.htm?type=devices&rid=your sensor idx


(Ed) #595

More than happy to do so!

{
   "ActTime" : 1530177355,
   "AstrTwilightEnd" : "00:00",
   "AstrTwilightStart" : "00:00",
   "CivTwilightEnd" : "23:05",
   "CivTwilightStart" : "03:38",
   "DayLength" : "17:28",
   "NautTwilightEnd" : "00:00",
   "NautTwilightStart" : "00:00",
   "ServerTime" : "2018-06-28 10:15:55",
   "SunAtSouth" : "13:05",
   "Sunrise" : "04:38",
   "Sunset" : "22:06",
   "result" : [
      {
         "AddjMulti" : 1.0,
         "AddjMulti2" : 1.0,
         "AddjValue" : 0.0,
         "AddjValue2" : 0.0,
         "BatteryLevel" : 255,
         "CustomImage" : 0,
         "Data" : "1050 ppm",
         "Description" : "",
         "Favorite" : 0,
         "HardwareID" : 13,
         "HardwareName" : "EnOcean-USB",
         "HardwareType" : "EnOcean USB (ESP3)",
         "HardwareTypeVal" : 31,
         "HaveTimeout" : false,
         "ID" : "0003",
         "LastUpdate" : "2018-06-28 10:11:55",
         "Name" : "Co2",
         "Notifications" : "true",
         "PlanID" : "12",
         "PlanIDs" : [ 12 ],
         "Protected" : false,
         "Quality" : "Fair",
         "ShowNotifications" : true,
         "SignalLevel" : "-",
         "SubType" : "Voltcraft CO-20",
         "Timers" : "false",
         "Type" : "Air Quality",
         "TypeImg" : "air",
         "Unit" : 213,
         "Used" : 1,
         "XOffset" : "0",
         "YOffset" : "0",
         "idx" : "936"
      }
   ],
   "status" : "OK",
   "title" : "Devices"
}

(Martin Verbeek) #596

Thanks, this is what I expect, need to look into code why it is not updating automatically.

met vriendelijke groeten,

Martin


(Martin Verbeek) #597

Actually it is updating correctly in my setup…could you check for events at the follwoing place? go to the composite sensor in ide under devices and click on the child device for AirQuailty to see it’s events, if all is good they should show…


(Michael Ekers) #598

Has anyone tried to use blinds from domoticz in alexa, for some reason if you tell alexa to open the blinds it closes the blinds and if you tell it to close the blinds it opens them, has anyone found a solution to this ?


(Martin Verbeek) #599

Thought there always was an issue with open and close support by Alexa? Is that no longer an issue?

met vriendelijke groeten,

Martin


(Michael Ekers) #600

no clue, i would have thought you could change domotics to map on and off differently maybe ?


(Ed) #601

Yes it is there, I can see air quality option, it just shows zero value


(Martin Verbeek) #602

are you looking here under devices, select your main composite device:

click on the air quality device,you see something like this:

if you then click on Airquality, evry curious what you see now:


(Mike) #603

Hi, finally found some time to try and get my mood switches working. With the latest DTH and Smartapp it looks like the mood switches are recognised. The one I have set to mood now has a LWRF logo, and it changes to the button name that is pressed - great work!

I noticed in the live log I’m getting a few errors, any idea what these are?