Command 'getDataValue' is not supported by device?


(Jeffrey) #1

Last few days I noticed an issue with some code that connects with my ISY. When I hit refresh in the IOS app in the logs I see:

 java.lang.IllegalArgumentException: Command 
 'getDataValue' is not supported by device 
 f4444ec6-017f-405d-93cd-bef5396820e0 of type 'ISY Switch'. Supported 
 commands: [on, off, poll, refresh] @ line 66

Did something change somewhere with getdatavalue or any changes in the APIs?


(Todd Wackford) #2

What is the syntax of the line that is throwing the error? Can you post that line here?

TIA


(Jeffrey) #3

Getting on a plane and can post more later but a snip is:

    def childMap = [:]
    parent.getChildDevices().each { child ->
        def childNodeAddr = child.getDataValue("nodeAddr")
        childMap[childNodeAddr] = child
    }

(Todd Wackford) #4

Is the code from the DTH? If it is, change the lie to read:

def childNodeAddr = getDataValue(“nodeAddr”)


(Jeffrey) #5

This is in the DTH. I will look into the change later. Did something change? This has worked fine since beginning of the year and just “broke” a few days ago.


(Todd Wackford) #6

did you just add another device of this type?


(Jeffrey) #7

No that is the weird part - no changes or added devices in many months.

The guy who wrote the actual code is seeing the same problem so I have to assume something changed on the backend?

The full code is here: https://github.com/rllynch/smartthings-isy994i


(Jeffrey) #8

No change - same error:
java.lang.IllegalArgumentException: Command
’getDataValue’ is not supported by device
0328c5ce-b394-4cd9-83c7-af090ad8ae50 of type ‘ISY Dimmer’. Supported
commands: [on, off, poll, setLevel, refresh] @ line 66


(Todd Wackford) #9

@jjslegacy,

Please submit formal ticket so this can be looked into by the right people.

Twack


(Jeffrey) #10

Todd,

By submit a ticket do you mean e-mail support or is there some other process? I did email support yesterday that and was pretty much told sorry we have no idea and can’t help with custom code.


(Todd Wackford) #11

Email support please.

Include that "getDataValue does not work in Device Definition File as oulined within SmartThings documentation: http://docs.smartthings.com/en/latest/cloud-and-lan-connected-device-types-developers-guide/building-lan-connected-device-types/building-the-device-type.html#getting-the-addresses "


(Aaron S) #12

Please reference this thread when you email support so we can immediately get it escalated to the right people (front line agents are supporting end users, not developers)


(Jeffrey) #13

I have passed it along to Jake (not from statefarm) as he’s the guy on my support ticket.

thanks guys!


(Asish V) #14

This is breaking my home security system. It seems something changed on Sept 7th.
error java.lang.IllegalArgumentException: Command ‘getDataValue’ is not supported by device 65f94589-a568-47a4-a59e-6df9bee39fcd of type ‘RPi Home Monitor’. Supported commands: [poll, refresh, subscribe] @ line 43


(Jeffrey) #15

It would seem it broke with the platform update on the 6th. Now just need the right eyes on it.


(Jeffrey) #16

Do we have the right eyes on this yet?


(Jeffrey) #17

Took 3 days but finally got a reply from support. The Ticket # is #254566. @twack @Aaron


(Jeffrey) #18

@asishv have you had any luck with this on a workaround?

@slagle – See I am not the only one :slight_smile:


(Asish V) #19

@jjslegacy I tried the workaround getChildDevices(false) and it worked. Thanks!