Clear Text Notifications From Automation Routine after Hub Reset


(Michael Mayfarth) #1

After a factory reset on my hub during the recent major down time, thinking it was a problem on my end… I am still getting text notifications from prior automation routines from Good Morning and Good Night. Is there a way to clear these within the system?
My new routines are not set to send text notifications but i am still getting them.


(Ray) #2

Try logging into IDE and delete from there.
Edit : apparently this one https://graph.api.smartthings.com is the old one and doesn’t work for everyone. Below is the new one.
https://account.smartthings.com/


#3

Please use https://account.smartthings.com <---- This is the official page to log into the IDE. Once logged in, it will correctly redirect you to the shard (url) that your account is on.

@Navat604 can you update your post to reflect that url? The graph.api… is the old way of logging in and most people today do not have their accounts on that shard. :slight_smile:


(Michael Mayfarth) #4

Once i am in there where do I go to see the automation tasks? I can only find the smart apps and the notifications that have already been completed.


#5

Goto Locations / Installed SmartApps - Do you see any/all your Routines that you previously had created. It will probably start the list with Hello Home.


(Michael Mayfarth) #6

I do see the routines, I can not make any changes. the ones that do show up are the ones that are from after the restart.


(Michael Mayfarth) #7

You can see that the Phone line is blank. but i am still getting texts every morning and night.


#8

Do you have a screenshot of any of the notifications you received? I would like to see the exact verbiage if you have it


(Michael Mayfarth) #9


#10

Do me a favor.

  1. Go to your Routines. Manually run the Good morning Routine.

  2. Do you get the text Notification?

  3. If Yes, continue

  4. Edit your Good morning Routine and add the notification to it and save.

  5. Manually run the Routine again

  6. Do you get two text notifications?


(Jimmy) #11

do you have contact book turned on? Maybe it’s somehting with that?


(Michael Mayfarth) #12

I just manually ran the routine from the application and I did not receive a text message. I ran both routines that in the sequence that would turn the lights on and then back off.

The circled information is what is generating the text message. the upper section of the clip is the routine.


(Michael Mayfarth) #13

I have no idea what that is, so likely i dont have it turned on… ?


#14

So whether or not I turn on push notifications inside a Routine, it doesn’t log the performing routine name… I get that dislayed on screen when I manually execute.

Did you physically enable the notification to occur in the Routine? Do that and run it. Do you get a text notification?

Then edit it again and turn off Notification. Run it again.


(Michael Mayfarth) #15

I enabled it the first time I set up our Hub. we had one switch and I thought it would be nice to have it tell me what it was doing… that got annoying quick. so after I factory reset the hub thinking it would pull in all of my previous settings from the app, I looked and there were no settings tied to the routines. I re-created the routines, this time without the text notifications and added a few devices to the hub. later that night I got a text. I re-checked the routines and that next morning I received another text.

I dont know where to begin to find the routines that dont exist on the hub anymore.

I did just rename the routines that I want to keep to see if it still texts me with the “good night” name.


#16

If that doesn’t work, reach out to Support and explain. It’s possible it’s a phantom remnant of something since you reset the hub.


#17

FYI. In testing yesterday, I had turned on Push Notification in my Routine and left it on.

  1. I received an ST Notification for my Day Routine this morning.

  2. That means when you run a Routine manually, it doesn’t Notify (with the exception of quickly displaying that it has completed within the app). So that part of testing I had you do yesterday accomplished nothing :slight_smile:

The notification portion only works when it runs as scheduled or based on action I suppose. And in your case, it notifies you even when Notification isn’t selected.

Let us know your results from the rename.


(Michael Mayfarth) #18

Still got a text message this morning… however it proved something. The text said “Performing ‘Good Morning!’ for you at Sunrise as you requested”

I had renamed the routine “Sunrise” yesterday, so clearly this is a remnant of the routines prior to the factory reset.

Thanks for the insights and attempts to fix this. looks like I will be contacting Support…