CentraLite Keypads

keypad
dth_security

(Joe) #783

Nvm I got it. Nice took two days but good now so far.


#784

ConradSykes & Others,

Any way to get a newbies version of HOW (Step by Step) to

  1. install the Iris Keypad
  2. How to install SmartAlarm
    • I found it in the Marketplace and configured it. But can’t figure out where and how to get it to work. There is absolutely no delay when my alarm is triggered to when it goes off.

Thanks in advance

Luis


(Joe) #785

I would love to help but I have not gotten that far. I think you need to use a smart app for it. Maybe smart alarm. I installed the app into ST but have not gotten to play around with it as I am new to ST also. I started with the kit and said I would start small. But within 2 weeks I have about 45 devices.


(John) #786

Okay, I’m sorry guys. I’m very new to this stuff and not very tech savvy. I’m trying to install the Iris keypad from Lowe’s. I’ve been reading about IDE and code and custom smart apps. None of this makes sense. I’ve gone through my SmartThings app looking to figure out how to add a custom app, but can’t find anything. I’m going blind with all this. I’ve also looked through so many post, but every one I seem to come across, is someone that sounds as if they have already done some of this before.

Thank you so much in advance to anyone willing to put up with me needing instructions in a way that a non-computer programming guy like me can understand. FYI, I have the Samsung SmartThings Home Monitoring kit and an IPhone.


(Joe) #787

I can’t post instructions at work but they are all over the forum. You need to add them via the web. You can’t with the app.


#788

The following is the overview of custom code. The process is pretty straightforward, basically you copy someone else’s code and paste it into your account through the web interface (not through the mobile app).

But read the overview, and then if it sounds like something you’d like to go ahead with, we can help you get started. :sunglasses:


#789

I am having similar issues. I have learned about DTHs and APPS. THANKS JD. From here I:
Linked Keypad to ST …found 3405-L keypad
copied MitchP’s Centralite Keypad code and created a DTH.
saved DTH and published to me.
downloaded buttons smartapp
linked button app with keypad.

When I go to Things and select keypad I get a page withthe first 3 squares with –
the next row of three squares with configure in dark grey and the reset and horn in light grey. none of which do anything. On the last row is a test button. When pressed it makes the keypad beep 10 times. Can anyone help me make this work? I am now on day 4 without success.


(Joe) #790

Did you change the device type in your devices page to the centralite keypad after you added the DH?


#791

Checked in My Devices and appears I have centrallite as the keypad type.

BTW…How do you determine or set the access code?


(Joe) #792

Need to add a smartapp. There are two I can think of top my head. One only allows 1 code another allows multiple ones.


#793

Which do you recommend? Name of SA please?
I’ve loaded buttons but cannot tell if it is running.


(Mark) #794

Look at the first post of this thread.


#795

OK. Tonight was a good night. I loaded 3400-X keypad manager with Centralite Keypad DTH and after a few attempts was able to get a temperature, battery level, and alarm state to display, along with config and test soft buttons (SB) to unghost. While the refresh and horn SB were still greyed out the horn button still worked and I was even able to beep when a door contact changes state (CoRE). Thanks everyone for your instruction and patience.

However, I cannot get the keypad to change the state of SHM. The centralite keypad thread indicates to enter the 4 digit code (set up in keypad manager) followed by the state button (OFF/home; PARTIAL/stay; and ON/away). Any suggestions?


(Craig Ellebrecht) #796

I am having a horrible time trying to pair this keypad to ST. It is the CentraLite that i have from my comcast xfinity setup. it is model 3400.

It doesn’t want to pair, please let me know how you guys are doing the pair.

Thanks in advanced!!!


(Klas) #797

@csellebrecht when you say pair, do you mean to get ST hub to recognize it at all? You should remove all batteries from the keypad and then press down the button on the back below the battery compartment while inserting a battery. This will put the keypad in pairing mode and now it should be visible to the ST hub.


(Klas) #798

@khill There seem to be different firmware versions or something else different between certain keypads. I bought a keypad this autumn and did not for the life of me get my device to function. Then @zcorneli provided some additions to the original device handler and lo and behold, it worked! Maybe it could be worth testing with mitchp’s old source code from December 2015 just to see if that makes any difference. If that or zcroneli’s latest source code does not work you may just have to wait :frowning:


(Craig Ellebrecht) #799

I just for the life of me can’t get it to pair,


(Klas) #800

@csellebrecht to be able to help you out you will have to be a bit more verbal here. What steps did you do and in what order?


(Craig Ellebrecht) #801

Sorry I was on my phone and on a code call heading to Dwntn Chcicago…

Ok I have done as you suggested and it didn’t work. I removed both batteries and held down the button (well doest look like a button) and inserted one of the batteries while I had ST in pairing mode on my phone. I was not far from the hub maybe 10-15 feet max. Nothing happended, tried it several times. Comintons of releasing button after 30 seconds to holding button down entire time.
I do have the mitchs handler installed but its just not pairing for some reason.
My keypad is part of my Xfinity alarm that I don’t use and the only reason I have it is that it lowered my bill 80 bucks and I got a couple cameras. Well half function cameras since they modify the firmware and noway to get the full function of the cameras back.
I am thinking they have done the same with the keypad. I would love to use the actual control pad for something else.


(Klas) #802

Not sure if I remember because it was a month ago but pairing should result in the lower left light blinking on the keypad front. I believe you need to release the backside button before a couple of seconds of inserting the button. Let us know if this makes any difference.