SmartThings Community

Can I have heat by the time my alarm goes off?

alarm
thermostat
automation
(Don) #11

Not sure if you can make this work for your use case?

I have my phone check every night at 9pm if I’m scheduled to work the next day on Google calendar. If so it turns on my alarm for the next day for me automatically. It has been working pretty reliable for a while now.

To accomplish this I use Tasker, gentle alarm, and a calendar plugin for Tasker.

It’s kinda the long way around to your goal. Possibly you could set your work schedule in a Google calendar, have it checked like I do the night before. If true set a virtual switch via sharptools that completes logic to fire your thermostat at your preferred time via Tasker or Core or Webcore?

Also maybe you could use the Gcal smart app to set a contact based on your work schedule in Google calendar. Then use core or Webcore to fire your thermostat to on if the Gcal app contact is true at the time the furnace should start to warm things up for you.

I haven’t tried or tested these ideas. Just tossing them out there for you to ponder on.

1 Like
#12

What I do is I have a ST routine that runs at the time I Want to wake up. It turns on certain lights very dim and sets my Nest thermostat to heat. When I go to bed to tell alexa to wake me up at the time I desire. If I forget to have alexa wake, the lights would still be on anyway.

You could create a routine in ST to would only turn on your heat at 5:00. Then simply tell alexa to wake up at 5:15. You can also schedule Alexa to run an alarm using the Amazon Alexa app or Alexa website.

On the Alexa website (same layout on the app) go to reminders and alarms:

Set your time and what days to go off:
alexa1

(monica@glowball.com) #13

Going off of a calendar for work is a cool idea! I’m going to mess around with that, thanks.

(monica@glowball.com) #14

That’s what I’ve been able to set up, but it’s still two steps every night – start the ST routine and set an alarm. I’m hoping to boil it down into one command. Great ideas, here, thanks!

#15

You won’t have to start the routine at all. Let it run automatically. Same with the Alexa alarm. It only would be two steps the 1st time if you wake up at same time everyday. Have the Routine and the Alexa app alarm run (automatically) at the same times everyday. Set it and forget it until you need to make a change to your schedule for whatever reason.

If you have a different time for weekends etc, just create an additional ST Routine and Alexa app alarm that would run only on those days.

(Don) #16

Here is links to the original Gcal thread, and the updated thread.

If you have questions, I’ll try to help the best I can to answer them.

1 Like
(monica@glowball.com) #17

Thanks, tpip, but that’s really the issue. I get up at different times throughout the week, and sometimes I don’t want an alarm at all. Before getting ST I had a programmable thermostat that wasn’t smart. I would usually not use the scheduler because of my unpredictable wake-up times.

#18

I get up at three different times in a given week, two for works schedules, one for days off.

Example to create:
ST Routine Heat 1, turn on heat at 5:15
Alexa app alarm set for 5:00

ST Routine 2, turn on heat at 6:00
Alexa app alarm set for 6:15

again for the 3rd if needed or not for days off etc.

(monica@glowball.com) #19

Hey, thanks! This looks pretty powerful and I’ll work on figuring out how to use it today. That’s really nice of you to go find those posts. Merry Christmas!

(monica@glowball.com) #20

That’s what I’m doing now, running two things each night. I’m hoping to figure out how to run one command that sets an alarm and turns on the heat 15 minutes before that alarm. I’m still poking at it…

(Don) #21

Your welcome,

My current primary use for the Gcal app is putting in mine and my wife’s work schedule. I used to use the all day option but Gcal doesn’t like that method alot.
So I have our work day start before we actually get up. Me 1st 5am and my wife at 6am.

I then use core to compare the contacts associated with those Gcal triggers. If she’s off then when I leave for work and lock the door it turns off the lights. Then just the opposite if I’m off and she’s working. If we both work everything shuts down using the Good-bye routine when we’re both gone.

I plan on using those contacts to trigger the bathroom towel warmer too. Just haven’t gotten to it yet.

Just be aware the Gcal will trigger at midnight every night even if it isn’t supposed to be on. It’s a glitch in the app. Other than that it has worked very reliable for me.

1 Like
(monica@glowball.com) #22

I’m following directions at https://github.com/infofiend/GCal-Search and using code from the first post at https://github.com/mnestor/GCal-Search because the more recent post doesn’t link to any app or device code. I’ve made it up to publishing the devices, and when I try to add GCal Event Sensor as a new Device Handler from code, I get this message:

Groovy.lang.MissingMethodException: No signature of method: script_dth_metadata_be7bb5d4_84ea_4f79_a847_78737b3ac66b.appSetting() is applicable for argument types: (java.lang.String) values: [clientId] Possible solutions: typeSetting(java.lang.String), typeSetting(java.util.Map), typeSetting(java.lang.String, java.lang.String), getSettings(), setSettings(java.lang.Object), typeSetting(java.lang.String, java.lang.String, java.util.List)

Some searching implies the error is related to calling a function with the wrong parameters or the wrong number of parameters. How did you get around this error? Am I using old code? The latest GitHub page doesn’t link to any of the code. Thanks for your help – learning a lot by going through this exercise!

(Don) #23

I believe you have to update to the new code. Let me look

(Don) #24

I’m mobile so bear with me.

Does this link work?

There is a read me for the install, and the other files you need.

I think if you read later in the second thread there were changes in Google to the link you have to copy. So you might have to do those changes manually.

1 Like
(Don) #25

Disregard this,. This is for a different app.

(monica@glowball.com) #26

Shows you how unfamiliar I am with GitHub! Found the updated code, I’ll work on it and report back.

1 Like
(Don) #27

You’ll learn,. I am still figuring stuff out too. Just gotta not be afraid to try and ask questions in the threads.

(monica@glowball.com) #28

I used to be a web developer so I really appreciate you opening my eyes to apps. I am really looking forward to exploring and seeing what I can come up with. I have everything installed and published, and the settings look like it should show up in My Apps. I’ve waited for a bit and nothing is showing up there. Does it take a while?

(monica@glowball.com) #29

I was frustrated and running into the load balancing issue you helped with at Double login to IDE to get hubs and devices to show – but in a different way. I installed everything on two load balancers but still didn’t see it in My Apps. Then I realized that my Location showing in the IDE was at graph-na04-useast2.api.smartthings.com and I hadn’t installed the smart app on that load balancer. I finally did that, and now it shows up in My Apps. Madness.

To help someone else not seeing things in My Apps. In the IDE, go to My Locations, and hopefully you see the Location for where your ST is installed. Copy the subdomain or entire domain for that page. That’s the same subdomain/domain where your apps need to be installed. If you go to My SmartApps, make sure the subdomain/domain matches the one for My Locations.

1 Like
(monica@glowball.com) #30

Ever have one of those days where you work on something and after hours and hours you don’t seem to be any closer to finishing? Yeah, I’ve been working on this all day…

I understand how the IDE works now, and it’s pretty cool. GCal is working perfectly, turning lights on when a Google Calendar entry is set, as a test. However, I still would need to set my Alexa alarm. So it’s still two separate commands and less efficient than the way I was doing it earlier with ST routines, I think.

I’ve been researching and trying to understand webCoRE but I don’t think there is anyway to use an Alexa alarm as an action. Trigger, yes, but not the resulting action. So, I think it has to start from the Alexa alarm. Do you know if this is possible in the IDE?

Trigger: “Alexa, set an alarm for 5:30”

Action:
alarm set for 5:30
Google Calendar entry created at 5:15

The trick would be to be able to pass that alarm time (5:30) to the IDE or something, subtract 15 minutes, and set a calendar entry. That way, I can set an alarm for any time I want and the calendar entry would be 15 minutes earlier.

The other trick I’ve been unable to do is to use the setting of the alarm as the trigger. It’s pretty basic to have something happen when the alarm goes off, but not when the alarm is set.

After a whole day of poking at this I’ve learned a lot but I’m pretty defeated. I just KNOW that all of this is possible but I can’t seem to find my way down the right path.