Can CoRE run locally?


(Paul James) #1

I have been using CORE for a while now and have several pistons to do some automation. Is there a way to have CORE run locally. I have a pretty quick internet connection but, I have a piston that when the front door opens and it is after sunset and the living room light is not on to turn it on. I will open the door and make it half way across the room before the light turns on. Should there be a 5 second delay in turning on the light? or is there a way to have CORE run locally and cut down on the internet delay?


(Paul) #2

Out of interest is that all the piston does? Can you an image of the piston?


(John) #3

Not currently. Only Smart Home Monitor (parts of it at least) and Smart Lighting run local (assuming the DTH are local as well).


(Bernie H) #4

Smart Lighting runs local and is pretty much instant. Unless there is a lot more to this piston, switching to smart lighting should work better. As long as like mentioned above the DH is one that’s runs local.

All most all my lighting is run through SL. And it works great when ST or my internet goes down.


(Paul) #5

Pretty much where I was going. If it’s as simple as it sounds love CoRE alone.


(Paul James) #6

Unfortunately my lights are all Caseta and I am running through a Raspberry Pi. The one option that I couldn’t find in Smart Lighting was to not turn on if the light was already on. What I was also trying to avoid was if the light was on at 50% then to just leave it at 50%.


(Paul) #7

Pretty sure you can turn it on, just don’t turn on and set the level?


(Chris) #8

If it’s on at 50% already and you just send another turn on command nothing should change.


(Paul James) #9

Ok, Let me be a bit more clear. What I would like to do is to turn the light on to 100% but say the light is already on at anything less then 100% then I do not want the light to turn on to 100% but to leave it at the % it was already on at and to only do this if it is after sunset and before sunrise.


(Paul) #10

then you need CoRE :slight_smile:

So, going back a bit… it probably shouldn’t take 5 seconds. Can you post the piston?


#11

The issue here is probably not the question of SmartThings running locally or not locally, but the “man in the middle” integration with the raspberry pi.

The first thing I would do is ask in the Lutron integration thread and see if other people are either having the same issue or have any suggestions for reducing the latency.

It was announced in January at CES 2017 that there is an official Lutron/smartthings integration planned for release in the next few months, and that in itself might speed things up. It’s still a cloud to cloud integration and you would still need the Lutron SmartBridge, but it may be better tuned.


(Ron Talley) #12

I have 20 or so SmartLighting automations, mostly turn off/on if this sort of thing but nothing complex. Works “almost” instantly 98% of the time.

I have another 20 or so CoRE Lighting automations. These are used for more complex lighting and usually have about 3 or 4 scenarios per Piston. Works within a second 99.9% of the time.

I have about 3 IFTTT Lighting automations. These are used for things that are not connected to SmartThings. Works within 2-10 seconds…sometimes 20 seconds…82.98762% (totally made up statistic) of the time…

Probably isn’t CoRE slowing things down…


(Nate Schwartz) #13

@Paul_James That’s very odd that you have a piston taking so long to run. However, I highly doubt it is due to the raspberry pi integration. Do you have those kinds of delays with other lights using the pi integration or just this one piston. I know my and most others experience has been nearly instantaneous performance so it seems odd that this one would have such a delay. I’m happy to look into it and troubleshoot with you but I really don’t think it’s on the Luton side of things.


(Nate Schwartz) #14

Also, I agree with @rontalley that most core lighting Pistons I have work within a second or so. And that includes ones using the Luton pi integration. I think you should post your piston so we can see what is actually happening. Perhaps there is some inefficiency there causing the delay. Just a thought…


(Paul James) #15

Here is what I have. Although from this screen shot,


#16

BTW, just for information, nothing using “sunset” runs locally, not even SmartLighting. The sunset value is stored in your cloud account. (Don’t shoot the messenger. :wink:)


(Nate Schwartz) #17

That looks like a reasonable piston from what I can see. Just out of curiosity have you tired doing a simple Piston like door opens turn light on? Just curious if that runs quickly or if you see a similar delay. As @JDRoberts said it could also have something to do with the sunset stuff. Maybe try hard coding in times and see how that does. Just some troubleshooting ideas…


(Paul James) #18

I will give it a try on hard coding a time.

Thank you all for your advise.


(Nate Schwartz) #19

Yea let us know. Also, you didn’t say, but do you see similar lag with the Lutron integration anywhere else?


(Paul) #20

This:

BTW, just for information, nothing using “sunset” runs locally, not even SmartLighting. The sunset value is stored in your cloud account. (Don’t shoot the messenger. :wink:)

Is a quality observation and one that I hadn’t thought about. It yet another reason why none of my SmartLighting works when I take the net offline! Thanks.