Bug in schedule() which causes schedules to never fire again

Hi @Salgar,

What you mention is a well known bug in ST. Developers are aware and are working on a solution but it’s been several months since this was found and we don’t have a fix yet. Frustrating I realise.

Some folks have had more luck using Rule Machine to auto fire routines, etc.

1 Like

Hi thanks for the replies

@theedpope - Yes I have contacted them, no reply yet though.

@adeparker - I’ll have a look at Rule Machine, but it’s annoying as I’ll have to stop developing my app until this is fixed, unless I do something like unschedule, wait until the time has definitely passed, and reschedule the rule, feels like a horrible hack though.

1 Like

You might have found the issue, but unfortunately or ironically, SmartThings will NEVER read your email sent to support@smartThings.com.

1 Like

We’ve been referring to this as a “broken” schedule. This is clearly due to bugs in the ST backend scheduling software. The only fix until they fix the backend is to “refresh” these schedules by going into the app in question, and hitting Done. Doing that will create a new schedule. That will run for some indeterminate time until it breaks again. Some of mine have run for weeks or months without breaking. It reduces the likelihood of it breaking if the time in question is not on the hour or half hour, and in some places not at sunrise or sunset. Offset from those times a few minutes – that seems to help.

Unschedule() itself is problematic, and prone to timing out.

1 Like

Unfortunately THAT is no longer working for me. I had to delete and recreate both routines and rules for the past 2 weeks to get them back on schedule. Last night after several incidents, I decided to drop schedules altogether and just use lux levels. I meant to do this a long time ago, but I thought that running things on schedules on the server side will be more reliable than me being lazy self and not changing the batteries. Well thanks SmartThings, you have a funny way of keeping my best interest by forcing me to exercise once in a while :slight_smile:

1 Like

Yea, I should have mentioned that refreshing the schedule is the fist thing to try, and if that doesn’t work, you do have to delete the app and start over.

FWIW, my schedules, the few I do have, are working fine.

I have been speaking to 2nd level support, apparently they introduced a change that made this much worse last night, and have just fixed it a few minutes ago. So let’s hope :smile:

Ouch! Nothing like “SmartThings Starting Over” once a week!

1 Like

I understand you’re less than pleased with the timeliness of our support team, but this is absolutely false. Every email sent to us is triaged against known issues, and if something hasn’t been reported yet our Support team members can create a development ticket directly from their Support portal.

The best place for all bug reports is support@smartthings.com.

Source: I worked on our Support team for two years and designed a lot of the processes we’re using internally to track customer facing issues.


@Tyler This NOT ABSOLUTELY FALSE and I have several emails requesting support that are very outstanding that have NEVER been responded to. I have repeatedly posted these ticket numbers in the past to other SmartThings employees who watch this forum, only to never hear back. I am so done with trying anymore, after all, when my rules do not fire via the erratic backend scheduler and I have to “REFRESH” or DELETE AND START OVER, that isn’t much help is it?

Oh, BTW, I cannot access the SmartThings support portal. Ironically, I have EMAILED SUPPORT in the past two weeks for access and/or a password reset, which was NEVER Replied. How’s that? :rage:

@Tyler I am NOT THE ONLY ONE reporting non existent help from emails sent to SmartThings.

1 Like

Hey Kurt,

Again, I understand the frustration with our response time. We’re hiring and training Support members as I’m typing this.

As far as your tickets, here’s what I’m seeing:
127658 - Replied with a solution within 4 hours, no response from you.
149007 - Replied with a solution within 48 hours (on a weekend), no response from you.
149011 - Replied within 48 hours (on a weekend), no response from you.
163418 - Replied and merged ticket to 164278.
164278 - still open, awaiting a response from us.

I definitely see that ticket 164278 has gone too long with a response. I’ll check what’s going on with that.

Also - our support portal uses SSO with your SmartThings account. If you can log in to http://ide.smartthings.com you should be able to log in to the support portal. I don’t know that we have any material or functionality on our support portal that requires logging in though. Let me know if there’s something you’re looking for specifically.

edit: Please PM me if you need password reset help immediately.

1 Like

@Tyler Thanks for looking up these outstanding tickets, I have replied back to each and every response that a human provides with the success or failure of their recommendation. I do not consider the, “We have received your request for assistance, Warm regards” email as a “response”.

All the tickets are in the same status as OPEN in my mind when they have not been replied to (and I check my spam folder). Whoever updated these tickets with those responses NEVER emailed me back with ANY SUPPORT RECOMMENDATIONS. I am not the only one reporting that tickets are being closed or updated without customers being contacted.

I will try to sign-on again to support desk @Tyler, I would love to see my ticket status and also be responsible ONCE AGAIN for reporting bugs that I see.

1 Like

Hi Kurt,

Just to clarify - I don’t consider the automated response a reply. I mean that on each one of those tickets an agent has given you a thoughtful response and a suggested solution. I won’t share the specific text, but here’s ticket 149007 where we provided you a human response.

You may have a conflict with your Spam folder or another filter. If you happen to use Gmail, try this search:

in:anywhere from:support@smartthings.com

1 Like

I have found several of the requests and this is when I had very critical home routines that were not operating, and as you can imagine, coming home to a cold house, or a garage door left open, or the door locks not locked, etc. I reached out to Tim Slagle and he finally responded after 3 days of me pulling out my hair. As of November 2015, I completely removed any critical home operations, and only use the point solutions provided by each tech vendor. It is perfect, but works until the bugs in the SmartThings V2 cloud are once again reliable.

Tim Slagle (SmartThings)
Oct 25, 12:21 AM

Hi Kurt,

We are currently experiencing problems with our scheduling engine and are working to resolve the issue. I will be updating the community with any changes and updates as I get them. Subscribe to this thread to follow and updates I have for you guys on the community.

Time based events failing? - #134 by beckwith


Tim Slagle
Developer Solutions Specialist, SmartThings

This was of course when I tried both email and Chat, and now you ONLY have email.

Here is another example of my front door lock that was operating perfectly, and then did not operate via any SmartApp command for days. This left the house unlocked at night after the door was opened, and would not allow service personnel access via a schedule access. I have send reactivated the door locks internal blind 30 second lock routine which is frustrating when it locks and the door is slammed shut with the lock out.

@Tyler I have sent you a private forum message concerning the “View your Support Tickets” which is not currently working. I also included several links from other threads about tickets being closed without responses…


This happened again today.

I was wondering if there is a way to Programatically determine is a job is scheduled to run. The idea is to use a trigger to test the schedule queue and if an entry is not queued then (re) submit the runIn or cron request.

Well, this all came to an abrupt end when my smart socket came to a horrible death.

I hope no one blames this on SmartThings :slight_smile:

Well… err… The thing that was plugged into it was fine, and has been for years, so I’m not sure who else there is to blame…

Was it a SmartThings socket? If that is the case, then maybe.