[BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller

There must have been some changes. I have had the DTH for years now and integrated with Google Home hub for 1 year. My fan stopped responding in ST so I deleted and readded and assigned the DTH in Ide. But now when I add in the GH integration like mentioned with Alexa, the light is missing. The smartapp in classic showed the light as selected but Google Home did not see it. I then removed the smart app. The only way to add it back was thru Google Home but it no longer appears in the classic app as a smartapp once the account link is made

ST changed the Google home integration. It now works through the new app. There is another thread where they are discussing the “shortcomings” of the new integration.

I went through the steps of adding the device handlers. I’m now able to control the light and the fan from the classic app. I paired it by turning the lights on/off 5x and chose “Thing” when it appeared in the device discovery. Then in the device list on the smartthings website, edited “Thing” and changed it to the KOF Zigbee Fan Controller. It automatically added a device for the light.

In the classic app, I can control the fan and light from one thing. I can control only the lights from the separate light thing.

In the updated smartthings app, I can only control the fan, not the lights. And, Google Home is only recognizing the fan - I can turn it on/off, but not control the speed. Voice control doesn’t work at all.

Is this the same experience for others? Has anyone been able to get Google Home voice control to work with the fan and the lights?

Are you using the new Google home integration or the old integration? If you don’t know, when did you set up the Google integration with Smartthings?

I don’t know if I’m on the old or new integration. I only connected the two services yesterday by going through the process in the Google Home app. I’m one of those people jumping over from Wink.

You are most likely using the new integration.

This worked fine in the old integration and I have not used the new Smartthings integration with Google.

For what it’s worth, this DTH does not work all that great for the new Smartthings app.

There is a thread here with people discussing what works (and doesn’t work) with the new integration. You might want to ask in this thread.

I looked at the DTHes. The only official capability they expose is Switch, hence the Google integration will only allow On/Off for the main device which is the fan (saying turn on/off should work).
Also the new Google integration does not yet support child devices hence the light does not show up.
To control speed via Google and Alexa, the fan DTH would have to expose switchLevel.

That’s interesting. We were always been able to control the fan speed using the old integration. I wonder how it was done?

Wink refugee here too. I had the same issue with Alexa not controlling my Wink enabled fan. I created “virtual devices” in the original smartthings app - light, fan low, fan medium, and fan high. For some reason all the fan controls created with the DTH I got from this thread show up as options in the automations section, but do not show up in the new smartthings app and are not visible to Alexa (I imagine Google home, etc as well). I then set up two automatons to “mirror” each of the virtual controls - a virtual dimmer for the light, and virtual switches for the fan speeds, for each setting (light and 3 fan speeds) to the fan control (8 mirrored automations in total). The virtual controls, that show up in the new smartthings app and are recognizable to Alexa, control the real controls created by this DTH in the old smartthings app via the mirrored automations. It was a pain but everything works now to control the light with dimming and fan speeds through Alexa and the new smartthings app.

Thanks mwav3 for the tip about virtual devices. Works like a charm with google home.

In the classic app for controlling the light,

  1. Click on automation, then add a smart app
  2. Choose more, then scroll down and choose Virtual Device Creator
  3. I chose virtual switch and my smartthings hub
  4. Add device name as you want it to appear in google home and the newer smart things app, and save
  5. Click on automation, then add a smart app
  6. Choose Lights and Switches, then Smart Lighting
  7. Choose the actual device you want to control, the switch for trigger
  8. Then choose the virtual switch you created in step 4, and save
1 Like

I’ve successfully added the fan controller to smartthings 3 times, but I am not able to control the fan, light, or any thing. It seems that I’ve have a different firmware version than in some of the other screenshots that I’ve seem.

The child devices were exposed in old integration but I dont see how fan speed would have worked.

@Lars

Because the child devices are exposed as Switches. You ask Google (in my case) to turn on “living room ceiling fan low” and it would turn on the " low" switch. The “comfort breeze” switch was also exposed for simulated breeze.

You can’t tell it to turn on the fan to something like 50% though. You have to turn one of the exposed switches. I actually like that better than the percentage method were Google tells you it is dimming the ceiling fan speed. Having Google speak that it is dimming the ceiling fan sounds awkward.

If that is a screenshot from your device than you are on the latest version. The green circles would be red if there was an update.

Hello there!

Apologies if the question has already been covered.

When trying to copy/paste the code into the New SmartApp, I got an error message (slightly different for each portion of the code, but still). Something like:

No signature of method: script_app_metadata_79e78043_b23d_4e72_8ec3_1424a2f8307e.metadata() is applicable for argument types: (script_app_metadata_79e78043_b23d_4e72_8ec3_1424a2f8307e$_run_closure1) values: [script_app_metadata_79e78043_b23d_4e72_8ec3_1424a2f8307e$_run_closure1@343bc75a] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

I have no clue what it means and how to fix it. Can someone help?

Thanks in advance!

Make sure you are creating and pasting code for a DTH, not a smartapp.

https://thingsthataresmart.wiki/index.php?title=Using_Custom_Code

Hey John,

I knew it was something basic like that as I just started to play with SmartThings today.

Thanks a lot for your quick answer!

1 Like

hey guys - another wink refugee here. i just got this working in the classic app - is this not supported in the NEW app yet? sorry if this has been asked already. it the new app all i see is an on/off switch - no fan speed or dimmer.

No. Manual Control in the new app is pretty much non existent. You can control the fan just fine in automations. Lots of discussion about this in previous posts in this thread. No idea if/when this will be fixed for the new app.

Steve, I’m not sure what I’m doing wrong. Everything seems to work fine for me in the classic app. On the new app, the fan shows up as a tile and I can turn the fan on and off using it. The light also shows up, but it’s inactive so I can’t do anything with it. When I go to the automations panel and I try to make any automation with the fan, it’s the same. It looks like I could turn the fan on and off, but that’s it. Also, only the fan shows up in google home so I could only turn the fan on and off - not the light. Am I missing something here?

The classic app says I have Parent ver 0.2.170515, Light Child ver 0.2.170515a, and Fan Child ver 0.2.170515. Do I have the right versions of everything?

Is anyone using the version that is supposed to work with the new app by rafaelborja (https://github.com/rafaelborja)?