[BETA] GE 14287 Z-Wave Plus 3-Speed Fan Control With Double Tap

I had to migrate to the new app today. On my old app the switches show fine and work as they have since last year. In the new app the fans do not work and say the app can’t connect to them. If I go into the IDE and change them to a generic Z-wave fan device handler then they connect in the new app. Is there some way to make this double tap device handler work in the new app?

All I want is a device handler that will let me turn the blue led off on my zwave GE fan controller switch when the the fan is either in the on or off state with the exception of the few seconds of blinking it does when the speed has been adjusted…is there any way to do that?

Sorry I am not using smartthings anymore. If u try @nuttytree DTH and it does the same thing, then sorry I dont have a fix for you

Yes you can do that, but you don’t need a DTH for that. Please read above.

If you need a DTH setting, it didnt work when I had the setting there. It works on the dimmers though

I just tried adding the code provided by @mwav3 in the original NuttyTree DTH

import groovy.transform.Field
import groovy.json.JsonOutput

then added the following around line 163 under ‘def parse (string description)’, right before ‘result’

if (!device.currentValue(“supportedButtonValues”)) { sendEvent(name: “supportedButtonValues”, value:JsonOutput.toJson([“pushed”]), displayed:false) }

The DTH still works fine in the old app but no dice in the new app. Anyone able to troubleshoot? Nothing shows up in live logging just from trying to view the device in the app so I’m not sure where to start.

Unfortunately I don’t have this switch, but everyone was having a similar issue with the Wink King of Fan Controller - see the posts about that at [BETA v0515] Hampton Bay Zigbee Ceiling Fan/Light Controller . It worked great in the old app, but failed totally in the new app and with the new Alexa integration also didn’t work. @Rafael_Borja wrote a great DTH for that update, maybe you can message him and ask for help? The new driver for that fan is at https://github.com/rafaelborja/SmartthingsKingOfFansZigbee. It is zigbee vs zwave so will definitely be different.

With this 14287, you must be lucky enough to have two switches in a box with seperate fan/light control. I only have a hot and neutral (no third wire) between my fans, but Inovelli came out with their https://inovelli.com/red-series-fan-light-switch-z-wave/ which works great in the new app. They are working on one that would be very similar to the GE14287 called “project windy city”, but that is on hold and probably wouldn’t be out until at least a year https://community.inovelli.com/t/fan-switch-project-windy-city-on-hold/78

I assume you just want fan control and the double tap to work. Another option would be to take the stock smartthings Zwave fan controller at https://github.com/SmartThingsCommunity/SmartThingsPublic, and try and add the code changes made for the DTH related to the buttons from https://github.com/nuttytree/Nutty-SmartThings/pull/11 .

I would try but I don’t have this switch to troubleshoot. The only way I’ve been able to update code is with a lot of trial and error. I wrote some Java codes, but that was almost 20 years ago and I haven’t kept up with it. I can read the code enough to know what it is doing, but have trouble writing it. Plus, this code is all going from Groovy to basically JSON posts to an API. The new Smartthings app relies on these JSON posts. Groovy was very forgiving, but when you code a JSON post wrong, it just doesn’t work. JSON posts are super sensitive and if the quotes face the wrong way, or the case is wrong (its case sensitive), it just doesn’t build and you get nothing when you go into the new app and click it.

Another thing I am seeing is that many of the advanced users have jumped ship on Smartthings. They’re using Hubitat, Homeassistant, or others. It may be time to give up and make the switch. I’m trying Homeassistant, and if you have an old laptop, you can through Linux on it and a few Sudo blah blah blah commands and you have an instant new hub that is free. I’ve been saving old laptops with Linux for years since it is so much less of a resource hog then Windows and breaths new life into them. Homeassistant has a steep learning curve, but at least once its setup you’re not at the whim of what some developers want to do because you basically built it yourself and it runs local. We talked a lot about this over here Alternative Hubs .

However, attempting to update these DTH’s is starting to seem like placing band aids on a sinking ship. Sure we might get them working for now, but who knows if they will work in the future. Smartthings will sunset the Groovy IDE at some point, and every custom code will probably need to be completely redone when that happens. It honestly may be worth switching over now if you’re a power user. I’ve learned a ton from this community but I just don’t know if its worth the time to keep patching things up. I would love to hear @nathancu or @JDRoberts chime in on this. Their support and commentary has been absolutely invaluable to me as I continue to learn more about home automation.

1 Like

Good idea for a new topic, but probably best to keep this one specific to the GE DTH. :wink:

Yes, I tend to go off topic a lot lately.

Anyway, back to this switch. I’ve worked on the code and might have gotten it to work and support doubletap. Other advanced associations/settings aren’t supported in this. Again, I don’t have the switch, but tested it on one of my other GE switches and it pulled up a slider for fan control in the new app and button support in the smartlighting app. Anyone want to try it out, maybe @MarkTr ? If any suggestions or problems let me know. Link to code is https://github.com/mwav3/smartthingscode/blob/master/devicetypes/mwav3/ge-fan-switch.src/ge-fan-switch.groovy

2 Likes

No joy - the fan portion works correctly, and the button shows up as an option when creating an automation, but there’s no “button number” available. I know sometimes there’s some kind of refresh that has to be forced to make that show up, but I thought that could be done by editing and saving the device in the app and that hasn’t made a difference so far. Will experiment more tonight.

Any luck in the smartlighting app to get the button to show up? There’s issues trying to get the button to show up with the native Automation app in the new Smartthings, but it should at least show up in Smartlighting and Webcore (if you use that).

Nope, I was using Smart Lighting as that’s my normal use case for the double tap feature.

Darn, can you check the IDE and see if it shows “number of buttons:2” or is it saying 1? Mine is showing 2.

Also, maybe if you apply this DTH first https://github.com/nuttytree/Nutty-SmartThings/pull/11 (even though its the wrong switch), then try changing it to the updated one I posted, maybe that will “refresh it”?

If not I may have to try and go back to the drawing board. Its possible this switch uses the newer scene control associations for double tap like the 14318/46562 and if so the code I pulled out from the older switches won’t work. Hopefully it’s a start at least if anyone else has ideas/input?

Ok looking at the Zwave alliance’s info on all the certified fan controllers https://products.z-wavealliance.org/regions/2/categories/33/products my DTH “should” (emphasis on should) work with the 14287 but probably not the newer 55258. I took out the code about tile definitions because that’s what the classic app used, but that code might still actually be necessary (Groovy still needing the info for taking class definitions from it somehow and stuff). @MarkTr when you check the IDE and test it later let me know if it’s still not working and I’ll give another code update to try. Appreciate you testing this out for me and everyone.

Unfortunately I’m not able to do any testing with this at the moment; we took the fan switch offline in my daughter’s room, after rearranging to set up a desk put her loft bed too close to the fan blades. I have one in my other daughter’s room but the double tap feature is something we use daily; everything there is working fine as long as I don’t touch it, so I’m going to keep my hands off it for the moment. If something breaks or if being able to control it through the app becomes crucial I’ll start looking at it again.

1 Like

Yeah you definitely don’t want to break it if its working. I just updated the code to add some more settings if anyone else wants to give it a try.

@mwav3 I am happy to take over testing this for you. Right now I have the parent and child 14287 version installed and I can get it to start/stop by alexa and turn on via new ST app but can’t turn it off or change speeds in new ST app. IF you can clarify the process you want me to test I’ll do it tonight.

Tim, when I try to paste that into a new device controller I get this error “Org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: script_dth_metadata_05893bad_61dd_4c72_9720_b7745a17a4ea: 1: unexpected token: ** @ line 1, column 1. ** ^ 1 error” - confused why I don’t see a “raw” button to eliminate all the other text that isn’t part of the code.

When I tried to link to your code to try the DTH for myself I received error 404 apparently the code is not there any longer.

I’d love to help more with this.

I still have the fan DTH up this should link to the raw code https://raw.githubusercontent.com/mwav3/smartthingscode/master/devicetypes/mwav3/ge-fan-switch.src/ge-fan-switch.groovy

If you continue to get those odd errors try a different web browser then the one you’re using to add the code to the IDE and apply it.

Edit- child device for Alexa control should no longer be necessary with this handler, but let me know if it’s working.

A user Skates1616 on Github confirmed my DTH is working for fan control and double tap. Available here https://github.com/mwav3/smartthingscode/blob/master/devicetypes/mwav3/ge-fan-switch.src/ge-fan-switch.groovy or import from mwav3 smartthingscode master

1 Like

Yes, it is working.

This weekend, I ran into a weird issue though, and honestly I do not know if its beta firmware related. The DTH would turn on the fan/control the fan, but the status was not updated within the new app.

I will play with it a bit more today and get back to you. I do have the correct model/version of the switch.