Ask Alexa and Echosistant failure


(Joel W) #1

I am one of those guys that consider themselves tech savvy. But when it came to installing Ask Alexa or Echosistant , I was a total failure. I was able to setup the developer account and the AWs account, but from there on I failed totally. I wish there was an easy way to get this done, but alas, there is none. The wiki is fine, it is the user that is dysfunctional. So user error is my name. Any ideas would be welcome.


(Jason "The Enabler" as deemed so by @Smart) #2

Hi Joel,
Not to worry, we can definitely get you up and running. I’ll gladly walk with you through the install process.

Let me know when you’re ready.


(Joel W) #3

Thank you, I will have to reactivate my account. I will send Amazon a text today.


(Jason "The Enabler" as deemed so by @Smart) #4

No problem. I’ll pm you tonight when I get to my computer.


(Micheal ) #5

I can assist as well and I recommend installing both and seeing which gives you what you need for your smart home environment.

Let me know what you need.


(Joel W) #6

I tried to log into AWS to make sure my account is working, but I received a error, that my account was suspended. I sent a support request to Amazon. I will have to wait and see what happens. Also I have GitHub integration, is there a way to set up using that instead of my code?

Also tomorrow I have some surgery, so I won’t be available tonight. I will PM you.


(Jason "The Enabler" as deemed so by @Smart) #7

Ok, no problem. We will get you running asap.


(Joel W) #8

This is what I have done so far.


(Micheal ) #9

Ok…this looks good…what is the errors, if any, are you seeing/hearing?


(Joel W) #10

So far just installed, haven’t tried anything, and haven’t done the work on AWS. That is where I failed all the other times.


(Micheal ) #11

Ok…I just walked a guy through it this weekend…Specifically which part of the “AWS” part are you struggling with?


(Joel W) #12

I wish I knew, as I must have made a mistake somewhere, and had no idea where. I did this many times.


(Micheal ) #13

Ok…let’s start from the beginning…when you say ‘I did THIS many times’…what is ‘THIS’? Set up the account, tried to copy code, etc? I am pretty sure you didn’t break AWS, so we can get through it…there are just some very detailed steps that must be followed to the letter…Let’s start with the ultra basics…

Did you open an AWS account. Did you open a developer account?

If you did, you are literally 1/2 way there…

Let me know.


(Joel W) #14

I believe so.Here is a picture of my Lambada page. Maybe we can fix it?


(Micheal ) #15

Perfect…except you have REALLY old code…I recommend getting all of the latest code pieces. See the list here: http://thingsthataresmart.wiki/index.php?title=Ask_Alexa#Latest_Version

Now, a bit further down in your code (don’t post it here), but you will need to copy the information from the app setup page to the code. Would look like this:


(Joel W) #16

Added the OATH and test failed. I am now trying to delete the Acction, but it has been running for ten minutes.


(Micheal ) #17

Not sure what you mean about deleting the action. What do you mean by that? What is the exact error you are getting? Also, this us typically caused by a copy/paste error. In addition did you get the ARN properly into the developer site?


(Joel W) #18

OK I am at this screen and totally loast.


(Micheal ) #19

Ok…you need to fill in each of these areas with the output from the App. This is outlined here:
http://thingsthataresmart.wiki/index.php?title=Ask_Alexa#Developer_Account

When done, it will look something like this:


(Joel W) #20

I am thick, I am still lost. I put the code in. No problem, now I am at the slots. Where do I get them from? I am just not sure which place and what info. Am I just copying the list in th WIKI?