Aqara mini switch - can't connect

Has anyone been able to connect the following?

I’ve pressed the reset button and received the multiple flashes which supposedly puts it in pairing mode.

Scanning in ST doesn’t find anything.

Aqara Wireless Mini Switch, Requires AQARA HUB, Zigbee Connection, Versatile 3-Way Control Button for Smart Home Devices, Compatible with Apple HomeKit, Works with IFTTT

yes we can, what is the exact model name?

As I was typing this, I noticed that there are some devices between the ST and the aqara. Since it’s recommended to NOT have anything between them, I’ll try to re-pair it directly next to the ST.

it’s the wxkg11lm and shows up in ST as lumi.remote.b1acn01

I’ve tried both custom handlers
bspranger : Xiaomi Aqara Wireless Switch
and
bspranger : Xiaomi Button

Which is the correct one?

well I am using my own Edge driver , but drivers by bsprangler were ok

Would you mind sharing it?

also, regardless of the device handler, it doesn’t seem to fully connect.

I’m able to re-pair it but the logs don’t show any activity and the button doesn’t light up when I press the button.

Even with the default handler, shouldn’t the logs show activity?


edit:

I turned on debug logging in the settings and it does seem to be sending. I thought I read that the blue light should turn on with a button press.

[9dc8eca4-ab55-42cb-aab2-8239f7942ea1](https://graph.api.smartthings.com/ide/logs#9dc8eca4-ab55-42cb-aab2-8239f7942ea1) 9:03:09 AM: debug Thing: Parsing 'read attr - raw: DB8E0100120A5500210100, dni: DB8E, endpoint: 01, cluster: 0012, size: 10, attrId: 0055, result: success, encoding: 21, value: 0001'

[9dc8eca4-ab55-42cb-aab2-8239f7942ea1](https://graph.api.smartthings.com/ide/logs#9dc8eca4-ab55-42cb-aab2-8239f7942ea1) 9:03:05 AM: debug Thing: Parsing 'read attr - raw: DB8E0100120A5500210100, dni: DB8E, endpoint: 01, cluster: 0012, size: 10, attrId: 0055, result: success, encoding: 21, value: 0001'

[9df9sca4-abe5-41cb-aab3-834sf7942ea1](https://graph.api.smartthings.com/ide/logs#9dc8eca4-ab55-42cb-aab2-8239f7942ea1) 9:03:02 AM: debug Thing: Parsing 'read attr - raw: DB8E0100120A5500210100, dni: DB8E, endpoint: 01, cluster: 0012, size: 10, attrId: 0055, result: success, encoding: 21, value: 0001'

[9df9sca4-abe5-41cb-aab3-834sf7942ea1](https://graph.api.smartthings.com/ide/logs#9dc8eca4-ab55-42cb-aab2-8239f7942ea1) 9:02:57 AM: debug Thing: Parsing 'read attr - raw: DB8E0100120A5500210100, dni: DB8E, endpoint: 01, cluster: 0012, size: 10, attrId: 0055, result: success, encoding: 21, value: 0001'

[9df9sca4-abe5-41cb-aab3-834sf7942ea1](https://graph.api.smartthings.com/ide/logs#9dc8eca4-ab55-42cb-aab2-8239f7942ea1) 9:02:54 AM: info Thing: Set health checkInterval when preferences updated

[9df9sca4-abe5-41cb-aab3-834sf7942ea1](https://graph.api.smartthings.com/ide/logs#9dc8eca4-ab55-42cb-aab2-8239f7942ea1) 9:02:54 AM: debug Thing: Debug message logging enabled

[9df9sca4-abe5-41cb-aab3-834sf7942ea1](https://graph.api.smartthings.com/ide/logs#9dc8eca4-ab55-42cb-aab2-8239f7942ea1) 9:02:54 AM: info Thing: Info message logging enabled

[9df9sca4-abe5-41cb-aab3-834sf7942ea1](https://graph.api.smartthings.com/ide/logs#9dc8eca4-ab55-42cb-aab2-8239f7942ea1) 9:02:54 AM: info Thing: Updating preference settings

https://community.smartthings.com/t/edge-driver-for-aqara-switches-and-remotes/234576

but first rad the difference between (old) DTH and (new) Edge on the forum

thanks… this works great so far.
if I have any issues, I’ll post them in that thread.

Is there a reason it’s not included in the “supported list” in the first post?
Are you needing any additional feedback or testing?

1 Like

it was added later , probably together with similar device so I just forgot to add it to the thread