Android as a Speech/Alarm Device released! And Updated!

Must be something to do with the Google mesh routers.

I have eero mesh devices. eeros have two Ethernet ports. Ethernet connection from my ISP fiber optic terminal is connected to an eero in my wiring closet. Second port on that eero is connected to an Ethernet switch.

My SmartThings V2 hub is connected to that Ethernet switch along with several other things in the closet.

Never had any issues.

since updating my device to LineageOS 16 sound effects will not play. text-to-voice still works. anyone else experience this, any fixes? thanks.

Mine is plugged into a switch behind another switch with no problems

I’m also having the issue on my Fire 8HD with lannouncer “going to sleep” in the background. Sounds/Speech quit working after a period of time. I’m running on fully with lannouncer running in the background. Anybody figure out how to stop this from happening?

You can use this with Fully Kiosk, I had the same problem with Lannouncer going to sleep every few hours.


Version 36 is live on the Play Store and the website. You need this version; Google is shutting down GCM (Google Cloud Messaging), in favor of Firebase (FCM). This release moves to FCM compatibility.

Im trying to implement the behavior of a security camera composed of a motion detector, the LANouncer camera trigger, and the play store app “autosync for google drive” to automatically upload any photos taken

Unfortunately the lack of a front camera option is rendering this - potentially very useful - setup quite difficult.

Has anyone had any luck using the front camera in a scenario like this? With or without lanouncer?

At the moment the only solution I can think of is creating a little periscope mirror, but that seems kinda ridiculous given that my fire tablet has a front camera

Thanks for any advice

I just set this up on a Fire HD7 (9th Gen) and when testing via the buttons in the DTH, Siren and Speak work but Tone does not. Has anyone experienced this? Did I miss a config step? I’m going to test from WebCore next but skipping validation steps has seldom yielded good results for me :slight_smile:

Update: I couldn’t get anything to sound in WebCore (doorbell, siren, speak)
Update #2: When curling directly, Speak and siren work but chime does not. Is there a known incompatibility with Chime onthe Fire 7 ?

It does seem like the Fire7 may have some issues based on some of the comments above in this thread. All I can say is that I know is that LANNouncer works well with the 7th gen Fire HD8 which is what I have. The only other thing I might suggest is an earlier version of LANNouncer and see if that works.

Here is what another user tried:

I was trying the MediaRenderer that used to work but doesn’t give me the custom option for text such as ‘Door is open’.

So I was going to try this route. First, it is installed on the Android tablet and working from what I can tell. Problem is on the SmartThings App. I have installed the device with the device handler and it is showing up. But to set the IP/Port of the Android device, I do not see anyway to do so. In the settings of the device, there is just ‘Off’, ‘Strobe’, ‘Siren’, etc… Image capture, Find sensor… nothing to set IP/Port like i’ve seen in screen shots. If I hit the 3 dots and select edit, there is nothing but the generic location/room.

Any thoughts? And also, can you have the tablet relay to a speaker? My whole goal is to play to my FABRIQ speaker which used to work fine with Media Renderer (DNLA). So if either by going through this android app or directly, I need to find a way.

It sounds like to me that you are using the new version of the SmartThings app. You may have to use the Classic version of the SmartThings app to use this smartapp properly. There, under the Gear icon, you will see where to enter the IP address of your Android LANnouncer speaker.

Can LANnouncer be used to target google homes on the same network?

It only works with an Android device that run an app that listens to commands from the LANnouncer SmartThings device type though software such as BigTalker and WebCore.

So cant communicate to other devices on same network. Could it be done, I’m running another app on an old phone with nodejs but it’s a bit unreliable. I’d hope a purpose made app would work better and it would have all the android/assistant files

It can only communicate with an Android device running OS5 or better. There are other solutions such a using an Amazon Echo as a TTS playback device but I don’t think there is anything for google home.

Lannouncer stops working on my new Amazon Fire HD 10 Tablet. If I have the app open in the foreground it works perfectly, when I switch to Fully Kiosk it also work perfectly… for about 5 minutes then it never works again. I’ve had it working on 2 x Fire 8 HD Tablets for years but it just doesn’t like my Fire HD 10. Anyone got any suggestions?

1 Like

Hi all,

I am trying to make lannouncer works in the background on an android phone, however as long a the app is not shown in the front Android kills it after 10-15 seconds :

2020-04-19 14:22:47.347 23610-23644/? I/LANnouncer SockService: Connection received from /
2020-04-19 14:22:47.352 23610-23768/? I/LANnouncer SockService: Received data: speak=Test+house+automation&@DONE@
2020-04-19 14:22:47.353 23610-23610/? I/LANnouncer SockService: Received Socket Message: speak=Test+house+automation&@DONE@
2020-04-19 14:22:47.353 23610-23610/? D/LANnouncer SockService: Trimmed input to speak=Test+house+automation
2020-04-19 14:22:47.353 23610-23610/? I/LANnouncer SockService: Parsed Commands:[SPEAK: Test house automation]
2020-04-19 14:22:47.354 23610-23610/? D/LANnouncer SockService: Speak Test house automation
2020-04-19 14:22:47.374 23667-23690/? I/SamsungTTS: Synthesize : [eng-GBR-f00] Speed[100] Pitch[100] StreamType[Engine.DEFAULT_STREAM] Caller[10252-com.keybounce.lannouncer]
2020-04-19 14:23:00.213 4813-4963/? W/ActivityManager: Stopping service due to app idle: u0a252 -1m13s241ms com.keybounce.lannouncer/com.keybounce.LANnouncer.SocketService
2020-04-19 14:23:00.631 23610-23644/? W/System.err: at com.keybounce.LANnouncer.SocketService$

The phone is on stay awake with the developer mode, charging, and I removed every option that put an app to sleep or reduce battery usage. I tried to send a message every 5 seconds via a loop to keep things up, I could see ADB working every 5 seconds and still getting the same kill message.

Did anyone have this “Stopping service due to app idle” problem on android ? I could not find helping resource on that on internet.


@NWTony Would you entertain having some help or allowing a fork of LANnouncer? I couldn’t find a code repository anywhere.

I installed LANnouncer on a raspberry pi running android things (so i get Ethernet and don’t have to deal with battery issues…plus I had one laying around) and got it working and launching fine but I had to decompile and modify your manifest (to add required HOME to MAIN) then recompile and resign it. There are other quarks in android things like audio volume that I also would need to modify in app (via AudioManager). I figured I could make the mods and allow them to be shared.

@JPerson: have you ever found a solution to this? I have a Fire HD 10 (9th generation) and would like to get TTS to work. It appears that my device does exactly what you described: falls asleep after seconds and does not come back.