SmartThings Community

Android as a Speech/Alarm Device released! And Updated!

Can anyone help me? I’ve tried installing on a brand new Fire 7, but for some reason I cannot get the sounds to work. I’ve installed the device handler, created device, installed app, configured app. I can see the device in my Smartthings app, but nothing happens when I click the buttons. When I click siren or strobe, it will light up a warning, but no sounds. I see it logs the siren or strobe in smartthings. I’ve made sure to adjust the volume in LANnouncer, and also triple checked the volume on the device. I tried everything on my s9 and had the same problem. Given how many people have had wonderful success, I can only assume I’ve done something silly, but can’t figure out what. I am not horribly versed in this type of “programming” but I can follow directions like a champ. Can anyone ELI5?

I’m not so sure about the Fire 7 but I have installed on a stock Fire 8 (7th gen 2017) and it works. I have summarized the steps necessary to install here, take a look to make sure that you didn’t overlook something.

Thank you so much for replying so quickly! Ok, so I did a full uninstall of devices and handlers and started over following every step in your list. I even have the device set up with a static ip and port forwarding, just in case. The “thing” shows up in the smartthings (classic) app, but still no sounds at all. I also tried to set up a second LANnouncer with the ip from my s9 (again), in case it was an issue with the Fire, but still no luck. When I click the siren or strobe buttons, it shows the alert in smartthings, but no sound, and the rest of the buttons don’t seem to do anything when pressed. This sounds like a really stupid question (but at this point I’m certain only a really stupid mistake on my part is the problem). Aside from the steps listed in your reply above, and linking to smartthings, is there any other program required to make this work on a LAN connection only? I saw many talking about Big Talker, but it sounded like that was only needed for non local connections. Is there something else I need to install? Sorry for the dumb questions, just want to cover my bases before I give up on the idea.

I forgot about this post here from the author of the app. Try updating the LANnouncer apk file to see if that makes a difference.

Alright, I’ve gone to the website directly, used the link for playstore, says installed, no option to update, and the link for “direct download” is broken and gives a 404. In app it says I’m at the current version.

These button may or may not work depending on your Android device but I do know that the “Tone” usually is a good test and it works. The “Speak” button also works for me and it will announce the version of LANnouncer that you are using.

These are direct device handler buttons. For actual TTS (text to speech), I’ve been using BigTalker to send talking messages. When first installing BigTalker, make sure to specify it as a TTS device.

Figured out how to get some pictures! Maybe they’ll help? No dice with the tone or speak button :confused:. I did get big talker installed and configured, but still no sounds on either device.

Screenshot_20190226-103540_LANnouncer|243x500 Screenshot_20190226-103329_Chrome Screenshot_20190226-103031_SmartThings Screenshot_20190226-103027_SmartThings

I see you have your Android port as 1034, if you used the default, it should be 1035.

I wasn’t sure if I needed to use 2 separate ports for the separate devices, so I have the fire 7 set at default 1035 in lannouncer, smartthings and then set as a static ip through the device and also through the router. I did the same thing with the device above, with the exception of changing the port to 1034 in all locations.

*** just noticed the last picture of lannouncer configuration didn’t post!

Everything looks like it’s configured correctly. You could try toggling the “Say Nothing” in the app settings to ON and then try clicking on the “Speak” button in the handler in the SmartThings app.

Unfortunately, still no dice. Oh well, such is my luck with electronics. I do really appreciate all your time trying to help me!

Sorry, but I’m not sure what is causing your problem. I have a few other suggestions about your setup. I see that you have two devices configured, you should probably leave both on the same port #1035 but have different IP addresses for each one. I have two devices and that is how I have mine set up. Also,make sure that you are on the same WiFi network and band (2.4g for example). And of course, the obvious is that your sound is turned on all the way and not going through some Bluetooth headphones or speakers. Finally, the only other thing you might try is a different android device.

I have FINALLY figured it out and now that I have, I feel really stupid. Putting my idiocy out there so hopefully some other poor newbie can make use of it. We are on Google wifi. Each mesh device has 1 ethernet port and are all interchangeable. Our network closet houses the main “router” and a ton of switches to run all the other ethernet requirements. Turns out, smartthings hub absolutely must be directly plugged in, no switch allowed. So, after moving it out of the network closet and plugging directly into a different mesh device, it’s now working flawlessly. So, boys and girls, learn from my mistakes, plug directly in to a router.

1 Like

Must be something to do with the Google mesh routers.

I have eero mesh devices. eeros have two Ethernet ports. Ethernet connection from my ISP fiber optic terminal is connected to an eero in my wiring closet. Second port on that eero is connected to an Ethernet switch.

My SmartThings V2 hub is connected to that Ethernet switch along with several other things in the closet.

Never had any issues.

since updating my device to LineageOS 16 sound effects will not play. text-to-voice still works. anyone else experience this, any fixes? thanks.

Mine is plugged into a switch behind another switch with no problems

I’m also having the issue on my Fire 8HD with lannouncer “going to sleep” in the background. Sounds/Speech quit working after a period of time. I’m running sharptools.io on fully with lannouncer running in the background. Anybody figure out how to stop this from happening?

You can use this with Fully Kiosk, I had the same problem with Lannouncer going to sleep every few hours.

3 Likes

IMPORANT UPDATE
Version 36 is live on the Play Store and the website. You need this version; Google is shutting down GCM (Google Cloud Messaging), in favor of Firebase (FCM). This release moves to FCM compatibility.

Im trying to implement the behavior of a security camera composed of a motion detector, the LANouncer camera trigger, and the play store app “autosync for google drive” to automatically upload any photos taken

Unfortunately the lack of a front camera option is rendering this - potentially very useful - setup quite difficult.

Has anyone had any luck using the front camera in a scenario like this? With or without lanouncer?

At the moment the only solution I can think of is creating a little periscope mirror, but that seems kinda ridiculous given that my fire tablet has a front camera

Thanks for any advice
-Hudson