SmartThings Community

Android as a Speech/Alarm Device released! And Updated!

android
dth_security
dth_voice
tts
project_alerts

#435

There is nothing wrong with the instructions, they are just incomplete. They say to send the command @#ALARM=FILE1, which is fine. But the question I have is how are people sending the command? I currently use WebCore and the only way I can send information to the device I set up is the standard requests of ‘play chime’, ‘strobe’, play alarm, etc


(Mark) #436

I originally posted this to the wrong topic, so I’m adding the link here. Any help is appreciated.


#437

I’m not familiar with WebCore. LANNouncer predates it by quite a bit. But with BigTalker, you can send a Text-to-Speech string to the LANNouncer device. If you preface it (the @# portion), LANNouncer will know it’s a command, not text to say.

See the bottom of http://www.keybounce.com/lannouncer/integrating-with-smartthings/smartthings-installation-steps/ for an example in BigTalker. (Admittedly an older version of Big Talker.)


(Mark) #438

I got it working. Just in case someone else runs into the same issue, I had to delete the SmartApp and the DH and then reinstall them. LANnoucer is now working with both WebCoRE and Big Talker.


#439

Yup that got it working thanks. I found taking webcore out and just using bigtalker much simpler and more reliable.

I do have to start / stop lanannouncer pretty much weekly. Is there anything I can do for that?


(Arn B) #440

Just got this installed and working along with Big Talker. Was pleased to find the alarm’s “BEEP” command works with my SHM Delay smartapp, creating the CHIME sound :joy:

Is there any way to serialize or queue multiple commands (other than Smartapp command delays) so that subsequent commands execute after the completion of the prior command?

For Example http://192.168.0.108:1035/?ALARM=CHIME&SPEAK=hello&@DONE@
What currently occurs (for me) is Chime and “Hello” speech occur simultaneously, I want the chime to sound and complete, followed by the speech.
Also tried the following without success http://192.168.0.108:1035/?ALARM=CHIME&WAIT=TRUE&SPEAK=hello&@DONE@

Also same result for multple commands found in manual
http://192.168.0.108:1035/?SPEAK=@|ALARM=CHIME&SPEAK=Hello%20daddy&@DONE@


#442

There’s no way to do that yet. I could build it in, but have been busy on other projects.


#443

I don’t have that problem. Mine’s been running literally months. In a closet, hard to get to. You might want to check your network and power settings, as in the online manual.


#444

Yeah I’ve seen other people mention it as well and mine has been flawless until recently. I wonder if my android updated.

I’ve seen you mention File2, File3 commands a couple times. I know there is no true ‘pro edition’ yet as you explain on your page, but are the 4 extra files available somehow?


#445

Yeah, if you’ve got the Premium version, you’ve got the extra files.


#446

Just got my two Fire tablets set up with LANnouncer and Big Talker, and it is AWESOME! Directions were solid and it only took a minute or two, thanks for the legit app. I’ll have to play more with some settings to polish it off, but for now I at least know when the exterior doors open and close (mostly so I know that my kids aren’t leaving without me).


#447

I’m having a setup issue. I thought I followed the instructions step by step but I must have missed something. I’m good all the way up to Lannouncer device listed on my Things. I can go in there an push alarm etc and here the tones on my droid. I can also sent a tone to it using http://192.168.0.158:1035/?ALARM=CHIME&SPEAK=hellos&@DONE@… so no issues there. The problem is when I go into Big Talker. It does not list my device there as an available speaker. What am I missing? Thanks.


#448

With each install of Big Talker, you can either set it for Music Player (Default) or when you select Configure, you set that to off which will then allow speech synthesis devices to show.

You can leave the version that you have already installed which can be used for your regular external speakers and then goto Marketplace and install a second version of Big Talker for Speech Synthesis (turn off option in Configure).


#449

Well that was an easy fix. All set now. Thanks for the response WB70.


(Arn B) #450

Thanks for this great app!

Using app on a Kindle Fire 7. Having an issue when LanNouncer is set as a Siren in Smarthome, and an intrusion occurs. The device generates a siren sound for perhaps an 1/8 of a second, then stops and the screen goes to the Home page. I have to bring LanNouncer to the foreground to get it working again. When I attempt to take a look at the command log it’s empty. However, when I look at the Active Apps before tapping on the Lannouncer app, the following commands are displayed:

FLASH(STROBE) Continous
SOUNDALARM SIREN:Continuous

My device does not have a flash. I assume ST SHM issues the “Both” command to the device, setting off the siren and strobe. Also confirmed “Strobe” is the cause by going into the ST Device, then tapping “Strobe” tile, boom, back to the Home Screen on the Kindle.

For now I’ve removed LanNouncer as a SHM Siren device.

Any ideas other than modifying the DTH to kill the strobe on the both command? Or perhaps set an option in the Android app to “Ignore Strobe Command”.

FWIW: I also use the Fully browser that displays an ActionTiles page, and installed the “WI-FI keep alive” app from the Amazon app store


(Tony) #451

I’m a first time poster to the forum. I’ve read through this thread and with all of the changes and updates my head is spinning. I wonder if someone could update or point me to an thorough set of installation instructions to get this thing running. I have an android tablet running version 5.1.1 and an amazon echo (and obviously Smart Things). I would basically like to get voice notifications and hear them on the echo. I’m pretty confused as to if I need Lannouncer, Big Talker, AskAlexa, or some combination of them all. Thanks for any help


#452

Let me try to help. This is summarized from http://www.keybounce.com/lannouncer/

  1. Get and install LANnouncer from the Play store
    or directly from this link: http://www.keybounce.com/bin/LANnouncer.apk

  2. Once you have it running on your Android, look for the IP address (something like 192.168.1.xx) and the port # which is usually 1035

  3. Select All and Copy this Device Handler
    You will use this code to create a new speech device for SmartThings

  4. Log into your IDE https://account.smartthings.com

  5. Once logged in, click on a link My Device Handlers and then click at the right a green button “Create New Device Handler”

  6. Click on a link that says “From Code” and paste what you copied earlier into the field below.

  7. At the bottom, click on “Create”, then at the top right button, click on “Save”

  8. Click on the button that says “Publish”, then select “For Me”. You have now created a Device Handler

  9. Back on the main screen, click on a heading link “My Devices”

  10. Click on a green button “New Device” and configure it with a name such as “Android Speaker”

  11. In the Network ID field, just enter any number. Don’t worry about some of the other fields except for Type. Click the button underneath it and select LANnouncer Alerter (device type) that you created earlier. Probably near the bottom of the list and then click on the blue “Create” button.

  12. Now go to the SmartThings app and look for the newly created Device called “Android Speaker” under your “Things” tab

  13. Select it and click on the gear icon at the top right. Enter your IP address and Port# from the installed LANnouncer app on your Android device. Then press Done

  14. Now test it by clicking on the “Tone” or “Speak” tile. You should hear something come out of your Android device. To hear it on your Echo, you’ll need to connect your Android device via Bluetooth to the Echo.

  15. Now install the smartapp BigTalker 2 ([Release] BigTalker 2.x)

  16. When first configuring BigTalker, choose Speech Player as your device.

With BigTalker, you can configure Chimes, Sirens, and Text to Speech synthesis. A list of special commands can be found here: http://www.keybounce.com/lannouncer/commands/

I think that’s it. Let me know if this works for you. I kinda did this from memory.


BigTalker 2.x send to a BT speaker or Alexa Dot
Alarm Monitoring & Audible Alerts?
[RELEASE] LANnouncer with IFTTT
#453

Always login to https://account.smartthings.com as this will automatically redirect you to your correct shard.


(Tony) #454

Jim,
Thanks so much for your help. I’m doing as you said but when I get to the “New Device” step it asks for a network ID as a required field. What do I put in that field? I really appreciate the help.


#455

Put any number, it doesn’t matter. I’ll update my instructions.