Amazon Echo -> SmartThings -> Harmony; Worked for a year, now doesn't work (July 2018)

As Side note: Thankfully Cotana works! :slight_smile:

Having the same issue and it’s not working how annoying. After 30 mins deleting and re-adding its not working at all, it discovers then as scenes.

Interestingly I have a google home mini and this works fine so deffo a SmartThings to Alexa only issue.

I’m not using Harmony through SmartThings but I am also getting “hmm, I’m having trouble reaching SmartThings” when triggering thermostats - but the action still works perfectly. So not limited to Harmony it seems. Very annoying!

I am having the exact same issue. Spoke to support and they just said its a known issue and told me to bypass Smartthings for now. I am using harmony directly through the echo for now which is a shame since my harmony activities used to trigger lighting.

A couple people have said they’ve spoken to support and support has said it’s a known issue. If so, why does http://status.smartthings.com show all green and no issues reported?

Also, where do we go to open a support ticket on this issue? And to someone who has spoken with support, did they acknowledge it as a smartthings issue or did they say it’s a Logitech issue?

Thanks

Looks like someone else is having an issue as well:

I haven’t tried mine, yet but if you’re all having issues, then you all need to reach out to ST support and log a ticket so they can correlate it.

  1. Samsung should role back everyones update untill they have problem resolved.
  2. I wounder if we can set up st and ifft up to flood the suport server with new request ticket emails every second to fix st system. I think i will look into this tonight. Be kinda funny if we crashed samsung server. We are not there test monkeys!!! Stupid silo hardware companies.
  3. I wish there was a PLC computer for home automation, i want stability!!!
  4. I will be happy when a better home automation hub comes out, better features, stable, easier to program, hardware config file.
    I wish my hub became glorified papper weight!!
  5. How is smartthings smart? What a dumb name!
  6. Home automation needs a well thought out Standard, so the silo hardware companies stop breaking our systems. Tired of this stuff beeing so fragile. Everynight I come home from work I wounder what part in my eco system will stop working. Fisher Price cheape. What rickity piece of crap.

Very disappointed SAMSUNG! UNACCEPTABLE!! Get your Sh*** togeather. Role back the update TODAY, while you figure out a fix!!! Stop making the problem the communities problem!!!

1 Like

My Harmony hub works with Alexa but when I try to connect to SmartThings I get an error on the web page that tries to login (doesn’t even ask for username password). Is this the issue you all are talking about?

After over half hour hour wait with samsung cs. They say its amazon. Powered up/down echo. Still same problem. Now on amazon cs phone call which will probably be a complete waste time. Stuck in the silo vortex of everyone pointing fingers at each other. Saying the problem is not on there end. Amazon wants me to hard reset my system, but not right now because there servers are having problems connecting new devices.

You people are crazzy. I am not your test monkey!!

  1. Give us the ability to back up our systems in 2 ways:
  2. Hardware config file backup/load functionality.
  3. Program file backup/ load functionality.
    I will absolutely never hard reset my configuration with 100+ devices… i will not reprogram from scratch, i have better things to do with my time.
  4. Allow users to prevent firmware pushes. Stop breaking my system!!!
  5. Fix your software validation process before pushing to users. Truely validate your firmware. Man if I did this to my customers, i would not have a job/career. My employer would loose therr customers.
    Such cheape micky mouse crap… what ever happened to taking pride in your work and doing the job correctly!!

Guess i should figure out how to spam st support ticket request email server. This should be fun…

I have the same problem with Alexa complaining, "“Hmmm, I’m having trouble reaching SmartThings” when calling up a Harmony Hub activity. This has seemingly started since the last SmartThings hub firmware update. I’ve written to support@smartthings.com with a full description of the problem (and the fact that it works just fine with my Google Home.) When I wrote them, I also included a link to this forum post, so that the SmartThings support folk can see that others are having this same issue. I remember a similar issue last year, and it took a bunch of people writing to support@smartthings.com to let them know about that issue. Once they received enough reports, they posted an official announcement about it (and eventually solved it. Back then, I think it was an Amazon API-related issue that had to be worked out with SmartThings.) So, if you haven’t written to support@smartthings about the current problem, please do, as that will help raise the awareness to them. And, hopefully, we’ll receive an official announcement about the issue, and hopefully, soon after, a fix.

1 Like

Having the same issue, I can’t jump over to Yonami or another platform since I’m using Webcore to run presence & scheduled routines to control Harmony hub through Smartthings (still working). With 2 hubs, I use the Harmony Skill to control the 1st hub and Smartthings to control the 2nd hub, both are now broken using Alexa.

Hope they get this fixed soon.

I just followed the advice of @kalel and emailed support@smartthings.com and linked to this thread. If you haven’t already done so, please consider doing the same. It appears we need critical mass for them to research the problem. Thanks everyone, and I’ll let you know if I hear anything back.

2 Likes

Well, I’ve been absent from the community for a pretty good while because my setup has been pretty stable. I hope we’re not headed the other direction.

I’m being affected by the same issue. One idea I had is to create a virtual switch in ST that is just an “alias” for the harmony switch. My hope is that Alexa will discover this virtual switch and provide me a temporary work around.

I opened a ticket with Smartthings 3 days ago and not a single response yet. Quite frustrating.

Adding my name to the list. For me only “Turn on Apple TV” seems to work. All the other activities fail the same way as described in this thread.

Finally heard from support. "It’s broken because you don’t have the integration installed. Here’s a link to setting it up "… As opposed to basic research to see there’s an actual problem. (I waited a few days before removing it and trying the alexa skill side support was no show)
I waited over a week to have the two minute response with no effort to identify the problem. AARRRGGGGHHHH.

I just tested the virtual switch idea and it works.

I built a virtual switch and then created a quick and dirty core piston to trigger the Harmony activity when the virtual switch is turned on. I had Alexa discover the virtual switch. I gave the voice command to turn on the TV and the activity ran as expected.

I’m now going to do away with the piston and create a handler to manage this cleaner. It sucks that we have to resort to this type of rubber band and toothpicks approach.

Do you mind sharing the handler when you complete it? It would be greatly appreciated here.

I think I got a little ahead of myself. :roll_eyes:

It may well be just as easy to create a routine or Smart Lighting rule with out getting all fancy pants.

So , just received a response from Samsung/Smart Things, Finally!!!

They acted as if they had never heard of this problem (go figure)…So it was the usual response, take the batteries out and hard boot the ST Hub,and reset skills,Yada Yada…Still NO workie!!!

I think I am just about done with this ST Hub thing and going to go back to my Universal Devices ISY994ZW.

Which seems to be working flawlessly by the way,!

Universal Devices got back to me to help in just hours vs Samsung’s 3 days to get back to me!!!