All of a sudden my locks are talking, but they don't listen. HELP!

I have two locks on my front door. Both are using rboy’s DTH and smart app. They are:

  1. Schlage FE599 Z-Wave Lock.
  2. Yale T1L Deadbolt

Using a v2 hub. Ever since I installed them I haven’t had any issues besides the batteries in the deadbolt, which is probably expected since motors and all. Z-Wave repeaters close-- one is on the adjacent wall-- maybe 3 feet away.

Anyway, about 3 weeks ago, the dashboard showed them offline. But not consistently. They would occasionally report status… But they would not take commands. All unlocking and locking had to be done at the lock. Both of them had new batteries so I know that wasn’t the issue. I ran Z-Wave network repair, no change. I hadn’t updated the DTH/app for a while so yesterday i started with that to no avail…rboy suggested excluding them and re-pairing. I did this and now they consistently report status, but they still will not accept any commands. I tried to change one of the unlock codes - nothing. But if I unlock either of them at they keypad within 3 seconds i get the notification on my phone.

I suppose I could reset both of them back to factory, but I’d rather not do that just yet. I’d rather figure out what the !@#$ is going on so maybe if it is the result of something i did in the overall setup I will learn from it and not do it again…

Thoughts?

tagging @RBoy

2 Likes

Now I’m worried.

I excluded both locks using the app on the phone and the general exclusion utility. - Success. They no longer were in the app or the IDE.

I reset both locks according to factory instructions.

I temporarily deleted the rboy handler so that when I paired them up they would find the stock device handler.

I paired both of them. Success on both counts.

They don’t work. Either of them. No lock. No unlock. No code entry. Not reporting status correctly either.

I know stuff can break, but what are the chances that both of these locks would choose to die at the exact same time. Nothing else in my device list has any problems…

Hopefully someone will say, “oh you forgot to do xyz” and everything will smell like roses. Kind of hard to live without these once you get used to them.

Thanks in advance

That’s bizarre for two different locks to stop working at the same time. Have you tried resetting the hub?

You should contact rboy support, but there were problems recently with older Z wave devices, which both of those are, so that may be the issue.

@maddie

1 Like

We’ve been doing some investigating and have a found an issue that impacts some older devices with the new hub firmware. It’s been reported to ST and they’re working on a firmware patch. Not sure if that’s impacting your setup.
If it was working after the first time you paired it but not the second time then it could something with the mesh, maybe a bad intermediary routing device (repeater).

2 Likes

Well, it hasn’t worked for several weeks. The only time it worked was since I installed and set them up a little over two years ago. No problems at all until a couple of weeks ago. All I have been experiencing since is various versions of outbound communication from the locks. But yesterday I didn a full reset on both and took all of the RBoy off of my account. The thinking was that for all intents and purposes they were new devices. They paired instantly, and were recognized for exactly what they were. The IDE showed they were associated with the stock Z-Wave lock DTH. At this point I had not added any unlock codes to the devices. But just as before they wouldn’t respond to anything sent their way. No lock or unlock commands. No addition of any codes. Reinstalled the RBoy handler and app. No change. When I look at the IDE, both DTH’s correctly and completely identified what it was talking to and the list of all of their respective features.

With regards to a bad mesh - How would I know? I had a few orphans which are now gone. Pretty much my whole ground floor is wired with Z-Wave. No bulbs, all in wall dimmers/switches - one talks to an outlet, the rest are talking to fixtures. They work fine, and there are 3 of them less than 4 feet away and another 3 directly across a 15 foot open space.

What kind of debug tools are there? Anything like a traceroute? I have yet to reboot the hub. I’m doing that as soon as I post this. I remember reading somewhere that if it stays down for more than 15 minutes it rebuilds the whole lookup table?

Does the V3 hub use the same firmware? I was thinking I might swap this one out. Nothing I do is having any effect on these locks and I can’t see both failing at the same time.

Nothing? No gems of wisdom?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.