All but one Z-wave devices with status HUB_OFFLINE, Unavailable in App, breaks Alexa, otherwise perfectly functional

Things have been rock solid for the most part until I changed out my wifi router last night, which is weird, since the Hub is plugged into ethernet.

All of the affected devices are wall switches of one brand or another. The one working device is a Z-wave cord switch that was controlling the Christmas Tree.

I can find very little about what HUB_OFFLINE means regarding the status at Most references are to “Hub offline” meaning the hub is offline. This appears to be a Z-wave state.

I’ve read a dozen or so posts where the solutions is to turn off Device Health in the app. That doesn’t appear to fix anything, just mask it. From what I can tell, the devices are 100% functional. I can turn the lights on and off with the app. The only thing I can’t seem to do is control them with Alexa any more. It reports back that “Bedroom isn’t responding” or “Porch Light isn’t responding” but I can turn off and on the one working light, the Christmas Tree, no problem.

I have rebooted the hub, Repair Z-Wave network in the api web interface and also disabled and enabled Z-wave in the same place.

I found one community discussion of a similar problem that recommended going into the discovery mode and turning the switches off and on again. That didn’t have any effect.

I tried removing a device. That doesn’t work well on a good day and I wasn’t able to make it work today either.

The hub is v2 running firmware 000.019.00019.

Any ideas?

Chris, curious if you have any details about your router change. I had a similar experience when I enabled some new settings in my Netgear Orbi mesh Wifi system. Specifically, I turned on Implicit BEAMFORMING, MU-MIMO, and Fast Roaming. Shortly afterward, my whole Hub went offline, but I was walking out the door for a 2 day trip and didn’t relate those two events at the time. When I got back, I rebooted the hub and got it back online, and had a wide variety of devices reporting “HUB_OFFLINE”. Device type is inconsistent among those reporting, but includes most of my battery operated Zigbee motions sensors (several Iris branded and one Smartthings), a couple of Z-Wave motions sensors, a Z-Wave light switch, and maybe most odd of all, my Sonos Speaker. All of the devices actually still function just fine when operated via the app, but Alexa reports them as “not responding”. I have also tried all of the troubleshooting out there, with no joy.

This just happened to me after I did a zwave repair. I wasn’t able to control anything with the echo. The only way I was able to fix this was to unpair every device and repair it. I have a lot so it was a pain and took a while to do.

Hi Kevin, very interesting. The new router is also an Orbi. I haven’t turned on beam forming, but then again I haven’t explicitly turned it off either. I would assume it was on be default. Were you able to turn off the beam forming and make the problem go away? I have a battery powered Z-wave motion sensor somewhere that I intended to install in my garage. Maybe I should add it and see if it comes online. Chris

Hi Joe, I was surprised that a zwave repair didn’t do the trick. It seems like it would be for things like this. I have basically conceded that I was going to have to do them all one at a time, but wasn’t able to get the first couple I tried to release from the network. I remember having a lot of trouble removing the wall switches and dimmers when I upgraded from a v1 to a v2 Smartthings hub. Chris

Oddly enough I also swapped out my network for a ubiquiti router and a couple ac pros. I’m experiencing the same thing. I had the hub unplugged from the network for the whole day. I see the same hub offline for all my switches. I havnt done any tinkering but I definitely don’t want to repair all of them. I’m going to send an email to support this afternoon.

Just changed the device type and then changed it back. Switch is back online. Give it a try, still sucks but I can fix this in 15 min now.

I did get it working again after switching the Orbi settings off. I followed @JDRoberts instructions in the below post for “Healing the Zigbee Network”. 6 hours after following his instructions, everything still showed “Unavailable”, but when I got home from work today everything was good (~18 hours). Previous to finding JD’s solution, I also had luck with 2 of my 10 unavailable devices doing what Jay did, changing the device type. But strangely that worked for one of my Iris motion sensors, but not the other 5 identical ones. Hope you get everything back in order as well.

1 Like

Well, tonight all the devices were back ONLINE and Alexa is once again turning everything on and off. Not sure what caused it to self heal, but it took nearly 36 hours. Thanks for all your comments!

1 Like

Likewise. I only changed that one device type and left the rest alone. By the time I got home, all was working again. Mine total time was around 24hrs.