Alexa Routines & Simulated Contact Sensors stopped working (17 April 2020)

If anyone has noticed SmartThings launched a new skill on Amazon Alexa late last night. Originally you could use a simulated contact sensor to trigger a routine in the Alexa app so you can control things that dont have native SmartThings support but Alexa support. During this new update this control has basically been broken. You can still set a contact sensor as a trigger, but Alexa will no longer actually trigger the routine.

This has resulted in the loss of control for a few of my devices.

Has anyone else experienced or noticed this issue?


1 Like

Edit: I see now that I’m using the SmartThings Classic skill, not the new SmartThings skill. Since I don’t have a Samsung TV or smart vacuum, it doesn’t sound like there’s a good reason for me to switch…

I use virtual contact sensors to trigger Alexa routines with door open / door closed announcements (so I can disable them when we bring a sleeping kid in from the car). They’re still working fine.

1 Like

I have set up a virtual switch, bur I am now curious to set up a simulated contact sensor. I’m new to ST (thankfully left Wink) and would appreciate any guidance. Thanks.

You should be able to follow the instructions in the community FAQ. The warning shouldn’t apply to you since you never used the old skill.

(The topic title is a clickable link.)


I have the same issue. i run Xaiomi contact sensors and motion sensors on ST. after this nothing is working. i can still create the routines and can see all the sensors but its not triggering the lights and other devices. i can see the contact sensors working both in smartthings and also in alexa but the alexa routines are not being triggered. did you find any solution to this ?


1 Like

I am having the same issue. I updated my smartthings app yesterday and noticed that my virtual contact sensors that I setup on smartthings are not triggering Alexa routines anymore even though alexa can “see” and registers the opening and closing of the virtual sensors. Any solutions to this?

1 Like

@JDRoberts I just posted my issue above but noticed that you mentioned to another poster that they won’t have the problem because they never used the old skill. Does this mean if I remove the ST skill on alexa and reinstall, my virtual switch will start triggering the routines? It seems like the skill however was updated automatically on my alexa app a month ago and there was never an issue until I updated my smartthings app and Alexa app yesterday.

@TheModernShane were you able to find a solution ?

Unfortunately, no. Once you have the problem, it seems to come and go on its own, there’s no combination of steps we as customers can do to fix it. :disappointed_relieved: we just have to hope they find a fix soon.

When I said the warning didn’t apply in the previous post,
I meant the warning that you wouldn’t be able to go back to the previous skill. Not that you wouldn’t have any glitches.

@JDRoberts do you think there is any solution to my routine? It involves four different apps: ring alarm, ST, Alexa and Simplecommands. The routine is setup so that I can arm and disarm ring using ST. Here is how it works.

  • run routine in ST “arm away”
  • among other things it does, the routine also turn ON a virtual ST switch.
  • Alexa sees the virtual switch turn ON
  • Alexa routine now runs a scene that was established via Simplecommands called “I’m away in Simple commands”.
  • simple commands app now triggers an “arm away” mode on ring alarm.

I have this routine since among other things, it also locks all the doors etc using ST. Hence why such a long complicated routine. But now with the virtual switch not working, the whole process is broken.

If physical sensors work and only virtual ones do not, then there are some things you can try, but they are pretty clunky. (The topic title is a clickable link.)

If physical sensors don’t trigger Alexa routines either, than I don’t know of any alternatives unless you can use IFTTT or webhooks. :disappointed_relieved:

@JDRoberts thanks man! I hope they fix this issue soon.

1 Like

i have been trying all weekend and still without success. i have also tried to create a new alexa account , trying with virtual switches but nothing is working. the Alex routines are not being triggered. this sucks since i have 300 euro + worth of sensors in all the house between contact and motion sensors. i hope this is fixed

1 Like

I’m having the same issues with Simulated Contact Sensors since upgrading the Alexa Skill for SmartThings. I’ve been using this code:

bjpierron : Simulated Alexa Switch

I had “wrapper” routines in Alexa to turn virtual switches in ST on/off to extend functionality for devices that only had Alexa skills. I was able to find new IFTTT integrations for 2 of 3 of my skills, but I still have Govee Light Strips that are only useable with Alexa, not SmartThings and Homekit via HomeBridge. Please let me know if anyone finds a solution.


1 Like

Engineering is aware of the problem and is working on it, but no estimate yet of when it will be fixed.

I might have found a fix … although im still testing. its not the best of fixes as i had to completely reset the Smartthings hub and restart all over again. i did this late in the evening so i still need to test but i added a virtual contact switch and Alexa routine is working when switching on and of the switch from smartthings. lets hope for the best

That’s been tried before


1 Like

update on my last post, after the smartthings reset both a virtual switch and also the contact and motion sensors are triggering the Alex routine !! its a lot of work to reconfigure but at least looks to be working. before doing the reset disable the smartthings skill and remove the smartthings devices from alexa.

SmartThings engineers have said that there is nothing individual customers can do one way or the other to solve this problem. They are working on it on the platform level.

Multiple people have reported in other threads that they have not done anything at all with their system but that Alexa routines did indeed start working again in the last 12 hours or so. :sunglasses:

I think this is a situation where the main thing that is needed is patience. If you want to reset or rebuild your system, you certainly can, but it should not be necessary for this particular issue.