Aeotec nano switch DTH?

Sorry to jump in on this, but I was about to make a nearly identical post.

I just installed the Nano Dimmer ZW111-A, and it took a bit of work to get it going. The physical install couldn’t have been easier, but adding it to SmartThings took three tries for it to “stick”. The first two, it just vanished on its own after a few minutes. After that, I had to use Z-Wave Tweaker to set some parameters. So the physical switch and the basic handler in SmartThings is working.

My only problem is, when I added it to Google Assistant Home Control, the device appears but will not respond to commands. It works in the ST app, and I had no trouble getting it added to Assistant - it just doesn’t respond to assistant.

Is this because it’s using a very basic device handler?

Hi Jamie,

We got a confirmation that custom handlers are not available for the Nano series yet but they’re working on them. In the meantime, both switches and dimmers should be recognized correctly with default handlers.

If these are still too big, you may check out the smallest micro relays of them all which are also cheaper and in many way, more advanced (they also have custom handlers ready for you):

1 Like

This is probably a question for SmartThings programmers since none of the Z-Wave devices can communicate with Goggle Home Assistant directly, it all goes through ST-Google cloud communication and scripts.

Thanks @TheSmartestHouse. I’ll take a look at the Qubino. I’m mainly concerned about a particular application I have, where there is a 3 gang box with 6 romex cables coming in. I’m sure its not a box fill violation, but its pretty crowded in there. The other place I’m looking to put the Nano is a single gang with 2 cables coming in. There seems to be enough room in there for the switch.

So still a big n00b with ST, so just want to make sure I understand you. When you say default DTH, will ST recognize the nano when I include it or will I need to do something in the IDE with the Type?


If you want to put in more than 1 micro switch in that triple gang box, you can use a double micro switch, the Qubinos are sold out but the Vision could work and it would automate 2 of the switches/lights instead of just one:

The nano switch will be recognized by SmartThings as is, no need to log into IDE at all. Just click Add Thing and activate the switch once ST is looking for it. It should be recognized correctly as an on/off switch.

I have installed one of the nano switches, and I thought I’d provide some feedback for anyone else looking at these. As I mentioned above, I am installing the ZW139 version of the nano.

The application is a 3-way lighting circuit that has two 75-w equivalent Cree LEDs on it. The circuit is wired like the line-switch-load-switch-1 in the GE wiring FAQ. Not being an electrican, I was clueless on how to wire this up (or really any smart switch, as this thread shows). So I emailed Aeotec support and received a reply in about 12 hours as how to wire it. Here is a diagram of the orginal 3-way wiring:

Here is how the Aeotec CS told me to wire it:

The physical installation wasn’t to difficult. I used the back of a screwdriver to push the wiring bundles back into the box as far as possible after I was done with each one. Here you can see a picture of what the nano looked like wired up with the toggle switches put back in place:

Inclusion & ST:
After turning power back on and pushing the action button on the nano to include it, it showed up as a standard Z-wave switch in ST. I had a slight hiccup initally, because local control at the toggle switches wouldn’t work. I could turn the light off and on with the app, but not at the switch. I was alittle worried that I had done something wrong. The instruction state the nano can automatically detect what circuit it is in by flipping the local switch once and waiting 2 seconds. Well I did that and nothing… I don’t know if there is a time window after its powered on or included that you have to do this, but it did not work for me. I was about to download the Z-wave tweaker, change DTH, etc to get the right mode on the nano. However, further reading of the manual said you could put the nano back in automatic detection mode for S1 by pushing the action button 4 times. I did that, flipped the local toggle switch once, and everything worked from then on.

Then, for no real reason I can tell, I removed the nano from the network and re-added it in secure mode (two action button presses instead of one). The nano showed up a Secure Z-wave switch in ST. Have had no problems with it over the last ~48 hours.


  • It is small. A lot depends on the volume of your switch boxes. 3-gang boxes can vary from 44 to 53 in^3 for example. However, with diligent attention to wiring routing and wire length, it fit into my box (with four 14-2 and two 14-3 romex coming in) with some room to spare.

  • Cost: So z-wave plus switches are usually $40-$50. The add-on/companion switches are ~$20. So for 3-way and 4-way situations the nano has the potential of being a cheaper solution, since you only need one per circuit.

  • And for the one that really matters to me, it was the only solution that fit my specific use case. The nano was actually my third choice/attempt at automating this light. I first tried a Leviton DZ15S. However, my wife did not like the look of the paddle style switches mixed with the existing toggles. As I was not about to replace the dozens and dozens of switches in our home in one fell swoop, WAF kind of tanked this option. Knowing GE has toggle switches, I was all set to get some of those. However, I had two other requirements: Lt Almond color, and Zwave plus. While GE has one of these switches on their product list, I couldn’t find it anywhere. I could get a toggle and z-wave plus but only in white. Or I could get a older toggle in Lt Almond, but not z-wave plus. So the nano (or similar wire-in) was the only way I could get a Lt Almond, Z-wave plus, toggle light switch.

Only two I can think of.

  • Noise: There slight “click” of the rely that you can hear whenever the nano is used. Its not so loud in our house that has computers, receivers, refrigerators, washing machines, etc going most of the time. However, to say its not noticable would not be accurate. This will obviously come down to personal taste, but for me, not a big distraction.

  • Delay: There is a slight delay when you use the local control before the light will react. This isn’t uncommon with some automation switches, especially that ones that wait to see if you doubled-tapped before reacting. However, it is fairly significant for something you’ve become used to working instantaneously. I haven’t done anything remotely scientifically, but it feels like a solid second lag.

Hope this helps anyone looking at this product. Overall, I’m happy with them and plan on using them (or the dual variety) in the future.


1 Like

I had a similar problem… a year or more ago I changed all the switches and sockets in my kitchen area to be Legrand Adorne.

And I sure didn’t want to undo all of that to get ZWave inserted. I chose to use the Aeotec switch and after getting it all wired and joined to my network, I found that the 3-way physical switch part didn’t work. I reset it a thousand times, I put it into “self determine” mode a thousand times, I used Tweeker to set it. Nothing cured it until I replaced it. The 2nd Aeotec switch worked perfectly, first try.

I removed the wires from S1 and used a jumper wire, giving me full faith in the conductivity of one 6" piece of copper. Didn’t work. That was when I started to suspect the physical Aeotec.

The slightly ironic part is I then added an Aeotec Multisensor 6 to the Kitchen area and now I never touch the beautiful Legrand switches at all!!

That’s kinda been my philosophy though… If I’m touching a switch, or reaching for my phone, I’ve done Home Automation wrong.

Sadly, Home Automation just isn’t that reliable yet. Especially with SmartThings and it’s relationship with the Cloud. It feels like something gets dropped on some device, every day. I have 65+ ZWave devices and therefore, even a 1% failure is going to be noticed every day.

I have 3 Zwave Controllers/Hubs on my Network, with only SmartThings using the Cloud. Both of the other Controllers/Hubs are entirely local and when I must reach for my phone, and pick an app, (3 to chose from) if I pick the Local apps, vs SmartThings, responsiveness is better, naturally, and although reliability is twice as good, that’s still leaving 0.5% failure. Enough to see at least every other day.

Difficult to recommend to my non-tech friends and acquaintances. Reliability is noticeably off, Delays are noticeable, costs are too high to do en mass, therefore setup is spread across months if not years, and setup is hard for “us - the early adopters” - near impossible for “second adopters” and so I read messages from them as they give up.


So I added another one of the nanos and things have not gone as swimmingly. The inclusion seemed to work fine, ST recognized the nano as a generic z-wave switch. However, no matter what I do the app shows the state of the switch as “On”. I tap on the switch in My Home>Things and turn if off, then go back to My Home, and it shows on. I can still actually turn the light on and off in the app, but the state stays “On”. I’ve did a z-wave repair and have excluded and included the switch back a couple of times, but the same behavior. Any ideas anyone?


I too am having the same issues. Were you ever able to get them resolved?


I just installed one of these switch an seem to have everything up and running but i’m running into an issue where the app is not detecting the wall toggle.
Lights turn on and off etc but ST smartthings does not detect the physical state change.

So if i turn but if i turn the light on with smartthings app, the light turns on and the app updates as light being on, but when i toggle the wall switch to turn the lights turn off, ST doesn’t update the app and show the lights going off.

My other older aeotec switches update ST app with any physical walls switches.

Any idea’s, issue with device handler or switch setup?

I too have been unable to find a custom DTH for the Aeotec Nano Switch. I just installed the energy monitoring version, ZW116 and am using the generic Z-Wave Metering Switch DTH.

My trouble is that the wattage does not auto report. The power usage will remain the same until a manual refresh is called. I do not have a dumb switch hooked up to it. I’m just using it to monitor energy usage.

I’m wondering if there is something wrong with the switch or if it is just a factor of the DTH.

Have you found a solution to your issue @xdreamwalker? Looking to solve the exact same issue.

I have not. However I haven’t been able to put much time/effort into it yet. For now I am just using webcore to refresh it every 60 seconds while it’s on.

@xdreamwalker and anyone else who comes looking for a solution. After reaching out to Aeotec, I discovered that the default frequency for instant power reporting is set to 300 seconds. This is set in the default Z-Wave Metering Switch device handler that SmartThings uses for this device. Support recommended I change parameter 101 to 15 (Report everything) and parameter 111 to 240 (report every 240 seconds). My dilemma is that 240 seconds is too long to get a realistic idea of what a device is doing at any given time. I couldn’t get the default DTH to work so I took another device handler I had for the ZooZ plug I have and modified this to do what I want. It also allows you to set these two parameters in the options. Let me know if this works for you as it’s still very much a work in progress.

1 Like

I’ll give your handler a try later this week.
I wonder if the Z-Wave Tweaker by @zcapr17 would help us with this.

I haven’t used it yet, but bookmarked it a while ago. I’ll have to do some reading. I’d like to have the nano switch report at least every 30 seconds.

The problem is that it does work and successfully changes the parameters, but it doesn’t work after you change it back to the default handler as the incorrect values are hard-coded in and set on load. I looked at this option as Aeotec recommended it and found it didn’t work.

I changed mine to your handler and it does now report every 10 seconds. So far so good. Thanks :+1:

I’ve made a few more changes to the handler. I added led control and removed a lot of the unnecessary code. Over time I’ll be adding some more of the parameters I can test on my device.

1 Like

Any idea why the on/off function in the app doesn’t work any more? I check the log and there is this line: “Switch is disabled”. I did an exclusion, reset, and readd but the problem is still there.

Look in the settings and there is a setting for disabling the on/off functionality. It should be set to off by default. I set this up since I use mine for a dishwasher and wanted to prevent the dishwasher from getting turned off.